summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-02-09 19:21:12 +0000
committerMike Gilbert <floppym@gentoo.org>2013-02-09 19:21:12 +0000
commit565630333fcc9d5b7ea16144a963a4328279f014 (patch)
tree10b4203d0d59ddf47e24f422a2184b5da0d8216b /dev-vcs
parentVersion bump. (diff)
downloadgentoo-2-565630333fcc9d5b7ea16144a963a4328279f014.tar.gz
gentoo-2-565630333fcc9d5b7ea16144a963a4328279f014.tar.bz2
gentoo-2-565630333fcc9d5b7ea16144a963a4328279f014.zip
Version bump, bug 456344. Depend on <mercurial-2.5 due to compatibility problems.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog9
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.7.ebuild78
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild4
3 files changed, 88 insertions, 3 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index 0666eb32f7fd..d247cc2886cb 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.30 2013/02/09 19:16:01 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.31 2013/02/09 19:21:12 floppym Exp $
+
+*tortoisehg-2.7 (09 Feb 2013)
+
+ 09 Feb 2013; Mike Gilbert <floppym@gentoo.org> +tortoisehg-2.7.ebuild,
+ tortoisehg-9999.ebuild:
+ Version bump, bug 456344. Depend on <mercurial-2.5 due to compatibility
+ problems.
09 Feb 2013; Mike Gilbert <floppym@gentoo.org> tortoisehg-9999.ebuild:
Convert to distutils-r1.
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.7.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.7.ebuild
new file mode 100644
index 000000000000..b2d49bf2b91c
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-2.7.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.7.ebuild,v 1.1 2013/02/09 19:21:12 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit distutils-r1 eutils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://bitbucket/${PN}/targz/downloads/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-2.4 <dev-vcs/mercurial-2.5"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
+ EHG_REVISION="stable"
+ KEYWORDS=""
+ SRC_URI=""
+ HG_DEPEND="dev-vcs/mercurial"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="http://tortoisehg.bitbucket.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt4
+ dev-python/qscintilla-python"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-1.0.3 )"
+
+# Workaround race condition in build_qt
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ if [[ ${LINGUAS+set} ]]; then
+ cd i18n/tortoisehg || die
+ local x y keep
+ for x in *.po; do
+ keep=false
+ for y in ${LINGUAS}; do
+ if [[ ${y} == ${x%.po}* ]]; then
+ keep=true
+ break
+ fi
+ done
+ ${keep} || rm "${x}" || die
+ done
+ cd "${S}" || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO
+ if use doc ; then
+ dohtml -r doc/build/html/
+ fi
+ newicon -s scalable icons/scalable/apps/thg-logo.svg tortoisehg_logo.svg
+ domenu contrib/${PN}.desktop
+}
+
+pkg_postinst() {
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt4 please rebuild"
+ elog "dev-python/qscintilla-python."
+}
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index 44a573f82e8c..2f481734b71b 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.14 2013/02/09 19:16:01 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.15 2013/02/09 19:21:12 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
@@ -10,7 +10,7 @@ inherit distutils-r1 eutils
if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~x86"
SRC_URI="mirror://bitbucket/${PN}/targz/downloads/${P}.tar.gz"
- HG_DEPEND=">=dev-vcs/mercurial-2.3 <dev-vcs/mercurial-2.5"
+ HG_DEPEND=">=dev-vcs/mercurial-2.4 <dev-vcs/mercurial-2.5"
else
inherit mercurial
EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"