summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-06-05 09:16:26 +0000
committerChristian Ruppert <idl0r@gentoo.org>2010-06-05 09:16:26 +0000
commitb01ae6aa8511c9ea53159bfd68f383f7ca5f9abc (patch)
treef974b157c441fdd48040d01a859db244e65b5ebc /dev-vcs
parentRemove old, these won't compile with stable glibc due to getline function con... (diff)
downloadgentoo-2-b01ae6aa8511c9ea53159bfd68f383f7ca5f9abc.tar.gz
gentoo-2-b01ae6aa8511c9ea53159bfd68f383f7ca5f9abc.tar.bz2
gentoo-2-b01ae6aa8511c9ea53159bfd68f383f7ca5f9abc.zip
Initial commit, bug 250516, thanks to Alexander Potashev <aspotashev@gmail.com> and Benjamin Bannier <bbannier+gentoo_bugs@gmail.com>.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/topgit/ChangeLog12
-rw-r--r--dev-vcs/topgit/metadata.xml9
-rw-r--r--dev-vcs/topgit/topgit-0.8.ebuild34
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-vcs/topgit/ChangeLog b/dev-vcs/topgit/ChangeLog
new file mode 100644
index 000000000000..edf79544ea89
--- /dev/null
+++ b/dev-vcs/topgit/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-vcs/topgit
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/topgit/ChangeLog,v 1.1 2010/06/05 09:16:26 idl0r Exp $
+
+*topgit-0.8 (05 Jun 2010)
+
+ 05 Jun 2010; Christian Ruppert <idl0r@gentoo.org> +topgit-0.8.ebuild,
+ +metadata.xml:
+ Initial commit, bug 250516, thanks to Alexander Potashev
+ <aspotashev@gmail.com> and Benjamin Bannier
+ <bbannier+gentoo_bugs@gmail.com>.
+
diff --git a/dev-vcs/topgit/metadata.xml b/dev-vcs/topgit/metadata.xml
new file mode 100644
index 000000000000..ea6573a9fbf4
--- /dev/null
+++ b/dev-vcs/topgit/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-vcs/topgit/topgit-0.8.ebuild b/dev-vcs/topgit/topgit-0.8.ebuild
new file mode 100644
index 000000000000..83ef0df085f5
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/topgit/topgit-0.8.ebuild,v 1.1 2010/06/05 09:16:26 idl0r Exp $
+
+inherit bash-completion
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="http://repo.or.cz/w/topgit.git"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentooexperimental.org/~idl0r/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion"
+
+DEPEND="sys-apps/sed
+ sys-apps/gawk"
+RDEPEND="dev-vcs/git"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}" || die
+}
+
+src_install() {
+ emake prefix="${D}/usr" sharedir="${D}/usr/share/doc/${PF}" install || die
+
+ if use bash-completion; then
+ dobashcompletion contrib/tg-completion.bash ${PN}
+ fi
+
+ dodoc README || die
+}