summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-02 08:49:44 +0000
committerMark Wright <gienah@gentoo.org>2012-06-02 08:49:44 +0000
commitb2e1dbf6c928609daccba1e2dbca3e6fff461db1 (patch)
tree5ac419af7953318ac7249a5075de6ec45c481be0 /dev-vcs
parentInitial import. New dependency for forthcoming versions of sass. (diff)
downloadgentoo-2-b2e1dbf6c928609daccba1e2dbca3e6fff461db1.tar.gz
gentoo-2-b2e1dbf6c928609daccba1e2dbca3e6fff461db1.tar.bz2
gentoo-2-b2e1dbf6c928609daccba1e2dbca3e6fff461db1.zip
Bump git-annex to 3.20120522
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-annex/ChangeLog7
-rw-r--r--dev-vcs/git-annex/git-annex-3.20120522.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/dev-vcs/git-annex/ChangeLog b/dev-vcs/git-annex/ChangeLog
index e7e0bd9e3265..d2cf0e32f2d6 100644
--- a/dev-vcs/git-annex/ChangeLog
+++ b/dev-vcs/git-annex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/git-annex
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-annex/ChangeLog,v 1.4 2012/03/24 14:28:51 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-annex/ChangeLog,v 1.5 2012/06/02 08:49:44 gienah Exp $
+
+*git-annex-3.20120522 (02 Jun 2012)
+
+ 02 Jun 2012; Mark Wright <gienah@gentoo.org> +git-annex-3.20120522.ebuild:
+ Bump git-annex to 3.20120522
*git-annex-3.20120315 (24 Mar 2012)
diff --git a/dev-vcs/git-annex/git-annex-3.20120522.ebuild b/dev-vcs/git-annex/git-annex-3.20120522.ebuild
new file mode 100644
index 000000000000..9c7084769fc3
--- /dev/null
+++ b/dev-vcs/git-annex/git-annex-3.20120522.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-annex/git-annex-3.20120522.ebuild,v 1.1 2012/06/02 08:49:44 gienah Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="manage files with git, without checking their contents into git"
+HOMEPAGE="http://git-annex.branchable.com/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+RESTRICT=test # don't seem to like our git environment much
+
+RDEPEND=">=dev-vcs/git-1.7.7" # TODO: add more deps?
+DEPEND="${RDEPEND}
+ test? ( dev-haskell/extensible-exceptions
+ dev-haskell/hunit
+ dev-haskell/testpack
+ )
+ dev-haskell/bloomfilter
+ >=dev-haskell/cabal-1.8
+ dev-haskell/dataenc
+ dev-haskell/edit-distance
+ dev-haskell/hs3
+ dev-haskell/hslogger
+ dev-haskell/http
+ dev-haskell/ifelse
+ dev-haskell/json
+ dev-haskell/lifted-base
+ dev-haskell/missingh
+ dev-haskell/monad-control
+ dev-haskell/mtl
+ dev-haskell/network
+ dev-haskell/pcre-light
+ >=dev-haskell/quickcheck-2.1
+ dev-haskell/sha
+ dev-haskell/text
+ dev-haskell/time
+ dev-haskell/transformers-base
+ dev-haskell/utf8-string
+ >=dev-lang/ghc-6.12.3
+ dev-lang/perl
+ doc? ( www-apps/ikiwiki net-misc/rsync )"
+# dev-lang/perl is to build the manpages
+# www-apps/ikiwiki and net-misc/rsync used to build the rest of the docs
+
+src_prepare() {
+ echo 'mans: $(mans)' >>"${S}"/Makefile
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+ use doc && emake docs
+ emake mans
+}
+
+src_test() {
+ export GIT_CONFIG=${T}/temp-git-config
+ git config user.email "git@src_test"
+ git config user.name "Mr. ${P} The Test"
+
+ emake test
+}
+
+src_install() {
+ #haskell-cabal_src_install
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+ mv "${ED}"/usr/share/doc/{${PN},${PF}}
+ dodoc CHANGELOG README
+}