summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-07-20 07:35:01 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-07-20 07:35:01 +0000
commitf17258ebf70b58173ead9521ff9d7148658a69f0 (patch)
treea319075390f7cce4150a7dadc47d7743275c5608 /dev-vcs
parentFixed classpath rewriting (bug #517312) (diff)
downloadgentoo-2-f17258ebf70b58173ead9521ff9d7148658a69f0.tar.gz
gentoo-2-f17258ebf70b58173ead9521ff9d7148658a69f0.tar.bz2
gentoo-2-f17258ebf70b58173ead9521ff9d7148658a69f0.zip
Fix build failure against older feed from upstream (bug #517350 by Fabian Köster).
(Portage version: 2.2.10_p39/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-annex/ChangeLog7
-rw-r--r--dev-vcs/git-annex/files/git-annex-5.20140717-old-feed.patch24
-rw-r--r--dev-vcs/git-annex/git-annex-5.20140717.ebuild4
3 files changed, 33 insertions, 2 deletions
diff --git a/dev-vcs/git-annex/ChangeLog b/dev-vcs/git-annex/ChangeLog
index 0a9411db23ae..7f22bb431fd4 100644
--- a/dev-vcs/git-annex/ChangeLog
+++ b/dev-vcs/git-annex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/git-annex
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-annex/ChangeLog,v 1.28 2014/07/19 06:27:45 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-annex/ChangeLog,v 1.29 2014/07/20 07:35:01 slyfox Exp $
+
+ 20 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/git-annex-5.20140717-old-feed.patch, git-annex-5.20140717.ebuild:
+ Fix build failure against older feed from upstream (bug #517350 by Fabian
+ Köster).
*git-annex-5.20140717 (19 Jul 2014)
diff --git a/dev-vcs/git-annex/files/git-annex-5.20140717-old-feed.patch b/dev-vcs/git-annex/files/git-annex-5.20140717-old-feed.patch
new file mode 100644
index 000000000000..c67024c6e910
--- /dev/null
+++ b/dev-vcs/git-annex/files/git-annex-5.20140717-old-feed.patch
@@ -0,0 +1,24 @@
+commit d15bfc9061d370b22ba4de8146fab92d3fa3ff02
+Author: Joey Hess <joey@kitenet.net>
+Date: Sat Jul 19 18:30:08 2014 -0400
+
+ fix build with old feed
+
+diff --git a/Command/ImportFeed.hs b/Command/ImportFeed.hs
+index e785885..1fdba46 100644
+--- a/Command/ImportFeed.hs
++++ b/Command/ImportFeed.hs
+@@ -227,9 +227,13 @@ feedFile tmpl i extension = Utility.Format.format tmpl $
+ #endif
+
+ extractMetaData :: ToDownload -> MetaData
++#if MIN_VERSION_feed(0,3,9)
+ extractMetaData i = case getItemPublishDate (item i) :: Maybe (Maybe UTCTime) of
+ Just (Just d) -> unionMetaData meta (dateMetaData d meta)
+ _ -> meta
++#else
++extractMetaData i = meta
++#endif
+ where
+ tometa (k, v) = (mkMetaFieldUnchecked k, S.singleton (toMetaValue v))
+ meta = MetaData $ M.fromList $ map tometa $ extractFields i
diff --git a/dev-vcs/git-annex/git-annex-5.20140717.ebuild b/dev-vcs/git-annex/git-annex-5.20140717.ebuild
index b8b5bf759d19..4c24aa25ea5c 100644
--- a/dev-vcs/git-annex/git-annex-5.20140717.ebuild
+++ b/dev-vcs/git-annex/git-annex-5.20140717.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-annex/git-annex-5.20140717.ebuild,v 1.1 2014/07/19 06:27:45 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-annex/git-annex-5.20140717.ebuild,v 1.2 2014/07/20 07:35:01 slyfox Exp $
EAPI=5
@@ -114,6 +114,8 @@ src_prepare() {
cabal_chdeps \
'hamlet' 'hamlet, shakespeare'
+
+ epatch "${FILESDIR}"/${P}-old-feed.patch
}
src_configure() {