summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-02-10 20:27:25 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-02-10 20:27:25 +0000
commitfd68cd1d4a0e7826bfd2a8767e401c39a990294f (patch)
treef93349fa868d959592f3ecc0fcda28c40b3d43ce /dev-vcs
parentDrop -g from FLAGS (diff)
downloadgentoo-2-fd68cd1d4a0e7826bfd2a8767e401c39a990294f.tar.gz
gentoo-2-fd68cd1d4a0e7826bfd2a8767e401c39a990294f.tar.bz2
gentoo-2-fd68cd1d4a0e7826bfd2a8767e401c39a990294f.zip
Initial import.
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-deploy/ChangeLog10
-rw-r--r--dev-vcs/git-deploy/Manifest4
-rw-r--r--dev-vcs/git-deploy/git-deploy-20120202.ebuild60
-rw-r--r--dev-vcs/git-deploy/metadata.xml9
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-vcs/git-deploy/ChangeLog b/dev-vcs/git-deploy/ChangeLog
new file mode 100644
index 000000000000..dfbf9750720b
--- /dev/null
+++ b/dev-vcs/git-deploy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-vcs/git-deploy
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-deploy/ChangeLog,v 1.1 2012/02/10 20:27:25 idl0r Exp $
+
+*git-deploy-20120202 (10 Feb 2012)
+
+ 10 Feb 2012; Christian Ruppert <idl0r@gentoo.org>
+ +git-deploy-20120202.ebuild, +metadata.xml:
+ Initial import.
+
diff --git a/dev-vcs/git-deploy/Manifest b/dev-vcs/git-deploy/Manifest
new file mode 100644
index 000000000000..b72cca6c9e08
--- /dev/null
+++ b/dev-vcs/git-deploy/Manifest
@@ -0,0 +1,4 @@
+DIST git-deploy-20120202.tar.bz2 35850 RMD160 927051257fcc4a0193b23e874e50c571739fe732 SHA1 0f97f251fcfe94617a8bf4822abe107185c1f051 SHA256 815cded39620838c0e25c6f51d58c74456ebb6ae424efb7ad7e3dd2272b41184
+EBUILD git-deploy-20120202.ebuild 1196 RMD160 46ce84c62590b35cba10997f98163006febe0ca9 SHA1 fbb8b60023e56861ab837c9c46f0a6ed99db0979 SHA256 448316b645644765fc55a1ee4c74aa2e260f2ed2f676826f90891ae25a8d2de1
+MISC ChangeLog 272 RMD160 4be377eda7978b1695668ba7514165f9b5d1a7a7 SHA1 91e86b1fa4990e5f7fc265304068f7bd7e17aa81 SHA256 bd8787509d4ce30b4df0f9f4d0c5263f91421fbec4c33c85567bd67ef266674b
+MISC metadata.xml 236 RMD160 304046949191a548a4668d41dcb2290da1909c97 SHA1 b923b11f5a427f838e90db25b9f35261e5e2c0a4 SHA256 224586cfa8d5e5362a62f8100d30f61016933ed37a2e87b3a795f66eddb8a177
diff --git a/dev-vcs/git-deploy/git-deploy-20120202.ebuild b/dev-vcs/git-deploy/git-deploy-20120202.ebuild
new file mode 100644
index 000000000000..f528aa354e9f
--- /dev/null
+++ b/dev-vcs/git-deploy/git-deploy-20120202.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-deploy/git-deploy-20120202.ebuild,v 1.1 2012/02/10 20:27:25 idl0r Exp $
+
+EAPI=4
+
+inherit perl-app
+
+DESCRIPTION="make deployments so easy that you'll let new hires do them on their
+first day"
+HOMEPAGE="https://github.com/git-deploy/git-deploy"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-lang/perl
+ test? (
+ dev-vcs/git
+ virtual/perl-File-Temp
+ perl-core/File-Spec
+ )"
+RDEPEND="dev-lang/perl
+ dev-vcs/git
+ perl-core/File-Spec
+ virtual/perl-Getopt-Long
+ virtual/perl-Term-ANSIColor
+ virtual/perl-Time-HiRes"
+
+src_prepare() {
+ pod2man -n git-deploy README.pod > git-deploy.1 || die
+}
+
+src_test() {
+ local testdir=${TMPDIR}/git-deploy-test
+
+ # Prepare for tests
+ cp -a "${S}/" $testdir || die
+ cd $testdir || die
+
+ git config --global user.name "git-deploy" || die
+ git config --global user.email "git-deploy@localhost" || die
+
+ git init . || die
+ git add . || die
+ git commit -a -m 'git-deploy testing' || die
+
+ USER="git-deploy" perl t/run.t || die
+}
+
+src_install() {
+ dobin git-deploy
+
+ insinto $VENDOR_LIB
+ doins -r lib/Git
+
+ doman git-deploy.1
+}
diff --git a/dev-vcs/git-deploy/metadata.xml b/dev-vcs/git-deploy/metadata.xml
new file mode 100644
index 000000000000..40fcaa650383
--- /dev/null
+++ b/dev-vcs/git-deploy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+</pkgmetadata>
+