summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2002-11-28 07:54:09 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2002-11-28 07:54:09 +0000
commitd2d0007291b49aff76260c7551ad5e0a17e0bad0 (patch)
tree78abdbb00ee12b92c996a6b96460aced35de5a71 /eclass/gtk-engines.eclass
parentInitial import. ~keyworded for testing. (diff)
downloadgentoo-2-d2d0007291b49aff76260c7551ad5e0a17e0bad0.tar.gz
gentoo-2-d2d0007291b49aff76260c7551ad5e0a17e0bad0.tar.bz2
gentoo-2-d2d0007291b49aff76260c7551ad5e0a17e0bad0.zip
more work for a new engine
Diffstat (limited to 'eclass/gtk-engines.eclass')
-rw-r--r--eclass/gtk-engines.eclass30
1 files changed, 27 insertions, 3 deletions
diff --git a/eclass/gtk-engines.eclass b/eclass/gtk-engines.eclass
index d2c71c7bed42..578ab66ed623 100644
--- a/eclass/gtk-engines.eclass
+++ b/eclass/gtk-engines.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gtk-engines.eclass,v 1.13 2002/11/28 05:21:23 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gtk-engines.eclass,v 1.14 2002/11/28 07:54:09 leonardop Exp $
# The gtk-engines eclass is inheritd by all gtk-engines-* ebuilds.
@@ -151,7 +151,8 @@ gtk-engines_src_compile() {
gtk-engines_src_install() {
[ "X${MY_PN}" = "Xgtk-engines" ] && cd ${ENGINE}
- if [ "X${MY_PN}" = "Xxenophilia" ]
+ # Some corrections to misc files
+ if [ "X${ENGINE}" = "Xxenophilia" ]
then
dodir /usr/X11R6/lib/X11/fonts/misc
@@ -161,6 +162,13 @@ gtk-engines_src_install() {
-e '7,8d' \
fonts/Makefile.orig > fonts/Makefile || die
rm fonts/Makefile.orig
+
+ elif [ "X${ENGINE}" = "Xgeramik" ]
+ then
+ mv theme/gtk-2.0/gtkrc-2.0 theme/gtk-2.0/gtkrc-2.0.old
+ sed -e '9,10d' \
+ theme/gtk-2.0/gtkrc-2.0.old > theme/gtk-2.0/gtkrc-2.0
+ rm theme/gtk-2.0/gtkrc-2.0.old
fi
einstall \
@@ -168,7 +176,9 @@ gtk-engines_src_install() {
ENGINE_DIR=${D}/usr/lib/gtk/themes/engines \
|| die "Installation failed"
- if [ "X${MY_PN}" = "XGTK-mist-engine" ]
+ # Remove unwanted stuff, since some engines include GTK-1 and GTK-2
+ # support.
+ if [ "X${ENGINE}" = "Xmist" ]
then
if [ "$SLOT" -eq "2" ]
then
@@ -178,6 +188,20 @@ gtk-engines_src_install() {
fi
rm -rf ${D}/usr/share/themes/Mist/metacity-1
+
+ elif [ "X${ENGINE}" = "Xgeramik" ]
+ then
+ if [ "$SLOT" -eq "2" ]
+ then
+ mv ${D}/usr/share/themes/Geramik/gtk/*png \
+ ${D}/usr/share/themes/Geramik/gtk-2.0
+ mv ${D}/usr/share/themes/Geramik/gtk-2.0/gtkrc-2.0 \
+ ${D}/usr/share/themes/Geramik/gtk-2.0/gtkrc
+
+ rm -rf ${D}/usr/lib/gtk ${D}/usr/share/themes/Geramik/gtk
+ else
+ rm -rf ${D}/usr/lib/gtk-2.0 ${D}/usr/share/themes/Geramik/gtk-2.0
+ fi
fi
for doc in AUTHORS BUGS ChangeLog CONFIGURATION COPYING CUSTOMIZATION \