summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-05-05 18:00:21 +0000
committerMike Gilbert <floppym@gentoo.org>2012-05-05 18:00:21 +0000
commite89566e1aedf919b4af907a57ba66728f0bb4696 (patch)
treeaed33b3364e0bd2895e814fa59e2d9d25c748a52 /eclass/python-distutils-ng.eclass
parentVersion bump. Fixes an argv splitting bug that can affect some packages (like... (diff)
downloadgentoo-2-e89566e1aedf919b4af907a57ba66728f0bb4696.tar.gz
gentoo-2-e89566e1aedf919b4af907a57ba66728f0bb4696.tar.bz2
gentoo-2-e89566e1aedf919b4af907a57ba66728f0bb4696.zip
Simplify ${D%/}/ to ${D}; PMS says ${D} always has a trailing slash, and it works without a trailing slash anyway.
Diffstat (limited to 'eclass/python-distutils-ng.eclass')
-rw-r--r--eclass/python-distutils-ng.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/python-distutils-ng.eclass b/eclass/python-distutils-ng.eclass
index fdbf2676062e..50339bc13681 100644
--- a/eclass/python-distutils-ng.eclass
+++ b/eclass/python-distutils-ng.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/python-distutils-ng.eclass,v 1.16 2012/05/04 08:31:43 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/python-distutils-ng.eclass,v 1.17 2012/05/05 18:00:21 floppym Exp $
# @ECLASS: python-distutils-ng
# @MAINTAINER:
@@ -181,7 +181,7 @@ _python-distutils-ng_default_distutils_install() {
unset PYTHONDONTWRITEBYTECODE
[[ -n "${PYTHON_DISABLE_COMPILATION}" ]] && compile_flags="--no-compile"
- "${PYTHON}" setup.py install ${compile_flags} --root="${D%/}/" || die
+ "${PYTHON}" setup.py install ${compile_flags} --root="${D}" || die
}
# @FUNCTION: python-distutils-ng_redoscript