summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-05-23 05:47:28 +0000
committerMike Frysinger <vapier@gentoo.org>2006-05-23 05:47:28 +0000
commit07592667470d16cbe88021e573454d5ef5607f14 (patch)
treed9e0490b21381c606a613de34bc7d60709f9862e /eclass
parentenabling aRts on compile fix (diff)
downloadgentoo-2-07592667470d16cbe88021e573454d5ef5607f14.tar.gz
gentoo-2-07592667470d16cbe88021e573454d5ef5607f14.tar.bz2
gentoo-2-07592667470d16cbe88021e573454d5ef5607f14.zip
fix get_make_var() when people are using -w in make options #133822 by Anthony Mutiso and Drake Wyrm
Diffstat (limited to 'eclass')
-rw-r--r--eclass/toolchain.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index ee9ac1b92a94..d3771a7cae41 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.281 2006/05/15 03:12:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.282 2006/05/23 05:47:28 vapier Exp $
HOMEPAGE="http://gcc.gnu.org/"
LICENSE="GPL-2 LGPL-2.1"
@@ -346,7 +346,7 @@ SRC_URI=$(get_gcc_src_uri)
get_make_var() {
local var=$1 makefile=${2:-${WORKDIR}/build/Makefile}
echo -e "e:\\n\\t@echo \$(${var})\\ninclude ${makefile}" | \
- r=${makefile%/*} emake -s -f - 2>/dev/null
+ r=${makefile%/*} emake --no-print-directory -s -f - 2>/dev/null
}
XGCC() { get_make_var GCC_FOR_TARGET ; }