summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2011-10-29 15:07:16 +0000
committerJonathan Callen <abcd@gentoo.org>2011-10-29 15:07:16 +0000
commit0f08f40d3e4e679d7b025b440f5a0cfe629079eb (patch)
tree83f1ddaa09aaad066c874b26a53bfff6e35fdca7 /eclass
parentImprove the postinst check for valid system VM to allow migrating icedtea6 to... (diff)
downloadgentoo-2-0f08f40d3e4e679d7b025b440f5a0cfe629079eb.tar.gz
gentoo-2-0f08f40d3e4e679d7b025b440f5a0cfe629079eb.tar.bz2
gentoo-2-0f08f40d3e4e679d7b025b440f5a0cfe629079eb.zip
Sync kde4 eclasses
Diffstat (limited to 'eclass')
-rw-r--r--eclass/kde4-base.eclass15
-rw-r--r--eclass/kde4-meta.eclass16
2 files changed, 17 insertions, 14 deletions
diff --git a/eclass/kde4-base.eclass b/eclass/kde4-base.eclass
index 6d4267642b54..0600665c729a 100644
--- a/eclass/kde4-base.eclass
+++ b/eclass/kde4-base.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.109 2011/10/21 23:00:19 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.110 2011/10/29 15:07:16 abcd Exp $
# @ECLASS: kde4-base.eclass
# @MAINTAINER:
@@ -600,7 +600,7 @@ debug-print "${LINENO} ${ECLASS} ${FUNCNAME}: SRC_URI is ${SRC_URI}"
kde4-base_pkg_setup() {
debug-print-function ${FUNCNAME} "$@"
- if has kdeprefix ${IUSE//+} && use kdeprefix; then
+ if use_if_iuse kdeprefix; then
eerror "Sorry, kdeprefix support has been removed."
eerror "Please remove kdeprefix from your USE variable."
die "kdeprefix support has been removed"
@@ -682,7 +682,7 @@ kde4-base_src_prepare() {
# Enable/disable handbooks for kde4-base packages
# kde-l10n inherits kde4-base but is metpackage, so no check for doc
# kdelibs inherits kde4-base but handle installing the handbook itself
- if ! has kde4-meta ${INHERITED} && has handbook ${IUSE//+}; then
+ if ! has kde4-meta ${INHERITED} && in_iuse handbook; then
if [[ ${KDEBASE} == kde-base ]]; then
if [[ ${PN} != kde-l10n && ${PN} != kdepim-l10n && ${PN} != kdelibs ]] && use !handbook; then
# documentation in kde4-functions
@@ -760,11 +760,11 @@ kde4-base_src_configure() {
# Build tests in src_test only, where we override this value
local cmakeargs=(-DKDE4_BUILD_TESTS=OFF)
- if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
+ if use_if_iuse kdeenablefinal; then
cmakeargs+=(-DKDE4_ENABLE_FINAL=ON)
fi
- if has debug ${IUSE//+} && use debug; then
+ if use_if_iuse debug; then
# Set "real" debug mode
CMAKE_BUILD_TYPE="Debugfull"
else
@@ -880,6 +880,9 @@ kde4-base_pkg_preinst() {
debug-print-function ${FUNCNAME} "$@"
gnome2_icon_savelist
+ if [[ ${BUILD_TYPE} == live && ${KDE_SCM} == svn ]]; then
+ subversion_pkg_preinst
+ fi
}
# @FUNCTION: kde4-base_pkg_postinst
@@ -894,7 +897,7 @@ kde4-base_pkg_postinst() {
buildsycoca
if [[ -z ${I_KNOW_WHAT_I_AM_DOING} ]]; then
- if has kdeenablefinal ${IUSE//+} && use kdeenablefinal; then
+ if use_if_iuse kdeenablefinal; then
echo
ewarn "WARNING! you have kdeenable final useflag enabled."
ewarn "This useflag needs to be enabled on ALL kde using packages and"
diff --git a/eclass/kde4-meta.eclass b/eclass/kde4-meta.eclass
index 4abe77fb2edd..08cbfa20016d 100644
--- a/eclass/kde4-meta.eclass
+++ b/eclass/kde4-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.57 2011/10/06 14:13:29 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.58 2011/10/29 15:07:16 abcd Exp $
#
# @ECLASS: kde4-meta.eclass
# @MAINTAINER:
@@ -289,7 +289,7 @@ kde4-meta_create_extractlists() {
# Add default handbook locations
# FIXME - legacy code - remove when 4.4.5 is gone or preferrably port 4.4.5.
- if [[ $(get_kde_version) < 4.5 ]] && has handbook ${IUSE//+} && use handbook && [[ -z ${KMNOMODULE} ]]; then
+ if [[ $(get_kde_version) < 4.5 ]] && use_if_iuse handbook && [[ -z ${KMNOMODULE} ]]; then
# We use the basename of $KMMODULE because $KMMODULE can contain
# the path to the module subdirectory.
KMEXTRA_NONFATAL+="
@@ -346,7 +346,7 @@ kde4-meta_create_extractlists() {
KMEXTRACTONLY+="
kdepim-version.h"
fi
- if has kontact ${IUSE//+} && use kontact; then
+ if use_if_iuse kontact; then
KMEXTRA+="
kontact/plugins/${PLUGINNAME:-${PN}}/"
fi
@@ -584,13 +584,13 @@ kde4-meta_change_cmakelists() {
sed -r -e '/find_package\(KdepimLibs/s/REQUIRED//' \
-e '/find_package\((KdepimLibs|Boost|QGpgme|Akonadi|ZLIB|Strigi|SharedDesktopOntologies|Soprano|Nepomuk)/{/macro_optional_/!s/find/macro_optional_&/}' \
-e '/macro_log_feature\((Boost|QGPGME|Akonadi|ZLIB|STRIGI|SHAREDDESKTOPONTOLOGIES|Soprano|Nepomuk)_FOUND/s/ TRUE / FALSE /' \
- -e '/if[[:space:]]*([[:space:]]*BUILD_.*)/s/^/#OVERRIDE /' \
- -e '/if[[:space:]]*([[:space:]]*[[:alnum:]]*_FOUND[[:space:]]*)/s/^/#OVERRIDE /' \
+ -e 's/if[[:space:]]*([[:space:]]*BUILD_.*)[[:space:]]*/if(1) # &/' \
+ -e 's/if[[:space:]]*([[:space:]]*[[:alnum:]]*_FOUND[[:space:]]*)[[:space:]]*$/if(1) # &/' \
-i CMakeLists.txt || die "failed to disable hardcoded checks"
# Disable broken or redundant build logic
- if ( has kontact ${IUSE//+} && use kontact ) || [[ ${PN} = kontact ]]; then
- sed -e '/if[[:space:]]*([[:space:]]*BUILD_.*)/s/^/#OVERRIDE /' \
- -e '/if[[:space:]]*([[:space:]]*[[:alnum:]]*_FOUND[[:space:]]*)/s/^/#OVERRIDE /' \
+ if use_if_iuse kontact || [[ ${PN} = kontact ]]; then
+ sed -e 's/if[[:space:]]*([[:space:]]*BUILD_.*)[[:space:]]*$/if(1) # &/' \
+ -e 's/if[[:space:]]*([[:space:]]*[[:alnum:]]*_FOUND[[:space:]]*)[[:space:]]*$/if(1) # &/' \
-i kontact/plugins/CMakeLists.txt || die 'failed to override build logic'
fi
if [[ $(get_kde_version) < 4.5 ]]; then