summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-10 11:39:42 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-10 11:39:42 +0000
commit2dac16be6d8082be42b71e4804fedf615ed8550b (patch)
treecd21125ca81faa70ea9685fe5dd348d3fb9639bd /eclass
parentError out if "tests" package is installed. This is a common mistake and a sou... (diff)
downloadgentoo-2-2dac16be6d8082be42b71e4804fedf615ed8550b.tar.gz
gentoo-2-2dac16be6d8082be42b71e4804fedf615ed8550b.tar.bz2
gentoo-2-2dac16be6d8082be42b71e4804fedf615ed8550b.zip
Override egg-info write location in out-of-source builds.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog5
-rw-r--r--eclass/distutils-r1.eclass9
2 files changed, 12 insertions, 2 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index 9666cd046e62..4245f077883f 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for eclass directory
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.667 2013/02/10 11:38:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.668 2013/02/10 11:39:42 mgorny Exp $
+
+ 10 Feb 2013; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
+ Override egg-info write location in out-of-source builds.
10 Feb 2013; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
Error out if "tests" package is installed. This is a common mistake and a
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 043fe1b0c2da..ec7171b8a624 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.49 2013/02/10 11:38:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.50 2013/02/10 11:39:42 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -215,6 +215,13 @@ esetup.py() {
die 'Out-of-source build requested, yet BUILD_DIR unset.'
fi
+ # if setuptools is used, adjust egg_info path as well
+ if "${PYTHON:-python}" setup.py --help egg_info &>/dev/null; then
+ add_args+=(
+ egg_info --egg-base "${BUILD_DIR}"
+ )
+ fi
+
add_args+=(
build
--build-base "${BUILD_DIR}"