summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-06-14 18:33:59 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-06-14 18:33:59 +0000
commit88d844006f210d56297b0d80faa04d3b4e532482 (patch)
tree67559cdfb86c73896bb7c011e494fa5328dc59c5 /eclass
parentVersion bump. (diff)
downloadgentoo-2-88d844006f210d56297b0d80faa04d3b4e532482.tar.gz
gentoo-2-88d844006f210d56297b0d80faa04d3b4e532482.tar.bz2
gentoo-2-88d844006f210d56297b0d80faa04d3b4e532482.zip
Sync with KDE overlay. Adapt to live ebuild versioning change. Remove reference to long-removed package. Explicitly specify a slot. Update SRC_URI for kde-workspace 4.11.10. Add new function to comment add_subdirectory calls. Remove obsolete add_blocker function.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog8
-rw-r--r--eclass/kde4-base.eclass17
-rw-r--r--eclass/kde4-functions.eclass81
3 files changed, 34 insertions, 72 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index de7fe9788fea..42d865c80ca2 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for eclass directory
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.1289 2014/06/14 07:37:47 rhill Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.1290 2014/06/14 18:33:59 kensington Exp $
+
+ 14 Jun 2014; Michael Palimaka <kensington@gentoo.org> kde4-base.eclass, kde4-functions.eclass:
+ Sync with KDE overlay. Adapt to live ebuild versioning change. Remove
+ reference to long-removed package. Explicitly specify a slot. Update SRC_URI
+ for kde-workspace 4.11.10. Add new function to comment add_subdirectory
+ calls. Remove obsolete add_blocker function.
14 Jun 2014; Ryan Hill <rhill@gentoo.org> flag-o-matic.eclass:
Add -Og, -gdwarf-*, and -fabi-version=* to allowed flags (bug #512534,
diff --git a/eclass/kde4-base.eclass b/eclass/kde4-base.eclass
index fb9d1ec23e74..45d117fb00fd 100644
--- a/eclass/kde4-base.eclass
+++ b/eclass/kde4-base.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.135 2014/04/25 19:39:42 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.136 2014/06/14 18:33:59 kensington Exp $
# @ECLASS: kde4-base.eclass
# @MAINTAINER:
@@ -82,15 +82,15 @@ case ${KDEBASE} in
# @DESCRIPTION:
# Specifies KDevelop version. Default is 4.0.0 for tagged packages and 9999 for live packages.
# Applies to KDEBASE=kdevelop only.
- KDEVELOP_VERSION="${KDEVELOP_VERSION:-9999}"
+ KDEVELOP_VERSION="${KDEVELOP_VERSION:-4.9999}"
# @ECLASS-VARIABLE: KDEVPLATFORM_VERSION
# @DESCRIPTION:
# Specifies KDevplatform version. Default is 1.0.0 for tagged packages and 9999 for live packages.
# Applies to KDEBASE=kdevelop only.
- KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-9999}"
+ KDEVPLATFORM_VERSION="${KDEVPLATFORM_VERSION:-4.9999}"
else
case ${PN} in
- kdevelop|quanta)
+ kdevelop)
KDEVELOP_VERSION=${PV}
KDEVPLATFORM_VERSION="$(($(get_major_version)-3)).$(get_after_major_version)"
;;
@@ -309,7 +309,7 @@ if [[ ${PN} != kdelibs ]]; then
case ${KDEVPLATFORM_REQUIRED} in
always)
kdecommondepend+="
- >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}
+ >=dev-util/kdevplatform-${KDEVPLATFORM_VERSION}:4
"
;;
*) ;;
@@ -448,6 +448,9 @@ _calculate_src_uri() {
4.11.9)
# Part of 4.12 actually, sigh. Not stable for next release!
SRC_URI="mirror://kde/stable/4.12.5/src/${_kmname_pv}.tar.xz" ;;
+ 4.11.10)
+ # Part of 4.13 actually, sigh. Not stable for next release!
+ SRC_URI="mirror://kde/stable/4.13.2/src/${_kmname_pv}.tar.xz" ;;
*)
# Stable KDE SC releases
SRC_URI="mirror://kde/stable/${PV}/src/${_kmname_pv}.tar.xz" ;;
@@ -471,7 +474,7 @@ _calculate_live_repo() {
# Determine branch URL based on live type
local branch_prefix
case ${PV} in
- 9999*)
+ 4.9999*)
# trunk
branch_prefix="trunk/KDE"
;;
@@ -558,7 +561,7 @@ _calculate_live_repo() {
fi
# default branching
- [[ ${PV} != 9999* && ${KDEBASE} == kde-base ]] && \
+ [[ ${PV} != 4.9999* && ${KDEBASE} == kde-base ]] && \
EGIT_BRANCH="KDE/$(get_kde_version)"
# default repo uri
diff --git a/eclass/kde4-functions.eclass b/eclass/kde4-functions.eclass
index c986bad71bd5..fc7dabf1d4b3 100644
--- a/eclass/kde4-functions.eclass
+++ b/eclass/kde4-functions.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-functions.eclass,v 1.67 2013/08/15 15:10:05 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-functions.eclass,v 1.68 2014/06/14 18:33:59 kensington Exp $
inherit versionator
@@ -121,6 +121,21 @@ buildsycoca() {
done
}
+# @FUNCTION: comment_add_subdirectory
+# @USAGE: subdirectory
+# @DESCRIPTION:
+# Comment out an add_subdirectory call in CMakeLists.txt in the current directory
+comment_add_subdirectory() {
+ if [[ -z ${1} ]]; then
+ die "comment_add_subdirectory must be passed the directory name to comment"
+ fi
+
+ if [[ -a "CMakeLists.txt" ]]; then
+ sed -e "/add_subdirectory[[:space:]]*([[:space:]]*${1}[[:space:]]*)/s/^/#DONOTCOMPILE /" \
+ -i CMakeLists.txt || die "failed to comment add_subdirectory(${1})"
+ fi
+}
+
# @FUNCTION: comment_all_add_subdirectory
# @USAGE: [list of directory names]
# @DESCRIPTION:
@@ -263,68 +278,6 @@ load_library_dependencies() {
eend $?
}
-# @FUNCTION: add_blocker
-# @DESCRIPTION:
-# Create correct RDEPEND value for blocking correct package.
-# Useful for file-collision blocks.
-# Parameters are package and version(s) to block.
-# add_blocker kdelibs 4.2.4
-# If no version is specified, then all versions will be blocked.
-# If the version is 0, then no versions will be blocked.
-# If a second version ending in ":3.5" is passed, then the version listed for
-# that slot will be blocked as well.
-#
-# Examples:
-# # Block all versions of kdelibs
-# add_blocker kdelibs
-#
-# # Block all versions of kdelibs older than 4.3.50
-# add_blocker kdelibs 4.3.50
-#
-# # Block kdelibs 3.5.10 and older, but not any version of
-# # kdelibs from KDE 4
-# add_blocker kdelibs 0 3.5.10:3.5
-add_blocker() {
- debug-print-function ${FUNCNAME} "$@"
-
- [[ -z ${1} ]] && die "Missing parameter"
- local pkg=kde-base/$1 atom old_ver="unset" use
- if [[ $pkg == *\[*\] ]]; then
- use=${pkg/#*\[/[}
- pkg=${pkg%\[*\]}
- fi
-
- [[ "$3" == *:3.5 ]] && old_ver=${3%:3.5}
-
- # If the version passed is "0", do nothing
- if [[ ${2} != 0 ]]; then
- # If no version was passed, block all versions in this slot
- if [[ -z ${2} ]]; then
- atom=${pkg}
- # If the version passed begins with a "<", then use "<" instead of "<="
- elif [[ ${2::1} == "<" ]]; then
- # this also removes the first character of the version, which is a "<"
- atom="<${pkg}-${2:1}"
- else
- atom="<=${pkg}-${2}"
- fi
- RDEPEND+=" !${atom}:4${use}"
- fi
-
- # Do the same thing as above for :3.5, except that we don't want any
- # output if no parameter was passed.
- if [[ ${old_ver} != "unset" ]]; then
- if [[ -z ${old_ver} ]]; then
- atom=${pkg}
- elif [[ ${old_ver::1} == "<" ]]; then
- atom="<${pkg}-${old_ver:1}"
- else
- atom="<=${pkg}-${old_ver}"
- fi
- RDEPEND+=" !${atom}:3.5${use}"
- fi
-}
-
# @FUNCTION: add_kdebase_dep
# @DESCRIPTION:
# Create proper dependency for kde-base/ dependencies.