summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-03-07 17:11:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-03-07 17:11:26 +0000
commit24cb327e1e5f6e8a6aefce57be72ab4c8232691e (patch)
tree21f5f6365b110d570178ffaf110223caa002f73f /games-action/abuse
parentSparc stable, Security Bug #212288. (diff)
downloadgentoo-2-24cb327e1e5f6e8a6aefce57be72ab4c8232691e.tar.gz
gentoo-2-24cb327e1e5f6e8a6aefce57be72ab4c8232691e.tar.bz2
gentoo-2-24cb327e1e5f6e8a6aefce57be72ab4c8232691e.zip
revert previous change which was broken
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-action/abuse')
-rw-r--r--games-action/abuse/ChangeLog5
-rw-r--r--games-action/abuse/abuse-0.7.1.ebuild33
2 files changed, 27 insertions, 11 deletions
diff --git a/games-action/abuse/ChangeLog b/games-action/abuse/ChangeLog
index 8ad13a89e5cb..98174ffbd1bd 100644
--- a/games-action/abuse/ChangeLog
+++ b/games-action/abuse/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/abuse
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/ChangeLog,v 1.3 2008/03/07 03:26:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/ChangeLog,v 1.4 2008/03/07 17:11:26 mr_bones_ Exp $
+
+ 07 Mar 2008; Michael Sterrett <mr_bones_@gentoo.org> abuse-0.7.1.ebuild:
+ revert previous change which was broken
07 Mar 2008; Michael Sterrett <mr_bones_@gentoo.org> abuse-0.7.1.ebuild:
change urls (bug #212520)
diff --git a/games-action/abuse/abuse-0.7.1.ebuild b/games-action/abuse/abuse-0.7.1.ebuild
index 56e750ff7f21..f51f4bf7ff28 100644
--- a/games-action/abuse/abuse-0.7.1.ebuild
+++ b/games-action/abuse/abuse-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/abuse-0.7.1.ebuild,v 1.3 2008/03/07 03:26:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/abuse/abuse-0.7.1.ebuild,v 1.4 2008/03/07 17:11:26 mr_bones_ Exp $
inherit eutils games
@@ -8,11 +8,11 @@ ZOY="http://abuse.zoy.org/attachment/wiki/Downloads/"
DESCRIPTION="port of Abuse by Crack Dot Com"
HOMEPAGE="http://abuse.zoy.org/"
-SRC_URI="${ZOY}/${P}.tar.gz
- !demo? ( ${ZOY}/abuse-data-2.00.tar.gz )
- demo? ( ${ZOY}/abuse-lib-2.00.tar.gz )
- sounds? ( ${ZOY}/abuse-sfx-2.00.tar.gz )
- levels? ( ${ZOY}/abuse-frabs-2.11.tar.gz )"
+SRC_URI="${ZOY}/${P}.tar.gz?format=raw
+ !demo? ( ${ZOY}/abuse-data-2.00.tar.gz?format=raw )
+ demo? ( ${ZOY}/abuse-lib-2.00.tar.gz?format=raw )
+ sounds? ( ${ZOY}/abuse-sfx-2.00.tar.gz?format=raw )
+ levels? ( ${ZOY}/abuse-frabs-2.11.tar.gz?format=raw )"
LICENSE="GPL-2"
SLOT="0"
@@ -24,6 +24,17 @@ DEPEND="${RDEPEND}
x11-libs/libXt
virtual/opengl"
+src_unpack() {
+ for a in ${A}
+ do
+ newname=${a%*?format=raw}
+ cp "${DISTDIR}"/${a} "${T}"/${newname}
+# mkdir -p "${T}"/${newname}-unpack
+# cd "${T}"/${newname}-unpack
+ unpack ../temp/${newname}
+ done
+}
+
src_compile() {
# Abuse auto-appends games, so point to the base
egamesconf --datadir="${GAMES_DATADIR_BASE}" || die
@@ -31,15 +42,17 @@ src_compile() {
}
src_install() {
- # Source-based install
+ # Sourcce-based install
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README TODO
# Data install
insinto "${GAMES_DATADIR}"/abuse
- doins -r "${WORKDIR}"/{addon,art,levels,lisp,music,netlevel,register,sfx} \
- "${WORKDIR}"/README.datafiles "${WORKDIR}"/abuse.lsp \
- || die "doins failed"
+ for i in addon art levels lisp music netlevel register sfx
+ do
+ doins -r "${WORKDIR}"/${i} || die "copying ${i}"
+ done
+ doins "${WORKDIR}"/README.datafiles "${WORKDIR}"/abuse.lsp || die "doins"
# Icons/desktop entry
doicon abuse.png