summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-09-06 22:55:25 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-09-06 22:55:25 +0000
commitabc66e16e24f09afcaadec03f279f865fc2fcd77 (patch)
tree5518651504a1218cc14ec11a587931d2fba09bc8 /games-action/armagetronad
parent099 release (diff)
downloadgentoo-2-abc66e16e24f09afcaadec03f279f865fc2fcd77.tar.gz
gentoo-2-abc66e16e24f09afcaadec03f279f865fc2fcd77.tar.bz2
gentoo-2-abc66e16e24f09afcaadec03f279f865fc2fcd77.zip
Revision bump with a GCC patch and a security patch. Closing bug #142394 and bug #135154.
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'games-action/armagetronad')
-rw-r--r--games-action/armagetronad/ChangeLog11
-rw-r--r--games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild82
-rw-r--r--games-action/armagetronad/files/armagetronad-0.2.7.1-gcc4.patch60
-rw-r--r--games-action/armagetronad/files/armagetronad-0.2.7.1-security-1.patch20
-rw-r--r--games-action/armagetronad/files/digest-armagetronad-0.2.7.1-r19
5 files changed, 181 insertions, 1 deletions
diff --git a/games-action/armagetronad/ChangeLog b/games-action/armagetronad/ChangeLog
index a3696759845e..5f739861fd7d 100644
--- a/games-action/armagetronad/ChangeLog
+++ b/games-action/armagetronad/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for games-action/armagetronad
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/ChangeLog,v 1.7 2006/05/01 03:20:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/ChangeLog,v 1.8 2006/09/06 22:55:25 wolf31o2 Exp $
+
+*armagetronad-0.2.7.1-r1 (06 Sep 2006)
+
+ 06 Sep 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/armagetronad-0.2.7.1-gcc4.patch,
+ +files/armagetronad-0.2.7.1-security-1.patch,
+ +armagetronad-0.2.7.1-r1.ebuild:
+ Revision bump with a GCC patch and a security patch. Closing bug #142394 and
+ bug #135154.
10 Feb 2006; Chris Gianelloni <wolf31o2@gentoo.org>
armagetronad-0.2.7.1.ebuild:
diff --git a/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild b/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild
new file mode 100644
index 000000000000..a5c19ef77716
--- /dev/null
+++ b/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/armagetronad/armagetronad-0.2.7.1-r1.ebuild,v 1.1 2006/09/06 22:55:25 wolf31o2 Exp $
+
+
+inherit flag-o-matic eutils games
+
+DESCRIPTION="3d tron lightcycles, just like the movie"
+HOMEPAGE="http://armagetronad.sourceforge.net/"
+SRC_URI="mirror://sourceforge/armagetronad/${P}.tar.bz2
+ !dedicated? (
+ http://armagetron.sourceforge.net/addons/moviesounds_fq.zip
+ http://armagetron.sourceforge.net/addons/moviepack.zip
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="dedicated"
+
+RDEPEND="
+ !dedicated? (
+ sys-libs/zlib
+ virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/jpeg
+ media-libs/libpng )"
+DEPEND="${RDEPEND}
+ !dedicated? ( app-arch/unzip )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+ epatch "${FILESDIR}"/${P}-security-1.patch
+}
+
+src_compile() {
+ filter-flags -fno-exceptions
+ if use dedicated; then
+ egamesconf --disable-glout || die "egamesconf failed"
+ else
+ egamesconf || die "egamesconf failed"
+ fi
+ emake || die "emake failed"
+ make documentation || "make doc failed"
+}
+
+src_install() {
+ dohtml doc/*.html
+ docinto html/net
+ dohtml doc/net/*.html
+ newicon tron.ico ${PN}.ico
+ exeinto "${GAMES_LIBDIR}/${PN}"
+ if use dedicated; then
+ doexe src/tron/${PN}-dedicated || die "copying files"
+ else
+ doexe src/tron/${PN} || die "copying files"
+ fi
+ doexe src/network/armagetronad-* || die "copying files"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r log language || die "copying files"
+ if ! use dedicated; then
+ doins -r arenas models sound textures music || die "copying files"
+ fi
+ insinto "${GAMES_SYSCONFDIR}/${PN}"
+ doins -r config/* || die "copying files"
+ if use dedicated; then
+ dogamesbin "${FILESDIR}/${PN}-ded"
+ fi
+ cd "${S}"
+ insinto "${GAMES_DATADIR}/${PN}"
+ if ! use dedicated; then
+ dogamesbin "${FILESDIR}/${PN}"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r ../moviepack ../moviesounds || die "copying movies"
+ make_desktop_entry armagetronad "Armagetron Advanced" ${PN}.ico
+ fi
+ prepgamesdirs
+}
diff --git a/games-action/armagetronad/files/armagetronad-0.2.7.1-gcc4.patch b/games-action/armagetronad/files/armagetronad-0.2.7.1-gcc4.patch
new file mode 100644
index 000000000000..fd12a5c971ce
--- /dev/null
+++ b/games-action/armagetronad/files/armagetronad-0.2.7.1-gcc4.patch
@@ -0,0 +1,60 @@
+diff -ur armagetronad-0.2.7.1-orig/src/engine/eGrid.h armagetronad-0.2.7.1/src/engine/eGrid.h
+--- armagetronad-0.2.7.1-orig/src/engine/eGrid.h 2005-02-03 17:26:03.000000000 +0100
++++ armagetronad-0.2.7.1/src/engine/eGrid.h 2006-06-04 20:06:17.000000000 +0200
+@@ -39,6 +39,7 @@
+ class ePoint;
+ class eFace;
+ class eHalfEdge;
++class eGameObject;
+ class eWall;
+ class eGrid;
+ class eWallView;
+diff -ur armagetronad-0.2.7.1-orig/src/engine/eVoter.cpp armagetronad-0.2.7.1/src/engine/eVoter.cpp
+--- armagetronad-0.2.7.1-orig/src/engine/eVoter.cpp 2005-03-02 23:25:18.000000000 +0100
++++ armagetronad-0.2.7.1/src/engine/eVoter.cpp 2006-06-04 20:13:54.000000000 +0200
+@@ -39,6 +39,8 @@
+ #include "ePlayer.h"
+ #include "eGrid.h"
+
++class eMenuItemVote;
++
+ static unsigned short se_votingItemID = 0;
+ static float se_votingTimeout = 300.0f;
+ static nSettingItem< float > se_vt( "VOTING_TIMEOUT", se_votingTimeout );
+diff -ur armagetronad-0.2.7.1-orig/src/engine/eWall.h armagetronad-0.2.7.1/src/engine/eWall.h
+--- armagetronad-0.2.7.1-orig/src/engine/eWall.h 2005-02-01 17:54:13.000000000 +0100
++++ armagetronad-0.2.7.1/src/engine/eWall.h 2006-06-04 19:49:36.000000000 +0200
+@@ -53,6 +53,8 @@
+
+
+ class eWall;
++class eWallView;
++class eWallHolder;
+ class eGameObject;
+
+ class eWallView:public tHeapElement{
+diff -ur armagetronad-0.2.7.1-orig/src/network/nPriorizing.h armagetronad-0.2.7.1/src/network/nPriorizing.h
+--- armagetronad-0.2.7.1-orig/src/network/nPriorizing.h 2004-11-29 11:26:42.000000000 +0100
++++ armagetronad-0.2.7.1/src/network/nPriorizing.h 2006-06-04 20:16:45.000000000 +0200
+@@ -36,6 +36,7 @@
+ class nSendBuffer;
+ class nBandwidthControl;
+ class nBandwidthTask;
++class nBandwidthTaskPriorizer;
+
+ tDECLARE_REFOBJ( nBandwidthTask );
+ tDECLARE_REFOBJ( nBandwidthArbitrator );
+diff -ur armagetronad-0.2.7.1-orig/src/tron/gCycle.h armagetronad-0.2.7.1/src/tron/gCycle.h
+--- armagetronad-0.2.7.1-orig/src/tron/gCycle.h 2005-03-06 08:26:03.000000000 +0100
++++ armagetronad-0.2.7.1/src/tron/gCycle.h 2006-06-04 19:59:52.000000000 +0200
+@@ -40,6 +40,10 @@
+ class gTextureCycle;
+ class eSoundPlayer;
+ class gSensor;
++class gCycle;
++class gPlayerWall;
++class gNetPlayerWall;
++class gDestination;
+
+ // minimum time between two cycle turns
+ extern REAL sg_delayCycle;
diff --git a/games-action/armagetronad/files/armagetronad-0.2.7.1-security-1.patch b/games-action/armagetronad/files/armagetronad-0.2.7.1-security-1.patch
new file mode 100644
index 000000000000..3b7a7759b44c
--- /dev/null
+++ b/games-action/armagetronad/files/armagetronad-0.2.7.1-security-1.patch
@@ -0,0 +1,20 @@
+Index: src/network/nNetObject.cpp
+===================================================================
+--- src/network/nNetObject.cpp (revision 5965)
++++ src/network/nNetObject.cpp (working copy)
+@@ -661,6 +661,15 @@
+ #endif
+ m.Read( owner );
+
++ // clients are only allowed to create self-owned objects
++ if ( sn_GetNetState() == nSERVER )
++ {
++ if ( owner != m.SenderID() )
++ {
++ throw nKillHim();
++ }
++ }
++
+ registrar.object = this;
+ registrar.sender = m.SenderID();
+
diff --git a/games-action/armagetronad/files/digest-armagetronad-0.2.7.1-r1 b/games-action/armagetronad/files/digest-armagetronad-0.2.7.1-r1
new file mode 100644
index 000000000000..48aaee5e5d72
--- /dev/null
+++ b/games-action/armagetronad/files/digest-armagetronad-0.2.7.1-r1
@@ -0,0 +1,9 @@
+MD5 cc29c2fd7de5699173de84d7cde57b97 armagetronad-0.2.7.1.tar.bz2 1243746
+RMD160 0dcf9d383fccd42509cae3aacc2df0d5531bd021 armagetronad-0.2.7.1.tar.bz2 1243746
+SHA256 0ec8793f6d4d4f5a90feec1c8b0a4846aa4fa2c1f3c69a20b21b5e930d70992c armagetronad-0.2.7.1.tar.bz2 1243746
+MD5 e2d40309dde7e1339ca6aff7599cdfa3 moviepack.zip 352253
+RMD160 07c8b2aa48ad84092869c90e32d32a96d367afd5 moviepack.zip 352253
+SHA256 3de835e1e8af71f1dcbf5ac8405dfa87973eac50d206c12338278fc601cf9d78 moviepack.zip 352253
+MD5 3c5d04af52eb296cdeb2fba5ecbd8899 moviesounds_fq.zip 2182021
+RMD160 9fe95f3cc31bfdf9149bf850d5ae46ca5253a09a moviesounds_fq.zip 2182021
+SHA256 9f8061eb0fef416885424bdba9f899fc5b4d9a021f46eef4eb821a7f1e08c1ba moviesounds_fq.zip 2182021