summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-10-10 16:57:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-10-10 16:57:43 +0000
commitaaac0dd8106cb856a662c05a3f2b52674e0feceb (patch)
tree14cf874f27c33f6a059e560e3d1701e2c939ae6e /games-action/atanks/atanks-5.2.ebuild
parentFix patch name for USE=dns, bug #386619 (diff)
downloadgentoo-2-aaac0dd8106cb856a662c05a3f2b52674e0feceb.tar.gz
gentoo-2-aaac0dd8106cb856a662c05a3f2b52674e0feceb.tar.bz2
gentoo-2-aaac0dd8106cb856a662c05a3f2b52674e0feceb.zip
version bump
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'games-action/atanks/atanks-5.2.ebuild')
-rw-r--r--games-action/atanks/atanks-5.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-action/atanks/atanks-5.2.ebuild b/games-action/atanks/atanks-5.2.ebuild
new file mode 100644
index 000000000000..325a029b51d9
--- /dev/null
+++ b/games-action/atanks/atanks-5.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-5.2.ebuild,v 1.1 2011/10/10 16:57:43 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="http://atanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="<media-libs/allegro-5[X]"
+
+src_prepare() {
+ find . -type f -name ".directory" -exec rm -vf '{}' +
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ emake \
+ BINDIR="${GAMES_BINDIR}" \
+ INSTALLDIR="${GAMES_DATADIR}/${PN}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r button misc missile sound stock tank tankgun text title \
+ unicode.dat *.txt \
+ || die "doins failed"
+ doicon ${PN}.png
+ make_desktop_entry atanks "Atomic Tanks"
+ dodoc Changelog README TODO
+ prepgamesdirs
+}