summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-08-11 08:14:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-08-11 08:14:58 +0000
commit182d1da09b09636d7798bff31899bf96c723bac0 (patch)
treeb886d0c2275f6e79f4aa57a0b98241de4b12c2bd /games-action/atanks
parentversion bump (diff)
downloadgentoo-2-182d1da09b09636d7798bff31899bf96c723bac0.tar.gz
gentoo-2-182d1da09b09636d7798bff31899bf96c723bac0.tar.bz2
gentoo-2-182d1da09b09636d7798bff31899bf96c723bac0.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-action/atanks')
-rw-r--r--games-action/atanks/atanks-1.1.0.ebuild49
-rw-r--r--games-action/atanks/files/1.1.0-gentoo.patch107
-rw-r--r--games-action/atanks/files/atanks-1.1.0-gcc4.patch27
3 files changed, 0 insertions, 183 deletions
diff --git a/games-action/atanks/atanks-1.1.0.ebuild b/games-action/atanks/atanks-1.1.0.ebuild
deleted file mode 100644
index 9a2bc38ed870..000000000000
--- a/games-action/atanks/atanks-1.1.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-1.1.0.ebuild,v 1.17 2006/10/30 18:20:05 mr_bones_ Exp $
-
-inherit eutils toolchain-funcs games
-
-DESCRIPTION="Worms and Scorched Earth-like game"
-HOMEPAGE="http://atanks.sourceforge.net/"
-SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND="media-libs/allegro"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- DATA_DIR="${GAMES_DATADIR}/${PN}"
-
- unpack ${A}
- cd "${S}"
-
- epatch \
- "${FILESDIR}/${PV}-gentoo.patch" \
- "${FILESDIR}/${P}-gcc4.patch"
-
- sed -i \
- -e "s:DATA_DIR=.*:DATA_DIR=\\\\\"${DATA_DIR}\\\\\":" \
- src/Makefile \
- || die "sed src/Makefile failed"
-}
-
-src_install() {
- dogamesbin atanks || die "dogamesbin failed"
- insinto "${DATA_DIR}"
- doins {credits,gloat,instr,revenge}.txt *dat || die "doins failed"
- dodoc BUGS Changelog Help.txt tanks.txt README TODO
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- einfo "NOTE: If you had atanks version 0.9.8b or less installed"
- einfo "remove ~/.atanks-config to take advantage of new features."
-}
diff --git a/games-action/atanks/files/1.1.0-gentoo.patch b/games-action/atanks/files/1.1.0-gentoo.patch
deleted file mode 100644
index 3ad775640f2c..000000000000
--- a/games-action/atanks/files/1.1.0-gentoo.patch
+++ /dev/null
@@ -1,107 +0,0 @@
-Index: src/explosion.cc
-===================================================================
-RCS file: /cvsroot/atanks/atanks/src/explosion.cc,v
-retrieving revision 1.12
-diff -u -r1.12 explosion.cc
---- src/explosion.cc 1 Feb 2004 23:29:28 -0000 1.12
-+++ src/explosion.cc 10 Oct 2004 20:14:03 -0000
-@@ -159,7 +159,7 @@
- }
- if (distance <= (radius + TANKHEIGHT/2) && tank->l > 0) {
- _global->updateMenu = 1;
-- tank->damage = (int) ((float) damage * ((float) 1 - ((fabs (distance) / (float)radius) / 2)) * player->damageMultiplier);
-+ tank->damage = (int) ((player ? (float) damage * player->damageMultiplier : (float) damage) * ((float) 1 - ((fabs (distance) / (float)radius) / 2)));
-
- tank->creditTo = player;
- tank->applyDamage ();
-@@ -253,7 +253,7 @@
- if (a > 1 && a <= EXPLODEFRAMES + 1) {
- int startCirc = (radius / EXPLODEFRAMES) * a;
- circlefill (_env->terrain, (int)x, (int)y, startCirc, PINK);
-- circle (dest, (int)x, (int)y, startCirc, player->color);
-+ circle (dest, (int)x, (int)y, startCirc, player ? player->color : WHITE);
- setUpdateArea ((int)x - (radius + 1), (int)y - (radius + 1), (radius + 1) * 2, (radius + 1) * 2);
- }
- } else if ((type >= RIOT_CHARGE) && (type <= RIOT_BLAST)) {
-@@ -261,7 +261,7 @@
- double sx = x - _global->slope[angle][0] * 15;
- double sy = y - _global->slope[angle][1] * 15;
- int startCirc = (radius / EXPLODEFRAMES) * a;
-- triangle (dest, (int)sx, (int)sy, (int)(sx + _global->slope[(angle + 45) % 360][0] * startCirc), (int)(sy + _global->slope[(angle + 45) % 360][1] * startCirc),(int)(sx + _global->slope[(angle + 315) % 360][0] * startCirc),(int)(sy + _global->slope[(angle + 315) % 360][1] * startCirc), player->color);
-+ triangle (dest, (int)sx, (int)sy, (int)(sx + _global->slope[(angle + 45) % 360][0] * startCirc), (int)(sy + _global->slope[(angle + 45) % 360][1] * startCirc),(int)(sx + _global->slope[(angle + 315) % 360][0] * startCirc),(int)(sy + _global->slope[(angle + 315) % 360][1] * startCirc), player ? player->color : WHITE);
- setUpdateArea ((int)sx - (startCirc + 1), (int)sy - (startCirc + 1), (startCirc + 1) * 2, (startCirc + 1) * 2);
- }
- } else {
-Index: src/beam.cc
-===================================================================
-RCS file: /cvsroot/atanks/atanks/src/beam.cc,v
-retrieving revision 1.6
-diff -u -r1.6 beam.cc
---- src/beam.cc 4 Feb 2004 23:34:33 -0000 1.6
-+++ src/beam.cc 10 Oct 2004 20:14:03 -0000
-@@ -167,7 +167,7 @@
- if (targetX > ltank->x - TANKWIDTH - radius && targetX < ltank->x + TANKWIDTH + radius && targetY > ltank->y - radius && targetY < ltank->y + TANKHEIGHT + radius && ltank->l > 0) {
- //hitSomething = 1;
- ltank->requireUpdate ();
-- ltank->damage += damage * player->damageMultiplier;
-+ ltank->damage += player ? damage * player->damageMultiplier : damage;
- ltank->creditTo = player;
- if (destroy)
- ltank->applyDamage ();
-Index: src/tank.cc
-===================================================================
-RCS file: /cvsroot/atanks/atanks/src/tank.cc,v
-retrieving revision 1.20
-diff -u -r1.20 tank.cc
---- src/tank.cc 1 Feb 2004 23:29:28 -0000 1.20
-+++ src/tank.cc 10 Oct 2004 20:13:18 -0000
-@@ -171,7 +171,8 @@
- sh -= (int)damage;
- if (creditTo) {
- if (player != creditTo) { //enemy hit ++
-- creditTo->money += (int)(damage * _global->scoreHitUnit);
-+ double money = damage * _global->scoreHitUnit;
-+ creditTo->money += (money < LONG_MAX ? (int)money : LONG_MAX);
- if ((int)player->type != HUMAN_PLAYER) {
- if (player->revenge == creditTo) {
- player->annoyanceFactor += damage;
-Index: src/atanks.cc
-===================================================================
-RCS file: /cvsroot/atanks/atanks/src/atanks.cc,v
-retrieving revision 1.57
-diff -u -r1.57 atanks.cc
---- src/atanks.cc 4 Feb 2004 23:34:33 -0000 1.57
-+++ src/atanks.cc 10 Oct 2004 20:13:18 -0000
-@@ -1574,7 +1574,8 @@
- fi = global->stopwindow = updatename = scroll = 1;
- if (global->currentround != global->rounds) {
- for (z = 0; z < global->numPlayers; z++) {
-- global->players[z]->money = (long int) (global->players[z]->money * global->interest);
-+ double money = global->players[z]->money * global->interest;
-+ global->players[z]->money = (money < LONG_MAX ? (long int) money : LONG_MAX);
- }
- }
-
-@@ -2764,9 +2765,11 @@
- ltank->explode ();
- if (ltank->creditTo) {
- if (ltank->player != ltank->creditTo) { //enemy destroyed
-- ltank->creditTo->money += (int)global->scoreUnitDestroyBonus;
-+ double money = ltank->creditTo->money + global->scoreUnitDestroyBonus;
-+ ltank->creditTo->money = (money < LONG_MAX ? (long int)money : LONG_MAX);
- } else { //self destroy - ugh foolish one :))
- ltank->creditTo->money -= (int)global->scoreUnitSelfDestroy;
-+ if (ltank->creditTo->money < 0) ltank->creditTo->money = 0;
- }
- ltank->creditTo = NULL;
- }
-@@ -2808,7 +2811,8 @@
- if (winner >= 0) {
- global->players[winner]->score++;
- global->players[winner]->won++;
-- global->players[winner]->money += (long int)global->scoreRoundWinBonus;
-+ double money = global->players[winner]->money + global->scoreRoundWinBonus;
-+ global->players[winner]->money = (money < LONG_MAX ? (long int) money : LONG_MAX);
- }
- bCount = 0;
- global->updateMenu = 1;
diff --git a/games-action/atanks/files/atanks-1.1.0-gcc4.patch b/games-action/atanks/files/atanks-1.1.0-gcc4.patch
deleted file mode 100644
index 7b7d4b8f4aeb..000000000000
--- a/games-action/atanks/files/atanks-1.1.0-gcc4.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -ur atanks-orig/src/player.cc atanks/src/player.cc
---- atanks-orig/src/player.cc 2005-08-18 22:02:59.000000000 -0400
-+++ atanks/src/player.cc 2005-08-18 22:05:58.000000000 -0400
-@@ -1009,12 +1009,12 @@
- if (weapNum >= RIOT_CHARGE && weapNum <= RIOT_BLAST) {
- // add points only within range and above ctank
- if ( (cy > ctank->y - (radius / 2)) ||
-- (abs (ctank->x - cx) > radius))
-+ (fabs (ctank->x - cx) > radius))
- continue;
- } else if (weapNum >= SML_ROLLER && weapNum <= DTH_ROLLER) {
- // Only aim rollers above other tanks
- if (cy > tankY + TANKHEIGHT &&
-- abs (ctank->x - cx) > radius)
-+ fabs (ctank->x - cx) > radius)
- continue;
- } else if (weapNum >= SML_LAZER && weapNum <= LRG_LAZER) {
- // Lazer can only be aimed above horizontal
-@@ -1085,7 +1085,7 @@
- if (itemNum >= ITEM_VENGEANCE && itemNum <= ITEM_FATAL_FURY) {
- // add sqrt distances for each tank * potential damage
- long int totalEffectiveDamage = calcTotalEffectiveDamage (itemNum);
-- _targetMatrix[(int)ctank->x] += sqrt (abs (ctank->x - ltank->x)) * totalEffectiveDamage;
-+ _targetMatrix[(int)ctank->x] += sqrt (fabs (ctank->x - ltank->x)) * totalEffectiveDamage;
-
- }
- }