summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-05 21:05:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-05 21:05:37 +0000
commit136442cd355e6e435699cfd8cae55aa9586afa58 (patch)
tree371b9eb43aafe115cf70f22427806d5ff67a2c79 /games-action/blobandconquer
parentAdded the KDE 4.0.5 version of kanagram. (diff)
downloadgentoo-2-136442cd355e6e435699cfd8cae55aa9586afa58.tar.gz
gentoo-2-136442cd355e6e435699cfd8cae55aa9586afa58.tar.bz2
gentoo-2-136442cd355e6e435699cfd8cae55aa9586afa58.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-action/blobandconquer')
-rw-r--r--games-action/blobandconquer/ChangeLog8
-rw-r--r--games-action/blobandconquer/blobandconquer-0.94.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/games-action/blobandconquer/ChangeLog b/games-action/blobandconquer/ChangeLog
index 8d32a50f34ef..f5c4009de1bc 100644
--- a/games-action/blobandconquer/ChangeLog
+++ b/games-action/blobandconquer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/blobandconquer
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/blobandconquer/ChangeLog,v 1.6 2008/05/10 14:43:53 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/blobandconquer/ChangeLog,v 1.7 2008/06/05 21:05:37 mr_bones_ Exp $
+
+*blobandconquer-0.94 (05 Jun 2008)
+
+ 05 Jun 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +blobandconquer-0.94.ebuild:
+ version bump
*blobandconquer-0.93 (10 May 2008)
diff --git a/games-action/blobandconquer/blobandconquer-0.94.ebuild b/games-action/blobandconquer/blobandconquer-0.94.ebuild
new file mode 100644
index 000000000000..e4902cd5dad5
--- /dev/null
+++ b/games-action/blobandconquer/blobandconquer-0.94.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/blobandconquer/blobandconquer-0.94.ebuild,v 1.1 2008/06/05 21:05:37 mr_bones_ Exp $
+
+inherit eutils toolchain-funcs games
+
+MY_PN=blobAndConquer
+DESCRIPTION="Mission and objective based 3D action game"
+HOMEPAGE="http://www.parallelrealities.co.uk/blobAndConquer.php"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_compile() {
+ emake \
+ CXX=$(tc-getCXX) \
+ LIBPATH="${LDFLAGS}" \
+ DATADIR="${GAMES_DATADIR}"/${PN}/ \
+ DOCDIR=/usr/share/doc/${PF}/html/ \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${MY_PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data gfx music sound textures || die "doins failed"
+ doicon icons/${MY_PN}.png
+ domenu icons/${MY_PN}.desktop
+ cd doc
+ dohtml -r images pages index.html
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "Until ${PN}-1.0, save games may be incompatible with previous"
+ ewarn "versions."
+}