summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-01-09 17:39:34 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-01-09 17:39:34 +0000
commit26cea150dd4acff964ae32663594975a6cff9293 (patch)
treea28e99ad62bab4b16d86beb11015375e14501b1a /games-action/btanks
parentTransfer Prefix keywords (diff)
downloadgentoo-2-26cea150dd4acff964ae32663594975a6cff9293.tar.gz
gentoo-2-26cea150dd4acff964ae32663594975a6cff9293.tar.bz2
gentoo-2-26cea150dd4acff964ae32663594975a6cff9293.zip
Version bump to 0.9.8083 Bug #300053
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-action/btanks')
-rw-r--r--games-action/btanks/ChangeLog10
-rw-r--r--games-action/btanks/btanks-0.8.7686.ebuild4
-rw-r--r--games-action/btanks/btanks-0.9.8083.ebuild57
-rw-r--r--games-action/btanks/files/btanks-0.9.8083-scons-blows.patch93
4 files changed, 160 insertions, 4 deletions
diff --git a/games-action/btanks/ChangeLog b/games-action/btanks/ChangeLog
index 537fcaec20df..7d0a140c4f38 100644
--- a/games-action/btanks/ChangeLog
+++ b/games-action/btanks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/btanks
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.20 2009/05/23 22:09:59 nyhm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/ChangeLog,v 1.21 2010/01/09 17:39:33 tupone Exp $
+
+*btanks-0.9.8083 (09 Jan 2010)
+
+ 09 Jan 2010; Tupone Alfredo <tupone@gentoo.org> +btanks-0.9.8083.ebuild,
+ +files/btanks-0.9.8083-scons-blows.patch:
+ Version bump to 0.9.8083 Bug #300053 by Arseny Solokha
23 May 2009; Tristan Heaven <nyhm@gentoo.org> btanks-0.8.7686.ebuild,
files/btanks-0.8.7686-scons-blows.patch:
diff --git a/games-action/btanks/btanks-0.8.7686.ebuild b/games-action/btanks/btanks-0.8.7686.ebuild
index 6c1482d9c8af..9fcd98d2ef0d 100644
--- a/games-action/btanks/btanks-0.8.7686.ebuild
+++ b/games-action/btanks/btanks-0.8.7686.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.8.7686.ebuild,v 1.10 2009/11/23 01:37:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.8.7686.ebuild,v 1.11 2010/01/09 17:39:33 tupone Exp $
EAPI=2
inherit eutils games
diff --git a/games-action/btanks/btanks-0.9.8083.ebuild b/games-action/btanks/btanks-0.9.8083.ebuild
new file mode 100644
index 000000000000..21e4028cffee
--- /dev/null
+++ b/games-action/btanks/btanks-0.9.8083.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/btanks/btanks-0.9.8083.ebuild,v 1.1 2010/01/09 17:39:33 tupone Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Fast 2D tank arcade game with multiplayer and split-screen modes"
+HOMEPAGE="http://btanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1
+ media-libs/libsdl[joystick,video]
+ media-libs/libvorbis
+ virtual/opengl
+ dev-libs/expat
+ media-libs/smpeg
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-gfx"
+DEPEND="${RDEPEND}
+ dev-util/scons
+ dev-util/pkgconfig"
+
+src_prepare() {
+ rm -rf sdlx/gfx
+ epatch "${FILESDIR}"/${P}-scons-blows.patch
+}
+
+src_compile() {
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
+
+ scons \
+ ${sconsopts} \
+ prefix="${GAMES_PREFIX}" \
+ lib_dir="$(games_get_libdir)"/${PN} \
+ plugins_dir="$(games_get_libdir)"/${PN} \
+ resources_dir="${GAMES_DATADIR}"/${PN} \
+ || die "scons failed"
+}
+
+src_install() {
+ dogamesbin build/release/engine/btanks || die "dogamesbin failed"
+ newgamesbin build/release/editor/bted btanksed || die "newgamesbin failed"
+ exeinto "$(games_get_libdir)"/${PN}
+ doexe build/release/*/*.so || die "doexe failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data || die "doins failed"
+ newicon engine/src/bt.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Battle Tanks"
+ dodoc ChangeLog *.txt
+ prepgamesdirs
+}
diff --git a/games-action/btanks/files/btanks-0.9.8083-scons-blows.patch b/games-action/btanks/files/btanks-0.9.8083-scons-blows.patch
new file mode 100644
index 000000000000..47ce410f0bf8
--- /dev/null
+++ b/games-action/btanks/files/btanks-0.9.8083-scons-blows.patch
@@ -0,0 +1,93 @@
+--- mrt/export_base.h.old 2010-01-09 17:38:47.000000000 +0100
++++ mrt/export_base.h 2010-01-09 17:39:23.000000000 +0100
+@@ -1,7 +1,7 @@
+ #ifndef MRT_EXPORT_MACRO_H__
+ #define MRT_EXPORT_MACRO_H__
+
+-// Shared library support
++/* Shared library support */
+ #ifdef _WINDOWS
+
+ # pragma warning(disable:4251) /* needs to have dll-interface used by client */
+--- SConstruct.old 2010-01-09 17:43:36.000000000 +0100
++++ SConstruct 2010-01-09 17:45:25.000000000 +0100
+@@ -50,7 +50,7 @@
+ if os.environ.has_key('CC'):
+ env['CC'] = os.environ['CC']
+ if os.environ.has_key('CFLAGS'):
+- env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++ env['CFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
+ if os.environ.has_key('CXX'):
+ env['CXX'] = os.environ['CXX']
+ if os.environ.has_key('CXXFLAGS'):
+@@ -91,19 +91,9 @@
+ #env.Append(CPPDEFINES = ['NDEBUG'])
+
+ else:
+- if env['gcc_visibility']:
+- env.Append(CCFLAGS=['-fvisibility=hidden']);
+- env.Append(CXXFLAGS=['-fvisibility-inlines-hidden', '-fvisibility=hidden']);
+-
+- if debug:
+- env.Append(CCFLAGS=['-ggdb', '-D_FORTIFY_SOURCE=2'])
+- env.Append(CPPFLAGS=['-ggdb', '-D_FORTIFY_SOURCE=2'])
+- else:
+- env.Append(CCFLAGS=['-O3'])
+- env.Append(CPPFLAGS=['-O3'])
+
+- env.Append(CPPFLAGS=['-Wall', '-Wno-deprecated', '-pedantic', '-Wno-long-long', '-pipe', '-pthread'])
+- env.Append(CCFLAGS=['-Wall', '-Wno-deprecated', '-pedantic', '-Wno-long-long', '-pipe', '-pthread'])
++ env.Append(CPPFLAGS=['-Wall', '-Wno-deprecated', '-pedantic', '-Wno-long-long', '-pthread'])
++ env.Append(CCFLAGS=['-Wall', '-Wno-deprecated', '-pedantic', '-Wno-long-long', '-pthread'])
+
+
+ conf_env = env.Clone()
+--- sdlx/SConscript.old 2010-01-09 17:46:05.000000000 +0100
++++ sdlx/SConscript 2010-01-09 17:46:55.000000000 +0100
+@@ -12,7 +12,7 @@
+
+ env.MergeFlags(sdl_cflags, sdl_libs)
+
+-libs = ['mrt', 'SDL', 'SDL_image']
++libs = ['mrt', 'SDL', 'SDL_image', 'SDL_gfx']
+
+ if sys.platform != "win32":
+ c_map_env= env.Clone()
+@@ -35,7 +35,6 @@
+ sdlx_sources = ['cursor.cpp', 'sdl_ex.cpp', 'surface.cpp', 'system.cpp', 'joystick.cpp',
+ 'thread.cpp', 'mutex.cpp', 'semaphore.cpp', 'color.cpp',
+ c_map, 'font.cpp', 'timer.cpp', 'module.cpp', 'file_rw.cpp',
+- 'gfx/SDL_rotozoom.c',
+ ] # 'ttf.cpp',
+
+ if sys.platform == 'win32':
+--- sdlx/surface.cpp.old 2010-01-09 17:47:33.000000000 +0100
++++ sdlx/surface.cpp 2010-01-09 17:48:19.000000000 +0100
+@@ -425,7 +425,7 @@
+ throw_sdl(("SDL_SetColorKey"));
+ }
+
+-#include "gfx/SDL_rotozoom.h"
++#include <SDL_rotozoom.h>
+
+ void Surface::rotozoom(const sdlx::Surface &src, double angle, double zoom, bool smooth) {
+ if (src.isNull())
+--- sdlx/wrappers/glSDL.c.old 2010-01-09 17:48:50.000000000 +0100
++++ sdlx/wrappers/glSDL.c 2010-01-09 17:49:23.000000000 +0100
+@@ -11,8 +11,6 @@
+
+ #ifdef HAVE_OPENGL
+
+-//#define LEAK_TRACKING
+-
+ #define DBG(x) /*error messages, warnings*/
+ #define DBG2(x) /*texture allocation*/
+ #define DBG3(x) /*chopping/tiling*/
+@@ -951,7 +949,6 @@
+ }
+ gl_doublebuf = flags & SDL_DOUBLEBUF;
+ SDL_GL_SetAttribute(SDL_GL_DOUBLEBUFFER, gl_doublebuf);
+- //SDL_GL_SetAttribute(SDL_GL_SWAP_CONTROL, gl_doublebuf ? 1: 0);
+
+ scale = 1;
+