summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-19 17:27:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-19 17:27:52 +0000
commit69d7500c79392c4a888334dd5b4d319f46794fcc (patch)
treebfc5b3cd2c01447910a29a22fe1b1f609b03fc5d /games-action/bzflag
parentNo longer rely on existance of /lib/librc.so to check for openrc as this is k... (diff)
downloadgentoo-2-69d7500c79392c4a888334dd5b4d319f46794fcc.tar.gz
gentoo-2-69d7500c79392c4a888334dd5b4d319f46794fcc.tar.bz2
gentoo-2-69d7500c79392c4a888334dd5b4d319f46794fcc.zip
EAPI=2; add use-based dep; tidy
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
Diffstat (limited to 'games-action/bzflag')
-rw-r--r--games-action/bzflag/ChangeLog7
-rw-r--r--games-action/bzflag/bzflag-2.0.12.ebuild21
2 files changed, 13 insertions, 15 deletions
diff --git a/games-action/bzflag/ChangeLog b/games-action/bzflag/ChangeLog
index dd71b0d4ea38..f4dde5eedf14 100644
--- a/games-action/bzflag/ChangeLog
+++ b/games-action/bzflag/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/bzflag
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.39 2008/09/21 13:51:22 ranger Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.40 2009/01/19 17:27:52 mr_bones_ Exp $
+
+ 19 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> bzflag-2.0.12.ebuild:
+ EAPI=2; add use-based dep; tidy
21 Sep 2008; Brent Baude <ranger@gentoo.org> bzflag-2.0.12.ebuild:
stable ppc, bug 238056
diff --git a/games-action/bzflag/bzflag-2.0.12.ebuild b/games-action/bzflag/bzflag-2.0.12.ebuild
index fd42d519973d..e116594e0e3e 100644
--- a/games-action/bzflag/bzflag-2.0.12.ebuild
+++ b/games-action/bzflag/bzflag-2.0.12.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.0.12.ebuild,v 1.5 2008/09/21 13:51:22 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-2.0.12.ebuild,v 1.6 2009/01/19 17:27:52 mr_bones_ Exp $
+EAPI=2
inherit eutils flag-o-matic games
DESCRIPTION="3D tank combat simulator game"
@@ -28,7 +29,7 @@ UIDEPEND="virtual/opengl
x11-libs/libXt
x11-libs/libXxf86vm"
-DEPEND=">=net-misc/curl-7.15.0
+DEPEND=">=net-misc/curl-7.15.0[ares]
sys-libs/ncurses
net-dns/c-ares
sdl? ( ${UIDEPEND} )
@@ -37,15 +38,10 @@ DEPEND=">=net-misc/curl-7.15.0
pkg_setup() {
# Only do the libsdl checks for !dedicated - bug #107792
use dedicated || GAMES_USE_SDL="nojoystick"
- if ! built_with_use net-misc/curl ares; then
- ewarn "net-misc/curl is not built with c-ares support"
- ewarn "To avoid undesired glitch during play consider"
- ewarn "emerging net-misc/curl with USE=\"ares\"."
- fi
games_pkg_setup
}
-src_compile() {
+src_configure() {
local myconf
if use dedicated && ! use sdl ; then
@@ -59,16 +55,15 @@ src_compile() {
--without-regex \
${myconf} \
|| die "egamesconf failed"
- emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS TODO ChangeLog BUGS PORTING DEVINFO NEWS README* RELNOTES
if use sdl || ! use dedicated ; then
- doicon "data/bzflag-48x48.png"
- make_desktop_entry ${PN} "BZFlag" ${PN}-48x48
+ newicon "data/bzflag-48x48.png" ${PN}.png
+ make_desktop_entry ${PN} "BZFlag"
fi
prepgamesdirs