summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-03-07 21:28:29 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-03-07 21:28:29 +0000
commit8e1aaee64b3f405407de4b9f21e33a17c8162049 (patch)
tree79b483f384aa21b67f35ca17883251cec913f114 /games-action/cs2d
parentVersion bump. (diff)
downloadgentoo-2-8e1aaee64b3f405407de4b9f21e33a17c8162049.tar.gz
gentoo-2-8e1aaee64b3f405407de4b9f21e33a17c8162049.tar.bz2
gentoo-2-8e1aaee64b3f405407de4b9f21e33a17c8162049.zip
Bump tp 0120, thanks to oleg@kaa.org.ua
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-action/cs2d')
-rw-r--r--games-action/cs2d/ChangeLog7
-rw-r--r--games-action/cs2d/cs2d-0120.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/games-action/cs2d/ChangeLog b/games-action/cs2d/ChangeLog
index 326dc33311cc..f794d54464f0 100644
--- a/games-action/cs2d/ChangeLog
+++ b/games-action/cs2d/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/cs2d
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/cs2d/ChangeLog,v 1.2 2012/03/03 13:39:26 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/cs2d/ChangeLog,v 1.3 2012/03/07 21:28:29 maksbotan Exp $
+
+*cs2d-0120 (07 Mar 2012)
+
+ 07 Mar 2012; Maxim Koltsov <maksbotan@gentoo.org> +cs2d-0120.ebuild:
+ Bump tp 0120, thanks to oleg@kaa.org.ua
03 Mar 2012; Maxim Koltsov <maksbotan@gentoo.org> cs2d-0119.ebuild:
Add app-arch/unzip DEPEND, bug #406677. Thanks to szarpaj@grubelek.pl
diff --git a/games-action/cs2d/cs2d-0120.ebuild b/games-action/cs2d/cs2d-0120.ebuild
new file mode 100644
index 000000000000..df1c7e182c44
--- /dev/null
+++ b/games-action/cs2d/cs2d-0120.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/cs2d/cs2d-0120.ebuild,v 1.1 2012/03/07 21:28:29 maksbotan Exp $
+
+EAPI=2
+
+inherit eutils games
+
+DESCRIPTION="Counter-Strike 2D is freeware clone of Counter-Strike with some added features in gameplay."
+HOMEPAGE="http://www.cs2d.com/"
+SRC_URI="http://dev.gentoo.org/~maksbotan/cs2d/cs2d_${PV}_linux.zip
+ http://dev.gentoo.org/~maksbotan/cs2d/cs2d_${PV}_win.zip"
+LICENSE="freedist"
+
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="x86? (
+ media-libs/openal )
+ amd64? (
+ app-emulation/emul-linux-x86-sdl
+ )"
+
+QA_PRESTRIPPED="opt/cs2d/CounterStrike2D"
+QA_EXECSTACK="opt/cs2d/CounterStrike2D"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+
+ # removing windows files
+ rm -f *.exe *.bat
+}
+
+src_install() {
+ insinto "${GAMES_PREFIX_OPT}/${PN}"
+ doins -r . || die
+
+ doicon "${FILESDIR}/cs2d.png"
+
+ make_desktop_entry CounterStrike2D "Counter Strike 2D"
+ make_desktop_entry "CounterStrike2D -fullscreen -24bit" "Counter Strike 2D - FULLSCREEN"
+ games_make_wrapper CounterStrike2D ./CounterStrike2D \
+ "${GAMES_PREFIX_OPT}"/${PN} "${GAMES_PREFIX_OPT}"/${PN}
+
+ prepgamesdirs
+
+ # OpenAL is default sound driver
+ sed -i 's:^sounddriver.*$:sounddriver OpenAL Default:' "${D}/${GAMES_PREFIX_OPT}/${PN}/sys/config.cfg"
+
+ # fixing permissions
+ chmod -R g+w "${D}/${GAMES_PREFIX_OPT}/${PN}/maps"
+ chmod -R g+w "${D}/${GAMES_PREFIX_OPT}/${PN}/screens"
+ chmod -R g+w "${D}/${GAMES_PREFIX_OPT}/${PN}/sys"
+ fperms ug+x "${GAMES_PREFIX_OPT}/${PN}/CounterStrike2D"
+}