summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-14 18:19:30 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-14 18:19:30 +0000
commit708469cba9d8c92a4477d04491718a829596a369 (patch)
treec2a574bcad748969949ead9a17cee5e7e6f67655 /games-action/d2x
parentAdded ~mips keyword. (Manifest recommit) (diff)
downloadgentoo-2-708469cba9d8c92a4477d04491718a829596a369.tar.gz
gentoo-2-708469cba9d8c92a4477d04491718a829596a369.tar.bz2
gentoo-2-708469cba9d8c92a4477d04491718a829596a369.zip
ppc support
Diffstat (limited to 'games-action/d2x')
-rw-r--r--games-action/d2x/d2x-0.2.5.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/games-action/d2x/d2x-0.2.5.ebuild b/games-action/d2x/d2x-0.2.5.ebuild
index 76377071b464..bf0e689304f0 100644
--- a/games-action/d2x/d2x-0.2.5.ebuild
+++ b/games-action/d2x/d2x-0.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5.ebuild,v 1.2 2004/02/20 06:13:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5.ebuild,v 1.3 2004/03/14 18:19:30 vapier Exp $
inherit games flag-o-matic eutils
@@ -12,7 +12,7 @@ SRC_URI="http://icculus.org/d2x/src/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ppc"
IUSE="debug opengl ggi svga"
DEPEND="media-libs/libsdl
@@ -33,7 +33,7 @@ src_unpack() {
src_compile() {
# --disable-network --enable-console
local myconf="`use_enable x86 assembler`"
- [ `use debug` ] \
+ use debug \
&& debugconf="${myconf} --enable-debug --disable-release" \
|| debugconf="${myconf} --disable-debug --enable-release"
# we do this because each of the optional guys define the same functions