summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-02-15 23:37:02 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-02-15 23:37:02 +0000
commit32183907157706df2c030329b5fc56f1d634f107 (patch)
tree57d562584c48ec4ac30a0c5c82b34f254fc15816 /games-action/descent3
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-32183907157706df2c030329b5fc56f1d634f107.tar.gz
gentoo-2-32183907157706df2c030329b5fc56f1d634f107.tar.bz2
gentoo-2-32183907157706df2c030329b5fc56f1d634f107.zip
Updated to use new cdrom_get_cds routine in eutils.eclass.
Diffstat (limited to 'games-action/descent3')
-rw-r--r--games-action/descent3/ChangeLog7
-rw-r--r--games-action/descent3/descent3-1.4.0b.ebuild29
2 files changed, 19 insertions, 17 deletions
diff --git a/games-action/descent3/ChangeLog b/games-action/descent3/ChangeLog
index b4297d04b6d6..871f4c51c4d9 100644
--- a/games-action/descent3/ChangeLog
+++ b/games-action/descent3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/descent3
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/ChangeLog,v 1.2 2003/09/10 20:31:16 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/ChangeLog,v 1.3 2004/02/15 23:37:02 wolf31o2 Exp $
+
+ 15 Feb 2004; Chris Gianelloni <wolf31o2@gentoo.org> descent3-1.4.0b.ebuild:
+ Updated to use new cdrom_get_cds routine in eutils.eclass.
*descent3-1.4.0b (28 Jul 2003)
diff --git a/games-action/descent3/descent3-1.4.0b.ebuild b/games-action/descent3/descent3-1.4.0b.ebuild
index 5cbcfeed01cc..950e6d4a092c 100644
--- a/games-action/descent3/descent3-1.4.0b.ebuild
+++ b/games-action/descent3/descent3-1.4.0b.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/descent3-1.4.0b.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/descent3/descent3-1.4.0b.ebuild,v 1.2 2004/02/15 23:37:02 wolf31o2 Exp $
inherit games
@@ -19,14 +19,15 @@ DEPEND="virtual/glibc"
RDEPEND="${DEPEND}
virtual/opengl"
-S=${WORKDIR}
-
dir=${GAMES_PREFIX_OPT}/${PN}
Ddir=${D}/${dir}
pkg_setup() {
if [ "`use videos`" ]; then
ewarn "The installed game takes about 1.2GB of space!"
+ cdrom_get_cds missions/d3.mn3 movies/level1.mve
+ else
+ cdrom_get_cds missions/d3.mn3
fi
if [ "`use nocd`" ]; then
ewarn "The installed game takes about 510MB of space!"
@@ -46,26 +47,24 @@ src_unpack() {
src_install() {
dodir ${dir}
- games_get_cd missions/d3.mn3
- games_verify_cd "Descent 3 Disk 1"
einfo "Copying files... this may take a while..."
exeinto /opt/descent3
- doexe ${GAMES_CD}/bin/x86/glibc-2.1/{descent3,nettest}
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/{descent3,nettest}
insinto /opt/descent3
- cp ${GAMES_CD}/{FAQ.txt,README,README.mercenary,d3.hog,icon.{bmp,xpm}} ${Ddir}
+ cp ${CDROM_ROOT}/{FAQ.txt,README,README.mercenary,d3.hog,icon.{bmp,xpm}} \
+ ${Ddir}
cd ${Ddir}
- tar xzf ${GAMES_CD}/data.tar.gz || die "uncompressing data"
- tar xzf ${GAMES_CD}/shared.tar.gz || die "uncompressing shared"
+ tar xzf ${CDROM_ROOT}/data.tar.gz || die "uncompressing data"
+ tar xzf ${CDROM_ROOT}/shared.tar.gz || die "uncompressing shared"
- use nocd && cp ${GAMES_CD}/missions/* ${Ddir}/missions
+ use nocd && cp ${CDROM_ROOT}/missions/* ${Ddir}/missions
if [ "`use videos`" ]; then
- games_get_cd movies/level1.mve
- games_verify_cd "Descent 3 Disk 2"
- cp ${GAMES_CD}/movies/* ${Ddir}/movies || die "copying movies"
+ cdrom_load_next_cd
+ cp ${CDROM_ROOT}/movies/* ${Ddir}/movies || die "copying movies"
fi
cd ${S}/a
@@ -84,7 +83,7 @@ src_install() {
dogamesbin ${FILESDIR}/descent3
dosed "s:GENTOO_DIR:${dir}:" ${GAMES_BINDIR}/descent3
insinto /usr/share/pixmaps
- newins ${GAMES_CD}/icon.xpm descent3.xpm
+ newins ${CDROM_ROOT}/icon.xpm descent3.xpm
prepgamesdirs
make_desktop_entry descent3 "Descent 3" "descent3.xpm"