summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-01-05 21:57:39 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-01-05 21:57:39 +0000
commit16fcbe8c8e5197a8f73ae4639d4d171bc6bedd5b (patch)
tree9c37503192e18abf1f226b481df6b056ac23a02a /games-action/geki2-KXL/geki2-KXL-2.0.3-r2.ebuild
parentuse laptop useflag as per requests from a few people (diff)
downloadgentoo-2-16fcbe8c8e5197a8f73ae4639d4d171bc6bedd5b.tar.gz
gentoo-2-16fcbe8c8e5197a8f73ae4639d4d171bc6bedd5b.tar.bz2
gentoo-2-16fcbe8c8e5197a8f73ae4639d4d171bc6bedd5b.zip
Use autotools eclass, bug #204394; install menu entry, bug #159752; move score file to $GAMES_STATEDIR
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'games-action/geki2-KXL/geki2-KXL-2.0.3-r2.ebuild')
-rw-r--r--games-action/geki2-KXL/geki2-KXL-2.0.3-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-action/geki2-KXL/geki2-KXL-2.0.3-r2.ebuild b/games-action/geki2-KXL/geki2-KXL-2.0.3-r2.ebuild
new file mode 100644
index 000000000000..4aaa97897d15
--- /dev/null
+++ b/games-action/geki2-KXL/geki2-KXL-2.0.3-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/geki2-KXL/geki2-KXL-2.0.3-r2.ebuild,v 1.1 2008/01/05 21:57:38 nyhm Exp $
+
+inherit autotools eutils games
+
+DESCRIPTION="2D length scroll shooting game"
+HOMEPAGE="http://kxl.hn.org/"
+SRC_URI="http://kxl.hn.org/download/${P}.tar.gz
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-games/KXL"
+RDEPEND="${DEPEND}
+ media-fonts/font-bitstream-75dpi"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f missing
+ sed -i \
+ -e '1i #include <string.h>' \
+ -e "s:DATA_PATH \"/.score\":\"${GAMES_STATEDIR}/${PN}\":" \
+ src/ranking.c \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-paths.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto "${GAMES_STATEDIR}"
+ newins data/.score ${PN} || die "newins failed"
+ fperms g+w "${GAMES_STATEDIR}"/${PN}
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry geki2 Geki2
+ dodoc ChangeLog README
+ prepgamesdirs
+}