summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-07 15:07:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-07 15:07:16 +0000
commit411e5121de6c8f1eda46a6b47f13ddd3fa359273 (patch)
treeca9695f466b4cf1b4bedd336491331de4467c43c /games-action/orbz-demo
parentbump (diff)
downloadgentoo-2-411e5121de6c8f1eda46a6b47f13ddd3fa359273.tar.gz
gentoo-2-411e5121de6c8f1eda46a6b47f13ddd3fa359273.tar.bz2
gentoo-2-411e5121de6c8f1eda46a6b47f13ddd3fa359273.zip
metadata
Diffstat (limited to 'games-action/orbz-demo')
-rw-r--r--games-action/orbz-demo/files/digest-orbz-demo-2.101
-rw-r--r--games-action/orbz-demo/metadata.xml35
-rw-r--r--games-action/orbz-demo/orbz-demo-2.10.ebuild45
3 files changed, 81 insertions, 0 deletions
diff --git a/games-action/orbz-demo/files/digest-orbz-demo-2.10 b/games-action/orbz-demo/files/digest-orbz-demo-2.10
new file mode 100644
index 000000000000..37a818e9e3c6
--- /dev/null
+++ b/games-action/orbz-demo/files/digest-orbz-demo-2.10
@@ -0,0 +1 @@
+MD5 bb2692618644a0ec9a4d4e8557543608 orbz_gg_2_10.sh.bin 15255281
diff --git a/games-action/orbz-demo/metadata.xml b/games-action/orbz-demo/metadata.xml
new file mode 100644
index 000000000000..076308ce7f35
--- /dev/null
+++ b/games-action/orbz-demo/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+ <name>Mike Frysinger</name>
+</maintainer>
+<longdescription>
+Orbz is an action/arcade game set in colorful 3D environments. The object
+of the game is to shoot your orb at targets located throughout 14 distinct
+courses in a race to score the most points. Game play contains both
+intense action and also strategy in planning the best scoring shots.
+Power-ups, like the "Money Shot" and "Curse of the Goober", are also
+available to either give you a scoring advantage or to slow down your
+opponents.
+
+In Solo Mode, the player completes a series of progressively difficult
+challenges that focus on scoring the most points in different scenarios.
+Bronze, Silver, and Gold medals are awarded for scoring performance and
+high scores for each challenge are tracked world-wide against all other
+Orbz players. For every 5 gold medals achieved, the player will also
+unlock a fancy new Orb to use in Solo or Online mode. Finally, there is a
+tutorial mode that will teach the player basics controls and scoring
+strategies.
+
+The Online Mode allows Orbz players to compete against each other over the
+Internet or Local Area Network. Up to 10 players, including computer
+opponents called Botz, can join a Lobby where the matches will be
+coordinated by selecting the course to play, number of rounds in the
+match, and a per-round time limit. A world-wide ranking system is also
+available for those who wish to compete for the ultimate title of Orbz
+Champion.
+</longdescription>
+</pkgmetadata>
diff --git a/games-action/orbz-demo/orbz-demo-2.10.ebuild b/games-action/orbz-demo/orbz-demo-2.10.ebuild
new file mode 100644
index 000000000000..83d751fea3df
--- /dev/null
+++ b/games-action/orbz-demo/orbz-demo-2.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/orbz-demo/orbz-demo-2.10.ebuild,v 1.1 2003/10/07 15:07:16 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="action/arcade game set in colorful 3D environments"
+HOMEPAGE="http://www.21-6.com/orbz.asp"
+SRC_URI="ftp://ggdev-1.homelan.com/orbz/orbz_gg_${PV/./_}.sh.bin"
+
+LICENSE="ORBZ"
+SLOT="0"
+KEYWORDS="-* x86"
+
+DEPEND=""
+
+S=${WORKDIR}
+
+pkg_setup() {
+ check_license
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir ${dir} ${GAMES_BINDIR}
+
+ tar -zxf Orbz.tar.gz -C ${D}/${dir} || die "extracting orbz.tar.gz"
+
+ exeinto ${dir}
+ doexe bin/Linux/x86/*
+ dosym ${dir}/orbz ${GAMES_BINDIR}/orbz
+ dosym ${dir}/orbzdedicated ${GAMES_BINDIR}/orbzdedicated
+
+ insinto ${dir}
+ doins icon.xpm
+
+ dodoc README.txt
+
+ prepgamesdirs
+}