summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-26 00:37:27 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-26 00:37:27 +0000
commit45d255b46571503ae5104c9a166556ecbacc879a (patch)
tree9e807be7215eb4146d9d42d9916778b4fe76fcaa /games-action/trackballs
parentSPARC lovin (diff)
downloadgentoo-2-45d255b46571503ae5104c9a166556ecbacc879a.tar.gz
gentoo-2-45d255b46571503ae5104c9a166556ecbacc879a.tar.bz2
gentoo-2-45d255b46571503ae5104c9a166556ecbacc879a.zip
Version bump, bug #179857
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'games-action/trackballs')
-rw-r--r--games-action/trackballs/ChangeLog7
-rw-r--r--games-action/trackballs/files/digest-trackballs-1.1.46
-rw-r--r--games-action/trackballs/trackballs-1.1.4.ebuild58
3 files changed, 70 insertions, 1 deletions
diff --git a/games-action/trackballs/ChangeLog b/games-action/trackballs/ChangeLog
index f7d89595c2d2..2389f4510dcd 100644
--- a/games-action/trackballs/ChangeLog
+++ b/games-action/trackballs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/trackballs
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/ChangeLog,v 1.19 2007/01/10 19:43:17 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/ChangeLog,v 1.20 2007/07/26 00:37:27 nyhm Exp $
+
+*trackballs-1.1.4 (26 Jul 2007)
+
+ 26 Jul 2007; Tristan Heaven <nyhm@gentoo.org> +trackballs-1.1.4.ebuild:
+ Version bump, bug #179857
10 Jan 2007; Piotr Jaroszyński <peper@gentoo.org>
trackballs-1.1.2.ebuild:
diff --git a/games-action/trackballs/files/digest-trackballs-1.1.4 b/games-action/trackballs/files/digest-trackballs-1.1.4
new file mode 100644
index 000000000000..15e11fb3ed5d
--- /dev/null
+++ b/games-action/trackballs/files/digest-trackballs-1.1.4
@@ -0,0 +1,6 @@
+MD5 84e2e8bb68842a636da91673751279a0 trackballs-1.1.4.tar.gz 7229541
+RMD160 6f3873fcfcbbc2cb13b491309a1c2f31333fc9c0 trackballs-1.1.4.tar.gz 7229541
+SHA256 459dbaec27354fb4afff3d1aa491bc21b4fc2c0769eae86a47aaeb545cb434a6 trackballs-1.1.4.tar.gz 7229541
+MD5 68be5fe2ed2381e73863a9858d02064d trackballs-music-1.2.tar.bz2 16064336
+RMD160 5400f47dcf42fe074fce2b465359ace182b857e7 trackballs-music-1.2.tar.bz2 16064336
+SHA256 3266499f8441619dd9332494c8ab99d240544e2469fb045f14a9312136d4ad88 trackballs-music-1.2.tar.bz2 16064336
diff --git a/games-action/trackballs/trackballs-1.1.4.ebuild b/games-action/trackballs/trackballs-1.1.4.ebuild
new file mode 100644
index 000000000000..ecc2c911e27c
--- /dev/null
+++ b/games-action/trackballs/trackballs-1.1.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/trackballs/trackballs-1.1.4.ebuild,v 1.1 2007/07/26 00:37:27 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="simple game similar to the classical game Marble Madness"
+HOMEPAGE="http://trackballs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${PN}-music-1.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ >=dev-scheme/guile-1.8
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's/icons //' share/Makefile.in \
+ || die "sed failed"
+ sed -i \
+ -e '/^localedir/s:=.*:=/usr/share/locale:' \
+ src/Makefile.in \
+ po/Makefile.in.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-highscores="${GAMES_STATEDIR}"/${PN}-highscores \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto "${GAMES_DATADIR}"/${PN}/music
+ doins "${WORKDIR}"/tb_*.ogg || die "doins failed"
+ newicon share/icons/${PN}-64x64.png ${PN}.png
+ make_desktop_entry ${PN} Trackballs
+ dodoc AUTHORS ChangeLog FAQ NEWS README TODO
+ prepgamesdirs
+}