summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-06-12 00:53:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-06-12 00:53:19 +0000
commit178ffdfa9c6346812917e614d929d8f04faadd86 (patch)
tree20e1a880c848fe7d285bfb37fd337c318b50da0c /games-action/wordwarvi
parentSupport autoconf-9999 #370753. (diff)
downloadgentoo-2-178ffdfa9c6346812917e614d929d8f04faadd86.tar.gz
gentoo-2-178ffdfa9c6346812917e614d929d8f04faadd86.tar.bz2
gentoo-2-178ffdfa9c6346812917e614d929d8f04faadd86.zip
version bump
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'games-action/wordwarvi')
-rw-r--r--games-action/wordwarvi/ChangeLog10
-rw-r--r--games-action/wordwarvi/files/wordwarvi-1.00-sound.patch80
-rw-r--r--games-action/wordwarvi/wordwarvi-1.00.ebuild55
3 files changed, 143 insertions, 2 deletions
diff --git a/games-action/wordwarvi/ChangeLog b/games-action/wordwarvi/ChangeLog
index 2acb3d257a4b..112a1b44def1 100644
--- a/games-action/wordwarvi/ChangeLog
+++ b/games-action/wordwarvi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/wordwarvi
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/ChangeLog,v 1.7 2010/02/08 22:52:26 mr_bones_ Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/ChangeLog,v 1.8 2011/06/12 00:53:19 mr_bones_ Exp $
+
+*wordwarvi-1.00 (12 Jun 2011)
+
+ 12 Jun 2011; Michael Sterrett <mr_bones_@gentoo.org> +wordwarvi-1.00.ebuild,
+ +files/wordwarvi-1.00-sound.patch:
+ version bump
08 Feb 2010; Michael Sterrett <mr_bones_@gentoo.org>
wordwarvi-0.26.ebuild, +files/wordwarvi-0.26-sound.patch:
diff --git a/games-action/wordwarvi/files/wordwarvi-1.00-sound.patch b/games-action/wordwarvi/files/wordwarvi-1.00-sound.patch
new file mode 100644
index 000000000000..5ad7bc8440b9
--- /dev/null
+++ b/games-action/wordwarvi/files/wordwarvi-1.00-sound.patch
@@ -0,0 +1,80 @@
+diff -ru wordwarvi-1.00.orig/Makefile wordwarvi-1.00/Makefile
+--- wordwarvi-1.00.orig/Makefile 2011-06-09 00:06:22.000000000 -0400
++++ wordwarvi-1.00/Makefile 2011-06-11 19:57:55.609619777 -0400
+@@ -1,5 +1,5 @@
+ PREFIX=/usr
+-DATADIR=${PREFIX}/share/wordwarvi
++DATADIR?=${PREFIX}/share/wordwarvi
+ MANDIR?=${PREFIX}/share/man
+ MANPAGEDIR=${MANDIR}/man6
+
+@@ -24,18 +24,6 @@
+ CC ?= gcc
+ BUILD_CC ?= gcc
+
+-# DEBUG=-g
+-# DEBUG=
+-# PROFILE_FLAG=-pg
+-#PROFILE_FLAG=
+-#OPTIMIZE_FLAG=
+-# OPTIMIZE_FLAG=-O3
+-#OPTIMIZE_FLAG=-O3 -pedantic -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security
+-OPTIMIZE_FLAG=-O3 -pedantic
+-
+-
+-LDFLAGS=${PROFILE_FLAG}
+-
+ DEFINES=${SNDFLAGS} -DDATADIR=\"${DATADIR}/\"
+
+ all: wordwarvi wordwarvi.6.gz
+@@ -53,24 +41,24 @@
+ endif
+
+ joystick.o: joystick.c joystick.h Makefile
+- $(CC) ${DEBUG} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} -pthread -Wall -c joystick.c
++ $(CC) ${DEBUG} ${PROFILE_FLAG} ${CFLAGS} -pthread -Wall -c joystick.c
+
+ ogg_to_pcm.o: ogg_to_pcm.c ogg_to_pcm.h Makefile
+- $(CC) ${DEBUG} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} `pkg-config --cflags vorbisfile` \
++ $(CC) ${DEBUG} ${PROFILE_FLAG} ${CFLAGS} `pkg-config --cflags vorbisfile` \
+ -pthread -Wall -c ogg_to_pcm.c
+
+ wwviaudio.o: wwviaudio.c wwviaudio.h ogg_to_pcm.h my_point.h Makefile
+- $(CC) -Wall ${DEBUG} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} \
++ $(CC) -Wall ${DEBUG} ${PROFILE_FLAG} ${CFLAGS} \
+ ${DEFINES} \
+ -pthread `pkg-config --cflags vorbisfile` \
+ -c wwviaudio.c
+
+ rumble.o: rumble.c rumble.h Makefile
+- $(CC) ${DEBUG} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} `pkg-config --cflags vorbisfile` \
++ $(CC) ${DEBUG} ${PROFILE_FLAG} ${CFLAGS} `pkg-config --cflags vorbisfile` \
+ -pthread -Wall -c rumble.c
+
+ wwvi_font.o: wwvi_font.c wwvi_font.h my_point.h Makefile
+- $(CC) ${DEBUG} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} -pthread -Wall -c wwvi_font.c
++ $(CC) ${DEBUG} ${PROFILE_FLAG} ${CFLAGS} -pthread -Wall -c wwvi_font.c
+
+ stamp: stamp.c
+ $(BUILD_CC) -o stamp stamp.c
+@@ -78,7 +66,7 @@
+ wordwarvi: wordwarvi.c joystick.o rumble.o ${OGGOBJ} wwviaudio.o wwvi_font.o \
+ Makefile version.h stamp levels.h rumble.h
+ ./stamp > stamp.h
+- $(CC) ${DEBUG} ${PROFILE_FLAG} ${OPTIMIZE_FLAG} ${SCREENSAVERFLAG} -pthread -Wall ${DEFINES} \
++ $(CC) $(LDFLAGS) ${DEBUG} ${PROFILE_FLAG} ${CFLAGS} ${SCREENSAVERFLAG} -pthread -Wall ${DEFINES} \
+ joystick.o \
+ rumble.o \
+ wwvi_font.o \
+diff -ru wordwarvi-1.00.orig/wwviaudio.c wordwarvi-1.00/wwviaudio.c
+--- wordwarvi-1.00.orig/wwviaudio.c 2011-06-09 00:06:22.000000000 -0400
++++ wordwarvi-1.00/wwviaudio.c 2011-06-11 19:57:17.394274660 -0400
+@@ -121,7 +121,7 @@
+ if (clipnum >= max_sound_clips || clipnum < 0)
+ return -1;
+
+- snprintf(filebuf, PATH_MAX, "%s/%s", DATADIR, filename);
++ snprintf(filebuf, PATH_MAX, "GENTOO_DATADIR/%s", DATADIR, filename);
+ rc = stat(filebuf, &statbuf);
+ if (rc != 0) {
+ strncpy(filebuf, filename, PATH_MAX);
diff --git a/games-action/wordwarvi/wordwarvi-1.00.ebuild b/games-action/wordwarvi/wordwarvi-1.00.ebuild
new file mode 100644
index 000000000000..5ec0a257860a
--- /dev/null
+++ b/games-action/wordwarvi/wordwarvi-1.00.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/wordwarvi-1.00.ebuild,v 1.1 2011/06/12 00:53:19 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="A retro side-scrolling shoot'em up based on the editor war story"
+HOMEPAGE="http://wordwarvi.sourceforge.net"
+SRC_URI="mirror://sourceforge/wordwarvi/${P}.tar.gz"
+
+LICENSE="GPL-2 CCPL-Attribution-2.0 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+RDEPEND="x11-libs/gtk+:2
+ portaudio? ( media-libs/libvorbis
+ >=media-libs/portaudio-19_pre1 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sound.patch
+ sed -i \
+ -e "/^WITHAUDIO/s/yes/$(use portaudio && echo yes || echo no)/" \
+ Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ wwviaudio.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ install || die "emake install failed"
+ use portaudio || rm -rf "${D}${GAMES_DATADIR}"
+ dodoc README AUTHORS changelog.txt AAA_HOW_TO_MAKE_NEW_LEVELS.txt
+ newicon icons/wordwarvi_icon_128x128.png ${PN}.png
+ make_desktop_entry ${PN} "Word War vi"
+ prepgamesdirs
+}