summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-08 10:53:01 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-08 10:53:01 +0000
commit30a55ae73f7b89ebcc6db900021b07a7a720dac7 (patch)
tree1821c8624dfbfde11eb8847ff27d7a9c32efe49c /games-action
parentRemove unused patch, bug #339375 by jalan <jalanpalmer@gmail.com>. (diff)
downloadgentoo-2-30a55ae73f7b89ebcc6db900021b07a7a720dac7.tar.gz
gentoo-2-30a55ae73f7b89ebcc6db900021b07a7a720dac7.tar.bz2
gentoo-2-30a55ae73f7b89ebcc6db900021b07a7a720dac7.zip
Respect LDFLAGS. Bug #336822
(Portage version: 2.1.9.13/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/xshipwars/ChangeLog10
-rw-r--r--games-action/xshipwars/files/xshipwars-2.6.1-ldflags.patch93
-rw-r--r--games-action/xshipwars/xshipwars-2.6.1.ebuild7
3 files changed, 104 insertions, 6 deletions
diff --git a/games-action/xshipwars/ChangeLog b/games-action/xshipwars/ChangeLog
index 497e636f6a70..9635df4407e7 100644
--- a/games-action/xshipwars/ChangeLog
+++ b/games-action/xshipwars/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/xshipwars
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/ChangeLog,v 1.25 2009/12/31 23:02:26 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/ChangeLog,v 1.26 2010/10/08 10:53:01 tupone Exp $
+
+ 08 Oct 2010; Tupone Alfredo <tupone@gentoo.org> xshipwars-2.6.1.ebuild,
+ +files/xshipwars-2.6.1-ldflags.patch:
+ Respect LDFLAGS. Bug #336822 by flameeyes@gentoo.org
*xshipwars-2.6.1 (31 Dec 2009)
@@ -108,7 +112,7 @@
01 Dec 2002; Mike Frysinger <vapier@gentoo.org> :
Added a patch for #9093, added games eclass support, added server install
- 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> xshipwars-1.34.0.ebuild :
+ 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> xshipwars-1.34.0.ebuild :
Added KEYWORDS.
01 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/games-action/xshipwars/files/xshipwars-2.6.1-ldflags.patch b/games-action/xshipwars/files/xshipwars-2.6.1-ldflags.patch
new file mode 100644
index 000000000000..62fb22f268a2
--- /dev/null
+++ b/games-action/xshipwars/files/xshipwars-2.6.1-ldflags.patch
@@ -0,0 +1,93 @@
+--- Makefile.unvedit.old 2010-10-08 11:39:09.000000000 +0200
++++ Makefile.unvedit 2010-10-08 11:42:48.000000000 +0200
+@@ -1,5 +1,5 @@
+ ALL_SRC_DIRS=unvedit
+ all install clean:
+ @for subdir in $(ALL_SRC_DIRS); do \
+- make -C $$subdir -f Makefile $@; \
++ $(MAKE) -C $$subdir -f Makefile $@; \
+ done
+--- unvedit/makefile_append.ini.old 2010-10-08 11:53:21.000000000 +0200
++++ unvedit/makefile_append.ini 2010-10-08 11:54:43.000000000 +0200
+@@ -14,7 +14,7 @@
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .cpp.o:
+ @echo "Compiling module $*.o"
+- @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ +$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
+
+ # Programs
+ LS = ls
+@@ -29,8 +29,8 @@
+ @echo "Compiling resources"
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+- @echo -n "Linking modules..."
+- @$(CPP) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
++ @echo "Linking modules..."
++ $(CPP) $(LDFLAGS) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
+ @echo -n " "
+ @-$(LS) $(LSFLAGS) $(BIN)
+
+--- Makefile.monitor.old 2010-10-08 12:25:11.000000000 +0200
++++ Makefile.monitor 2010-10-08 12:25:25.000000000 +0200
+@@ -1,5 +1,5 @@
+ ALL_SRC_DIRS=monitor
+ all install clean:
+ @for subdir in $(ALL_SRC_DIRS); do \
+- make -C $$subdir -f Makefile $@; \
++ $(MAKE) -C $$subdir -f Makefile $@; \
+ done
+--- monitor/makefile_append.ini.old 2010-10-08 12:26:24.000000000 +0200
++++ monitor/makefile_append.ini 2010-10-08 12:26:56.000000000 +0200
+@@ -14,7 +14,7 @@
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .cpp.o:
+ @echo "Compiling module $*.o"
+- @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ +$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
+
+ # Programs
+ LS = ls
+@@ -29,8 +29,8 @@
+ @echo "Compiling resources"
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+- @echo -n "Linking modules..."
+- @$(CPP) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
++ @echo "Linking modules..."
++ $(CPP) $(LDFLAGS) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
+ @echo -n " "
+ @-$(LS) $(LSFLAGS) $(BIN)
+
+--- client/makefile_append.ini.old 2010-10-08 12:37:44.000000000 +0200
++++ client/makefile_append.ini 2010-10-08 12:38:08.000000000 +0200
+@@ -14,7 +14,7 @@
+ OBJ_CPP = $(SRC_CPP:.cpp=.o)
+ .cpp.o:
+ @echo "Compiling module $*.o"
+- @+$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
++ +$(CPP) -c $*.cpp $(INC_DIRS) $(CFLAGS) $(CPPFLAGS)
+
+ # Programs
+ LS = ls
+@@ -29,8 +29,8 @@
+ @echo "Compiling resources"
+
+ modules: $(OBJ_C) $(OBJ_CPP)
+- @echo -n "Linking modules..."
+- @$(CPP) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
++ @echo n "Linking modules..."
++ $(CPP) $(LDFLAGS) $(OBJ_C) $(OBJ_CPP) -o $(BIN) $(LIBS) $(LIB_DIRS)
+ @echo -n " "
+ @-$(LS) $(LSFLAGS) $(BIN)
+
+--- Makefile.client.old 2010-10-08 12:37:19.000000000 +0200
++++ Makefile.client 2010-10-08 12:37:31.000000000 +0200
+@@ -1,5 +1,5 @@
+ ALL_SRC_DIRS=client
+ all install clean:
+ @for subdir in $(ALL_SRC_DIRS); do \
+- make -C $$subdir -f Makefile $@; \
++ $(MAKE) -C $$subdir -f Makefile $@; \
+ done
diff --git a/games-action/xshipwars/xshipwars-2.6.1.ebuild b/games-action/xshipwars/xshipwars-2.6.1.ebuild
index 1a59adf42586..6817e6255a3a 100644
--- a/games-action/xshipwars/xshipwars-2.6.1.ebuild
+++ b/games-action/xshipwars/xshipwars-2.6.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/xshipwars-2.6.1.ebuild,v 1.1 2009/12/31 23:02:26 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/xshipwars-2.6.1.ebuild,v 1.2 2010/10/08 10:53:01 tupone Exp $
EAPI=2
inherit eutils games
@@ -29,7 +29,8 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
epatch \
"${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-64bit.patch
+ "${FILESDIR}"/${P}-64bit.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
sed -i \
-e "/^BINDIR/s:=.*:=${GAMES_BINDIR}:" \
-e "/^DATADIR/s:=.*:=${GAMES_DATADIR}:" \