summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-04-30 16:46:31 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-04-30 16:46:31 +0000
commit417c830b1f7b73eb580a6e99c32ca769e44126db (patch)
treea605b90cc2b72a7601e7f0dc002d3b97f11608f3 /games-action
parentFix scons failure when some directories in /usr/local don't exist (diff)
downloadgentoo-2-417c830b1f7b73eb580a6e99c32ca769e44126db.tar.gz
gentoo-2-417c830b1f7b73eb580a6e99c32ca769e44126db.tar.bz2
gentoo-2-417c830b1f7b73eb580a6e99c32ca769e44126db.zip
Patch to fix building with gcc-4.3 from Peter Alfredsen, bug #219427
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/rafkill/ChangeLog6
-rw-r--r--games-action/rafkill/files/rafkill-1.2.3-gcc43.patch106
-rw-r--r--games-action/rafkill/rafkill-1.2.3.ebuild10
3 files changed, 117 insertions, 5 deletions
diff --git a/games-action/rafkill/ChangeLog b/games-action/rafkill/ChangeLog
index ec79c48c8e4e..0099aabd6a51 100644
--- a/games-action/rafkill/ChangeLog
+++ b/games-action/rafkill/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/rafkill
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/ChangeLog,v 1.4 2008/04/30 16:42:34 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/ChangeLog,v 1.5 2008/04/30 16:46:31 nyhm Exp $
+
+ 30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/rafkill-1.2.3-gcc43.patch, rafkill-1.2.3.ebuild:
+ Patch to fix building with gcc-4.3 from Peter Alfredsen, bug #219427
30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
files/rafkill-1.2.3-build.patch:
diff --git a/games-action/rafkill/files/rafkill-1.2.3-gcc43.patch b/games-action/rafkill/files/rafkill-1.2.3-gcc43.patch
new file mode 100644
index 000000000000..7284a74a1ac5
--- /dev/null
+++ b/games-action/rafkill/files/rafkill-1.2.3-gcc43.patch
@@ -0,0 +1,106 @@
+Index: rafkill-1.2.2/src/guns/gun_findgun.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/guns/gun_findgun.cpp 2006-05-07 15:50:04.000000000 +0100
++++ rafkill-1.2.2/src/guns/gun_findgun.cpp 2008-04-09 22:54:54.000000000 +0100
+@@ -5,6 +5,7 @@
+ #include "weaponobj.h"
+ #include "hulls/hull_weapon_machine.h"
+ #include "spaceobj.h"
++#include <cstdlib>
+ #include <vector>
+ #include <math.h>
+
+Index: rafkill-1.2.2/src/guns/gun_machine_circle.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/guns/gun_machine_circle.cpp 2006-05-02 02:50:40.000000000 +0100
++++ rafkill-1.2.2/src/guns/gun_machine_circle.cpp 2008-04-09 22:54:54.000000000 +0100
+@@ -3,6 +3,7 @@
+ #include "weaponobj.h"
+ #include "hulls/hull_weapon_machine.h"
+ #include "trigtable.h"
++#include <cstdlib>
+
+ // #define d_circle_move (2.9*8)
+
+Index: rafkill-1.2.2/src/guns/gun_saber.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/guns/gun_saber.cpp 2006-05-02 02:52:23.000000000 +0100
++++ rafkill-1.2.2/src/guns/gun_saber.cpp 2008-04-09 22:54:54.000000000 +0100
+@@ -5,6 +5,7 @@
+ #include "weapons/weapon_beam.h"
+ #include "spaceobj.h"
+ #include "ebox.h"
++#include <cstdlib>
+ #include <vector>
+
+ using namespace std;
+Index: rafkill-1.2.2/src/menu.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/menu.cpp 2008-04-09 22:53:35.000000000 +0100
++++ rafkill-1.2.2/src/menu.cpp 2008-04-09 22:54:54.000000000 +0100
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <cstdlib>
+ #include "defs.h"
+ #include "menu.h"
+ #include "loadsave.h"
+Index: rafkill-1.2.2/src/weapons/weapon_follow.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/weapons/weapon_follow.cpp 2006-03-25 23:29:05.000000000 +0000
++++ rafkill-1.2.2/src/weapons/weapon_follow.cpp 2008-04-09 22:54:54.000000000 +0100
+@@ -3,6 +3,7 @@
+ #include "weapon_follow.h"
+ #include "hulls/hull_weapon_follow.h"
+ #include "spaceobj.h"
++#include <cstdlib>
+ #include <vector>
+
+ using namespace std;
+Index: rafkill-1.2.2/src/hulls/hull_weapon_beam.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/hulls/hull_weapon_beam.cpp 2006-05-02 03:12:50.000000000 +0100
++++ rafkill-1.2.2/src/hulls/hull_weapon_beam.cpp 2008-04-09 22:54:54.000000000 +0100
+@@ -4,6 +4,7 @@
+ #include "hull_weapon_beam.h"
+ #include "trigtable.h"
+ #include "ebox.h"
++#include <cstdlib>
+
+ #ifndef debug
+ #include <iostream>
+Index: rafkill-1.2.2/src/drawer.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/drawer.cpp 2008-04-09 22:55:06.000000000 +0100
++++ rafkill-1.2.2/src/drawer.cpp 2008-04-09 22:55:55.000000000 +0100
+@@ -11,6 +11,7 @@
+ #include "trigtable.h"
+ #include "pck.h"
+ #include <iostream>
++#include <cstring>
+
+ /* TODO:
+ * Add weapon icons to HUD
+Index: rafkill-1.2.2/src/loadsave.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/loadsave.cpp 2008-04-09 22:55:19.000000000 +0100
++++ rafkill-1.2.2/src/loadsave.cpp 2008-04-09 22:55:55.000000000 +0100
+@@ -7,6 +7,7 @@
+ #include "spaceobj.h"
+ #include "strings.h"
+ #include <string>
++#include <cstring>
+ #include <vector>
+ #include "gunobj.h"
+ #include "hull.h"
+Index: rafkill-1.2.2/src/system.cpp
+===================================================================
+--- rafkill-1.2.2.orig/src/system.cpp 2008-04-09 22:55:29.000000000 +0100
++++ rafkill-1.2.2/src/system.cpp 2008-04-09 22:55:55.000000000 +0100
+@@ -1,6 +1,7 @@
+ #include "system.h"
+ #include <strings.h>
+ #include <string>
++#include <cstring>
+
+ #ifdef WINDOWS
+ static const char * type(){
diff --git a/games-action/rafkill/rafkill-1.2.3.ebuild b/games-action/rafkill/rafkill-1.2.3.ebuild
index 3f1fdc52113d..b96cdef94ed9 100644
--- a/games-action/rafkill/rafkill-1.2.3.ebuild
+++ b/games-action/rafkill/rafkill-1.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/rafkill-1.2.3.ebuild,v 1.2 2007/07/03 20:26:42 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/rafkill/rafkill-1.2.3.ebuild,v 1.3 2008/04/30 16:46:31 nyhm Exp $
inherit eutils toolchain-funcs games
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc x86"
IUSE=""
-RDEPEND=">=media-libs/allegro-4.0.0
+RDEPEND="media-libs/allegro
media-libs/aldumb"
DEPEND="${RDEPEND}
dev-util/scons"
@@ -22,7 +22,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
rm -f {data,music}/.sconsign
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
sed -i "/^#define INSTALL_DIR/s:\.:${GAMES_DATADIR}:" \
src/defs.cpp || die "sed failed"
}