summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-03-15 22:59:59 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-03-15 22:59:59 +0000
commit51f9a9a2633a6b94a980516ef4ece4840b65555e (patch)
tree8fe17c46530d286d441af2b23e66e251adf7c4a3 /games-action
parentAdded a patch allow compilation with gcc-4.1.0. (diff)
downloadgentoo-2-51f9a9a2633a6b94a980516ef4ece4840b65555e.tar.gz
gentoo-2-51f9a9a2633a6b94a980516ef4ece4840b65555e.tar.bz2
gentoo-2-51f9a9a2633a6b94a980516ef4ece4840b65555e.zip
Added check for mikmod USE flag on sdl-mixer and closing bug #126103.
(Portage version: 2.1_pre6-r2)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/powermanga/ChangeLog8
-rw-r--r--games-action/powermanga/powermanga-0.78.ebuild13
-rw-r--r--games-action/powermanga/powermanga-0.79.ebuild13
3 files changed, 28 insertions, 6 deletions
diff --git a/games-action/powermanga/ChangeLog b/games-action/powermanga/ChangeLog
index 60387555ab53..5bfd0b6db449 100644
--- a/games-action/powermanga/ChangeLog
+++ b/games-action/powermanga/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/powermanga
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/ChangeLog,v 1.6 2004/11/12 20:46:06 blubb Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/ChangeLog,v 1.7 2006/03/15 22:59:59 wolf31o2 Exp $
+
+ 15 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ powermanga-0.78.ebuild, powermanga-0.79.ebuild:
+ Added check for mikmod USE flag on sdl-mixer and closing bug #126103.
12 Nov 2004; Simon Stelling <blubb@gentoo.org> powermanga-0.79.ebuild:
added ~amd64
diff --git a/games-action/powermanga/powermanga-0.78.ebuild b/games-action/powermanga/powermanga-0.78.ebuild
index 6bd8e13583a7..a41d696b4e0a 100644
--- a/games-action/powermanga/powermanga-0.78.ebuild
+++ b/games-action/powermanga/powermanga-0.78.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.78.ebuild,v 1.5 2004/06/30 02:32:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.78.ebuild,v 1.6 2006/03/15 22:59:59 wolf31o2 Exp $
inherit games
@@ -17,6 +17,15 @@ DEPEND="virtual/libc
>=media-libs/libsdl-0.11.0
media-libs/sdl-mixer"
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-mixer mikmod
+ then
+ eerror "${PN} needs sdl-mixer compiled with mikmod use-flag enabled!"
+ die "sdl-mixer without mikmod detected"
+ fi
+ games_pkg_setup
+}
+
src_compile() {
egamesconf --prefix=/usr || die "egamesconf failed"
emake || die "emake failed"
diff --git a/games-action/powermanga/powermanga-0.79.ebuild b/games-action/powermanga/powermanga-0.79.ebuild
index aa96d3238677..6fb69b27c23d 100644
--- a/games-action/powermanga/powermanga-0.79.ebuild
+++ b/games-action/powermanga/powermanga-0.79.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.79.ebuild,v 1.3 2004/11/12 20:46:06 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.79.ebuild,v 1.4 2006/03/15 22:59:59 wolf31o2 Exp $
inherit games
@@ -17,6 +17,15 @@ DEPEND="virtual/libc
>=media-libs/libsdl-0.11.0
media-libs/sdl-mixer"
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-mixer mikmod
+ then
+ eerror "${PN} needs sdl-mixer compiled with mikmod use-flag enabled!"
+ die "sdl-mixer without mikmod detected"
+ fi
+ games_pkg_setup
+}
+
src_compile() {
egamesconf --prefix=/usr || die "egamesconf failed"
emake || die "emake failed"