summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-07-07 13:39:28 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-07-07 13:39:28 +0000
commit5d9a8552fdf51f9dede36b177a1429f35d2eb7f6 (patch)
tree1b03b55341c64d955e028f6407ce45fb152ec287 /games-action
parentVersion bump (diff)
downloadgentoo-2-5d9a8552fdf51f9dede36b177a1429f35d2eb7f6.tar.gz
gentoo-2-5d9a8552fdf51f9dede36b177a1429f35d2eb7f6.tar.bz2
gentoo-2-5d9a8552fdf51f9dede36b177a1429f35d2eb7f6.zip
Changed nocd to cdinstall, since it is optional and breaks interactivity.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/d2x/ChangeLog5
-rw-r--r--games-action/d2x/d2x-0.2.5-r1.ebuild14
2 files changed, 11 insertions, 8 deletions
diff --git a/games-action/d2x/ChangeLog b/games-action/d2x/ChangeLog
index 482f42ca09ff..2bb640c76609 100644
--- a/games-action/d2x/ChangeLog
+++ b/games-action/d2x/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/d2x
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.9 2005/01/09 10:48:13 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.10 2005/07/07 13:39:28 wolf31o2 Exp $
+
+ 07 Jul 2005; Chris Gianelloni <wolf31o2@gentoo.org> d2x-0.2.5-r1.ebuild:
+ Changed nocd to cdinstall, since it is optional and breaks interactivity.
09 Jan 2005; Sven Wegener <swegener@gentoo.org> d2x-0.2.5-r1.ebuild:
Added missing parentheses in SRC_URI/*DEPEND/LICENSE.
diff --git a/games-action/d2x/d2x-0.2.5-r1.ebuild b/games-action/d2x/d2x-0.2.5-r1.ebuild
index f3a76fa789e5..fd805fbf1be7 100644
--- a/games-action/d2x/d2x-0.2.5-r1.ebuild
+++ b/games-action/d2x/d2x-0.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r1.ebuild,v 1.7 2005/06/29 00:32:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r1.ebuild,v 1.8 2005/07/07 13:39:28 wolf31o2 Exp $
inherit flag-o-matic eutils games
@@ -8,16 +8,16 @@ DATAFILE="d2shar10"
DESCRIPTION="Descent 2"
HOMEPAGE="http://icculus.org/d2x/"
SRC_URI="http://icculus.org/d2x/src/${P}.tar.gz
- !nocd? ( http://icculus.org/d2x/data/${DATAFILE}.tar.gz )"
+ !cdinstall? ( http://icculus.org/d2x/data/${DATAFILE}.tar.gz )"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="ppc x86"
-IUSE="nocd debug opengl ggi svga"
+IUSE="cdinstall debug opengl ggi svga"
RDEPEND="media-libs/libsdl
media-libs/sdl-image
- nocd? ( app-arch/unarj )
+ cdinstall? ( app-arch/unarj )
opengl? ( virtual/opengl )
ggi? ( media-libs/libggi )
svga? ( media-libs/svgalib )"
@@ -27,7 +27,7 @@ DEPEND="${RDEPEND}
pkg_setup() {
games_pkg_setup
- if use nocd ; then
+ if use cdinstall ; then
if [[ ! -e ${DISTDIR}/descent2.sow ]] ; then
cdrom_get_cds d2data
if [ -e ${CDROM_ROOT}/d2data/descent2.sow ] ; then
@@ -44,7 +44,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- if use nocd ; then
+ if use cdinstall ; then
cd ${WORKDIR}
mkdir SOW
cd SOW
@@ -89,7 +89,7 @@ src_install() {
make install DESTDIR=${D} || die
dogamesbin my-bins/*
dodir ${GAMES_DATADIR}/${PN}
- if use nocd ; then
+ if use cdinstall ; then
cp -r ${WORKDIR}/SOW/* ${D}/${GAMES_DATADIR}/${PN}/
else
cp -r ${WORKDIR}/${DATAFILE}/* ${D}/${GAMES_DATADIR}/${PN}/