summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-05-04 06:13:43 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-05-04 06:13:43 +0000
commit629b213d9b98f078aca66169e99978503ca62a19 (patch)
tree7f5dbca2cb519a5f24a7a9ee8ccc592ee9191cbf /games-action
parent[kde-base] Drop KDE SC 4.4.1 (diff)
downloadgentoo-2-629b213d9b98f078aca66169e99978503ca62a19.tar.gz
gentoo-2-629b213d9b98f078aca66169e99978503ca62a19.tar.bz2
gentoo-2-629b213d9b98f078aca66169e99978503ca62a19.zip
Force python2 fixing bug #312229
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/slune/ChangeLog7
-rw-r--r--games-action/slune/slune-1.0.11.ebuild18
2 files changed, 19 insertions, 6 deletions
diff --git a/games-action/slune/ChangeLog b/games-action/slune/ChangeLog
index f3913b20a630..180f723e8771 100644
--- a/games-action/slune/ChangeLog
+++ b/games-action/slune/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/slune
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/slune/ChangeLog,v 1.15 2006/06/13 21:02:49 wolf31o2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/slune/ChangeLog,v 1.16 2010/05/04 06:13:43 tupone Exp $
+
+ 04 May 2010; Tupone Alfredo <tupone@gentoo.org> slune-1.0.11.ebuild:
+ Force python2 fixing bug #312229 by arfrever@gentoo.org
13 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org> slune-1.0.11.ebuild:
Changed the dependency on py2play to require 0.1.9 due to bug #103524.
diff --git a/games-action/slune/slune-1.0.11.ebuild b/games-action/slune/slune-1.0.11.ebuild
index 694c7cfb2650..b959e72634a6 100644
--- a/games-action/slune/slune-1.0.11.ebuild
+++ b/games-action/slune/slune-1.0.11.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/slune/slune-1.0.11.ebuild,v 1.2 2006/06/13 21:02:49 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/slune/slune-1.0.11.ebuild,v 1.3 2010/05/04 06:13:43 tupone Exp $
+EAPI="2"
+PYTHON_DEPEND="2"
-inherit distutils
+inherit python distutils
DESCRIPTION="A 3D action game with multiplayer mode and amazing graphics"
HOMEPAGE="http://oomadness.tuxfamily.org/en/slune/"
@@ -15,7 +17,6 @@ IUSE=""
DEPEND="virtual/opengl
>=media-libs/libsdl-1.2.6
- >=dev-lang/python-2.2.2
>=dev-python/soya-0.9
>=dev-python/py2play-0.1.9
>=dev-python/pyopenal-0.1.3
@@ -23,3 +24,12 @@ DEPEND="virtual/opengl
>=dev-python/pyvorbis-1.1"
S=${WORKDIR}/Slune-${PV}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+ distutils_src_prepare
+}