summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-29 15:45:51 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-29 15:45:51 +0000
commit7d5044a4085514ba9642808b0d453be39b178c74 (patch)
treed32e898a73c5440617e388e554a506b878d571df /games-action
parentInitial import (diff)
downloadgentoo-2-7d5044a4085514ba9642808b0d453be39b178c74.tar.gz
gentoo-2-7d5044a4085514ba9642808b0d453be39b178c74.tar.bz2
gentoo-2-7d5044a4085514ba9642808b0d453be39b178c74.zip
use unpack_zip from unpacker.eclass instead of unzip
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/trine-bin/ChangeLog8
-rw-r--r--games-action/trine-bin/trine-bin-1.08.ebuild6
2 files changed, 8 insertions, 6 deletions
diff --git a/games-action/trine-bin/ChangeLog b/games-action/trine-bin/ChangeLog
index 3782d3b0799d..8bb4a34887b2 100644
--- a/games-action/trine-bin/ChangeLog
+++ b/games-action/trine-bin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/trine-bin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/trine-bin/ChangeLog,v 1.2 2011/04/21 08:52:57 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/trine-bin/ChangeLog,v 1.3 2013/03/29 15:45:51 hasufell Exp $
+
+ 29 Mar 2013; Julian Ospald <hasufell@gentoo.org> trine-bin-1.08.ebuild:
+ use unpack_zip from unpacker.eclass instead of unzip
21 Apr 2011; Mike Frysinger <vapier@gentoo.org> trine-bin-1.08.ebuild:
Add glade/libx86 dep #364061 by Robert Cernansky.
@@ -10,4 +13,3 @@
16 Apr 2011; Mike Frysinger <vapier@gentoo.org> +trine-bin-1.08.ebuild,
+metadata.xml:
New package.
-
diff --git a/games-action/trine-bin/trine-bin-1.08.ebuild b/games-action/trine-bin/trine-bin-1.08.ebuild
index b8caa6460201..f998c7a18906 100644
--- a/games-action/trine-bin/trine-bin-1.08.ebuild
+++ b/games-action/trine-bin/trine-bin-1.08.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/trine-bin/trine-bin-1.08.ebuild,v 1.3 2011/04/21 08:52:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/trine-bin/trine-bin-1.08.ebuild,v 1.4 2013/03/29 15:45:51 hasufell Exp $
# these are ELFs that include a ZIP (504b0304) appended to it
# dd if=Trine.64.run of=Trine.64.zip ibs=$((0x342a8)) skip=1
@@ -39,7 +39,7 @@ pkg_nofetch() {
src_unpack() {
# manually run unzip as the initial seek causes it to exit(1)
- unzip -q "${DISTDIR}/${A}"
+ unpack_zip ${A}
rm lib*/lib{gcc_s,m,rt,selinux}.so.?
}