summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2010-04-06 18:58:49 +0000
committerTristan Heaven <nyhm@gentoo.org>2010-04-06 18:58:49 +0000
commit8a4baa808672eb98d31aa0473c688332b927acc0 (patch)
tree44293bf8588a18a0a6b1f1900285a47aff766e17 /games-action
parentMarking msmtp-1.4.19 ppc64 for bug 293647 (diff)
downloadgentoo-2-8a4baa808672eb98d31aa0473c688332b927acc0.tar.gz
gentoo-2-8a4baa808672eb98d31aa0473c688332b927acc0.tar.bz2
gentoo-2-8a4baa808672eb98d31aa0473c688332b927acc0.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/xpilot/ChangeLog9
-rw-r--r--games-action/xpilot/xpilot-4.5.5.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/games-action/xpilot/ChangeLog b/games-action/xpilot/ChangeLog
index 565a581b5fbc..bd949826a417 100644
--- a/games-action/xpilot/ChangeLog
+++ b/games-action/xpilot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/xpilot
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/ChangeLog,v 1.10 2006/12/01 20:17:34 wolf31o2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/ChangeLog,v 1.11 2010/04/06 18:58:49 nyhm Exp $
+
+*xpilot-4.5.5 (06 Apr 2010)
+
+ 06 Apr 2010; Tristan Heaven <nyhm@gentoo.org> +xpilot-4.5.5.ebuild:
+ Version bump
01 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org> xpilot-4.5.4.ebuild:
Removing old virtual/x11 dependency.
diff --git a/games-action/xpilot/xpilot-4.5.5.ebuild b/games-action/xpilot/xpilot-4.5.5.ebuild
new file mode 100644
index 000000000000..400c87aca851
--- /dev/null
+++ b/games-action/xpilot/xpilot-4.5.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/xpilot-4.5.5.ebuild,v 1.1 2010/04/06 18:58:49 nyhm Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="A multi-player 2D client/server space game"
+HOMEPAGE="http://www.xpilot.org/"
+SRC_URI="mirror://sourceforge/xpilotgame/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-misc/gccmakedep
+ x11-misc/imake
+ app-text/rman"
+
+src_prepare() {
+ sed -i \
+ -e '/^INSTMAN/s:=.*:=/usr/share/man/man:' \
+ -e "/^INSTLIB/s:=.*:=${GAMES_DATADIR}/${PN}:" \
+ -e "/^INSTBIN/s:=.*:=${GAMES_BINDIR}:" \
+ Local.config \
+ || die "sed failed"
+}
+
+src_compile() {
+ xmkmf || die "xmkmf failed"
+ emake Makefiles || die "emake Makefiles failed"
+ emake includes || die "emake includes failed"
+ emake depend || die "emake depend failed"
+ emake CC="${CC}" CDEBUGFLAGS="${CFLAGS} ${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install.man || die "emake install.man failed"
+ newicon lib/textures/logo.ppm ${PN}.ppm
+ make_desktop_entry ${PN} XPilot /usr/share/pixmaps/${PN}.ppm
+ dodoc README.txt doc/{ChangeLog,CREDITS,FAQ,README*,TODO}
+ prepgamesdirs
+}