summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-01-10 17:43:55 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-01-10 17:43:55 +0000
commit8fe7f1341d4638341ed7565c39799ff78122825e (patch)
tree2a62f5b87651ec4a18ee99358e06b948d510cf5f /games-action
parentSync with boost-1.42.0-r2 ebuild. New random-Jamfile patch. (diff)
downloadgentoo-2-8fe7f1341d4638341ed7565c39799ff78122825e.tar.gz
gentoo-2-8fe7f1341d4638341ed7565c39799ff78122825e.tar.bz2
gentoo-2-8fe7f1341d4638341ed7565c39799ff78122825e.zip
EAPI=2; honor LDFLAGS (bug #351309); tidy
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/towbowl-tactics/ChangeLog8
-rw-r--r--games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch42
-rw-r--r--games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild47
3 files changed, 68 insertions, 29 deletions
diff --git a/games-action/towbowl-tactics/ChangeLog b/games-action/towbowl-tactics/ChangeLog
index 274170223520..784facb49951 100644
--- a/games-action/towbowl-tactics/ChangeLog
+++ b/games-action/towbowl-tactics/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/towbowl-tactics
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/towbowl-tactics/ChangeLog,v 1.7 2008/03/06 03:42:02 wolf31o2 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/towbowl-tactics/ChangeLog,v 1.8 2011/01/10 17:43:55 mr_bones_ Exp $
+
+ 10 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ towbowl-tactics-0.5.ebuild, +files/towbowl-tactics-0.5-gentoo.patch:
+ EAPI=2; honor LDFLAGS (bug #351309); tidy
06 Mar 2008; Chris Gianelloni <wolf31o2@gentoo.org>
towbowl-tactics-0.5.ebuild:
diff --git a/games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch b/games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch
new file mode 100644
index 000000000000..aa6a950e9a07
--- /dev/null
+++ b/games-action/towbowl-tactics/files/towbowl-tactics-0.5-gentoo.patch
@@ -0,0 +1,42 @@
+diff -ru tbt.orig/config.xml tbt/config.xml
+--- tbt.orig/config.xml 2003-02-01 15:14:56.000000000 -0500
++++ tbt/config.xml 2011-01-10 12:08:01.564649048 -0500
+@@ -5,5 +5,5 @@
+ <screen_h>600</screen_h>
+ <sound_enabled>1</sound_enabled>
+ <video_enabled>1</video_enabled>
+-<language>0</language>
++<language>1</language>
+ </config>
+diff -ru tbt.orig/src/Makefile tbt/src/Makefile
+--- tbt.orig/src/Makefile 2003-02-01 15:07:40.000000000 -0500
++++ tbt/src/Makefile 2011-01-10 12:07:29.075274834 -0500
+@@ -1,24 +1,20 @@
+ TBTHOME = /usr/local/games/tbt
+ INCDIR = -I /usr/include/smpeg -I /usr/include/libxml2 -I /usr/include/SDL/
+-CFLAGS = -O2 -g -fno-strength-reduce -Wall -W -DTBTHOME=\"$(TBTHOME)\"
+-LFLAGS = -L. -lm -lSDL -lSDL_net -lSDL_image -lSDL_mixer -ldl -pthread -lxml2 -lsmpeg
+-CC = g++
++CXXFLAGS += -DTBTHOME=\"$(TBTHOME)\"
++LIBS = -lm -lSDL -lSDL_net -lSDL_image -lSDL_mixer -ldl -pthread -lxml2 -lsmpeg
+ SOURCES = movies.cpp sounds.cpp SFont.cpp Ball.cpp CON_console.cpp CON_consolecommands.cpp CON_internal.cpp Config.cpp Console.cpp DT_drawtext.cpp DialogBox.cpp Dice.cpp Formation.cpp Main.cpp MoviePlayer.cpp NetClient.cpp NetServer.cpp Network.cpp Path.cpp Player.cpp ProgressBar.cpp Public.cpp Screen.cpp Shared.cpp SoundPlayer.cpp Square.cpp State.cpp Team.cpp Transformation.cpp Translator.cpp XmlParser.cpp dir_func.cpp
+ OBJS = $(patsubst %.c,%.o,$(SOURCES:%.cpp=%.o))
+ PRGM = tbt
+
+ .SUFFIXES: .cpp .c
+
+-.c.o:
+- $(CC) -c $< $(CFLAGS) $(INCDIR) -o $@
+-
+ .cpp.o:
+- $(CC) -c $< $(CFLAGS) $(INCDIR) -o $@
++ $(CXX) -c $< $(CXXFLAGS) $(INCDIR) -o $@
+
+ all: $(PRGM)
+
+ $(PRGM): $(OBJS)
+- $(CC) $(OBJS) -o $(PRGM) $(LFLAGS)
++ $(CXX) $(OBJS) -o $(PRGM) $(LDFLAGS) $(LIBS)
+
+ clean:
+ -rm -f $(PRGM) *core *~ *.o
diff --git a/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild b/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
index 43eb672404ba..c899a071c331 100644
--- a/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
+++ b/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild,v 1.10 2008/05/15 12:34:00 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/towbowl-tactics/towbowl-tactics-0.5.ebuild,v 1.11 2011/01/10 17:43:55 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="Tow Bowl Tactics is a game based on Games Workshop's Blood Bowl"
@@ -15,45 +16,37 @@ IUSE=""
RDEPEND="dev-libs/libxml2
media-libs/smpeg
+ media-libs/libsdl[audio,video]
media-libs/sdl-net
- media-libs/sdl-image
+ media-libs/sdl-image[jpeg,png]
media-libs/sdl-mixer"
DEPEND="${RDEPEND}
app-arch/unzip"
-S="${WORKDIR}/tbt/src"
-
-src_unpack() {
- local f
-
- unpack ${A}
- cd "${S}"
+S=${WORKDIR}/tbt/src
+src_prepare() {
+ cd ..
+ edos2unix $(find src -type f) config.xml
+ epatch "${FILESDIR}"/${P}-gentoo.patch
sed -i \
- -e "s/<language>0/<language>1/g" ../config.xml \
- || die "sed config.xml failed"
+ -e "/^TBTHOME/ s:/.*:${GAMES_DATADIR}/tbt:" \
+ src/Makefile || die
sed -i \
- -e "/^CFLAGS/ s:-O2 -g -fno-strength-reduce -Wall -W:${CFLAGS}:" \
- -e "/^TBTHOME/ s:/.*:${GAMES_DATADIR}/tbt:" Makefile \
- || die "sed Makefile failed"
- sed -i \
- -e "/tbt.ico/ s:\"\./:TBTHOME \"/:" Main.cpp \
- || die "sed Main.cpp failed"
+ -e "/tbt.ico/ s:\"\./:TBTHOME \"/:" \
+ src/Main.cpp || die
sed -i \
-e "s:TBTHOME \"/config.xml:\"${GAMES_SYSCONFDIR}/tbt/config.xml:g" \
- global.h || die "sed global,h failed"
-
- for f in $(find "${S}" -type f)
- do
- edos2unix ${f}
- done
+ src/global.h || die
}
src_install() {
- dogamesbin tbt || die "dogamesbin failed"
+ dogamesbin tbt || die
dodir "${GAMES_DATADIR}/tbt"
- cp -r ../data ../tbt.ico "${D}${GAMES_DATADIR}/tbt" || die "cp failed"
+ cp -r ../data ../tbt.ico "${D}${GAMES_DATADIR}/tbt" || die
insinto "${GAMES_SYSCONFDIR}/tbt"
- doins ../config.xml || die "doins failed"
+ doins ../config.xml || die
+ newicon ../data/images/panel/turn.png ${PN}.png || die
+ make_desktop_entry tbt "Tow Bowl Tactics" || die
prepgamesdirs
}