summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-04 04:20:24 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-04 04:20:24 +0000
commitab5d53703ced72fb06b99db86b9bc1922ac2fc4e (patch)
treead23ae9b0642eb63749a8aa52f5aa813091d612f /games-action
parentAdd sanity checks to keep from breaking the host system. (diff)
downloadgentoo-2-ab5d53703ced72fb06b99db86b9bc1922ac2fc4e.tar.gz
gentoo-2-ab5d53703ced72fb06b99db86b9bc1922ac2fc4e.tar.bz2
gentoo-2-ab5d53703ced72fb06b99db86b9bc1922ac2fc4e.zip
fix parallel build (bug #82536)
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/dungeon/ChangeLog7
-rw-r--r--games-action/dungeon/dungeon-3.2.3.ebuild35
-rw-r--r--games-action/dungeon/files/dungeon-3.2.3-makefile.patch13
3 files changed, 35 insertions, 20 deletions
diff --git a/games-action/dungeon/ChangeLog b/games-action/dungeon/ChangeLog
index 19280442cf2b..3026eca2267f 100644
--- a/games-action/dungeon/ChangeLog
+++ b/games-action/dungeon/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/dungeon
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/ChangeLog,v 1.6 2004/12/20 13:13:24 josejx Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/ChangeLog,v 1.7 2005/03/04 04:20:24 mr_bones_ Exp $
+
+ 03 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org> dungeon-3.2.3.ebuild:
+ fix parallel build (bug #82536)
20 Dec 2004; Joseph Jezak <josejx@gentoo.org> dungeon-3.2.3.ebuild:
Marked ppc stable.
diff --git a/games-action/dungeon/dungeon-3.2.3.ebuild b/games-action/dungeon/dungeon-3.2.3.ebuild
index ca0ed1ee89ac..633ef0a07115 100644
--- a/games-action/dungeon/dungeon-3.2.3.ebuild
+++ b/games-action/dungeon/dungeon-3.2.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/dungeon-3.2.3.ebuild,v 1.7 2004/12/20 13:13:24 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/dungeon-3.2.3.ebuild,v 1.8 2005/03/04 04:20:24 mr_bones_ Exp $
-inherit games
+inherit eutils games
DESCRIPTION="A linux port of the Dungeon game once distributed by DECUS"
HOMEPAGE="http://www.ibiblio.org/linsearch/lsms/dungeon-3.2.3.html"
@@ -10,40 +10,39 @@ SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/games/textrpg/${P}.src.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="ppc x86"
IUSE=""
-RDEPEND="virtual/libc"
-DEPEND="${RDEPEND}
- dev-lang/f2c
- >=sys-apps/sed-4"
+DEPEND="dev-lang/f2c"
-S="${WORKDIR}/dungn32c"
-
-DATS="${GAMES_DATADIR}/${PN}"
+S=${WORKDIR}/dungn32c
+DATS=${GAMES_DATADIR}/${PN}
src_unpack() {
unpack ${A}
- cd ${S}
- sed -i \
- -e "s:-O:${CFLAGS}:g" Makefile \
- || die "sed Makefile failed"
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
}
src_compile() {
- make game.c || die "make game.c failed"
+ local f
+
+ # f2c steps on itself
+ for f in *.f
+ do
+ emake ${f/.f/.c} || die "emake failed"
+ done
sed -i \
-re "s:d(indx|text).dat:${DATS}/&:g" \
-e "s:ofnmlen = [^;]+:&+${#DATS}+1:g" \
game.c || die "sed game.c failed"
-
emake || die "emake failed"
}
src_install() {
dogamesbin dungeon || die "dogamesbin failed"
insinto "${DATS}"
- doins dindx.dat dtext.dat
+ doins dindx.dat dtext.dat || die "doins failed"
doman "${FILESDIR}/dungeon.6"
dodoc README *.txt *.doc
prepgamesdirs
diff --git a/games-action/dungeon/files/dungeon-3.2.3-makefile.patch b/games-action/dungeon/files/dungeon-3.2.3-makefile.patch
new file mode 100644
index 000000000000..b73bb4323451
--- /dev/null
+++ b/games-action/dungeon/files/dungeon-3.2.3-makefile.patch
@@ -0,0 +1,13 @@
+--- Makefile.orig 2005-03-03 11:12:07.000000000 -0500
++++ Makefile 2005-03-03 11:50:42.000000000 -0500
+@@ -12,9 +12,8 @@
+
+ FC = f2c
+ FFLAGS = -A -C -Nn802 -NL400 #-c
+-CFLAGS = -O
+
+-.f.c:
++%.c: %.f
+ $(FC) $(FFLAGS) $<
+
+ all: dungeon textcnv bin2txt