summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-16 19:42:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-16 19:42:30 +0000
commitf407c81a5a596c152189013ca5abff86e5c073b7 (patch)
treeece4e1fa821f3134a3a2bdcfea89d9aea67c153c /games-action
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-f407c81a5a596c152189013ca5abff86e5c073b7.tar.gz
gentoo-2-f407c81a5a596c152189013ca5abff86e5c073b7.tar.bz2
gentoo-2-f407c81a5a596c152189013ca5abff86e5c073b7.zip
Fix building with recent glibc wrt #331511 by Diego E. Pettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/atanks/ChangeLog6
-rw-r--r--games-action/atanks/atanks-4.6.ebuild7
-rw-r--r--games-action/atanks/files/atanks-4.6-glibc212.patch13
3 files changed, 22 insertions, 4 deletions
diff --git a/games-action/atanks/ChangeLog b/games-action/atanks/ChangeLog
index e72f5c354bd4..0023b3a618d2 100644
--- a/games-action/atanks/ChangeLog
+++ b/games-action/atanks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/atanks
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.54 2010/08/13 14:01:11 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.55 2010/08/16 19:42:30 ssuominen Exp $
+
+ 16 Aug 2010; Samuli Suominen <ssuominen@gentoo.org> atanks-4.6.ebuild,
+ +files/atanks-4.6-glibc212.patch:
+ Fix building with recent glibc wrt #331511 by Diego E. Pettenò.
13 Aug 2010; Joseph Jezak <josejx@gentoo.org> atanks-4.6.ebuild:
Marked ppc stable for bug #327343.
diff --git a/games-action/atanks/atanks-4.6.ebuild b/games-action/atanks/atanks-4.6.ebuild
index 5df488f61a06..5011f2c781be 100644
--- a/games-action/atanks/atanks-4.6.ebuild
+++ b/games-action/atanks/atanks-4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-4.6.ebuild,v 1.4 2010/08/13 14:01:11 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-4.6.ebuild,v 1.5 2010/08/16 19:42:30 ssuominen Exp $
EAPI=2
inherit eutils games
@@ -18,12 +18,13 @@ DEPEND="media-libs/allegro[X]"
src_prepare() {
find . -type f -name ".directory" -exec rm -vf '{}' +
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-glibc212.patch
}
src_compile() {
emake \
- BINDIR="${GAMES_BINDIR}"
+ BINDIR="${GAMES_BINDIR}" \
INSTALLDIR="${GAMES_DATADIR}/${PN}" \
|| die "emake failed"
}
diff --git a/games-action/atanks/files/atanks-4.6-glibc212.patch b/games-action/atanks/files/atanks-4.6-glibc212.patch
new file mode 100644
index 000000000000..8403397355e0
--- /dev/null
+++ b/games-action/atanks/files/atanks-4.6-glibc212.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/331511
+
+--- src/files.cpp
++++ src/files.cpp
+@@ -3,7 +3,7 @@
+ #include <string.h>
+ #include <dirent.h>
+
+-#ifdef MACOSX
++#if defined(MACOSX) || defined(LINUX)
+ #include <sys/stat.h>
+ #endif
+