summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-11-18 13:38:20 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-11-18 13:38:20 +0000
commitff72fdbb81e0357426d585d39df386a6c6557f36 (patch)
tree037dab121707968461e868316ce2d716427e40b4 /games-action
parentMove x11-libs/evas to media-libs/evas (diff)
downloadgentoo-2-ff72fdbb81e0357426d585d39df386a6c6557f36.tar.gz
gentoo-2-ff72fdbb81e0357426d585d39df386a6c6557f36.tar.bz2
gentoo-2-ff72fdbb81e0357426d585d39df386a6c6557f36.zip
Version bump to 0.3.1 Bug #341895
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/violetland/ChangeLog7
-rw-r--r--games-action/violetland/violetland-0.3.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/games-action/violetland/ChangeLog b/games-action/violetland/ChangeLog
index c9c2c8b6fa65..69b4a67696ed 100644
--- a/games-action/violetland/ChangeLog
+++ b/games-action/violetland/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/violetland
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.12 2010/07/10 14:40:07 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.13 2010/11/18 13:38:20 tupone Exp $
+
+*violetland-0.3.1 (18 Nov 2010)
+
+ 18 Nov 2010; Alfredo Tupone <tupone@gentoo.org> +violetland-0.3.1.ebuild:
+ Version bump to 0.3.1 Bug #341895 by Azamat H. Hackimov
10 Jul 2010; Christian Faulhammer <fauli@gentoo.org>
violetland-0.3.0.ebuild:
diff --git a/games-action/violetland/violetland-0.3.1.ebuild b/games-action/violetland/violetland-0.3.1.ebuild
new file mode 100644
index 000000000000..5496d813b222
--- /dev/null
+++ b/games-action/violetland/violetland-0.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.3.1.ebuild,v 1.1 2010/11/18 13:38:20 tupone Exp $
+
+EAPI=2
+inherit eutils cmake-utils games
+
+DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
+HOMEPAGE="http://code.google.com/p/violetland/"
+SRC_URI="http://violetland.googlecode.com/files/${PN}-v${PV}-src.zip"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[audio,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ x11-libs/libXext
+ x11-libs/libSM
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_prepare() {
+ sed -i \
+ -e "/README_EN.TXT/d" \
+ -e "/README_RU.TXT/d" \
+ CMakeLists.txt || die "sed failed"
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DDATA_INSTALL_DIR=${GAMES_DATADIR}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README_EN.TXT CHANGELOG" cmake-utils_src_install
+ newicon icon-light.png ${PN}.png
+ make_desktop_entry ${PN} VioletLand
+ prepgamesdirs
+}