summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-08-29 18:43:08 +0000
committerPacho Ramos <pacho@gentoo.org>2011-08-29 18:43:08 +0000
commit11494bf4025d66408f857040f488965aef5a4d22 (patch)
tree32da94515c71f1ba07348288bdddab9dd908eac3 /games-arcade/blobwars
parentMarked ~x64-macos (diff)
downloadgentoo-2-11494bf4025d66408f857040f488965aef5a4d22.tar.gz
gentoo-2-11494bf4025d66408f857040f488965aef5a4d22.tar.bz2
gentoo-2-11494bf4025d66408f857040f488965aef5a4d22.zip
Initial commit, bug #260843
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/blobwars')
-rw-r--r--games-arcade/blobwars/ChangeLog11
-rw-r--r--games-arcade/blobwars/blobwars-1.19.ebuild71
-rw-r--r--games-arcade/blobwars/files/blobwars-1.19-ldflags.patch22
-rw-r--r--games-arcade/blobwars/files/blobwars-1.19-linking-order.patch36
-rw-r--r--games-arcade/blobwars/metadata.xml9
5 files changed, 149 insertions, 0 deletions
diff --git a/games-arcade/blobwars/ChangeLog b/games-arcade/blobwars/ChangeLog
new file mode 100644
index 000000000000..6ec09b98cbf7
--- /dev/null
+++ b/games-arcade/blobwars/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-arcade/blobwars
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/blobwars/ChangeLog,v 1.40 2011/08/29 18:43:08 pacho Exp $
+
+*blobwars-1.19 (29 Aug 2011)
+
+ 29 Aug 2011; Pacho Ramos <pacho@gentoo.org> +blobwars-1.19.ebuild,
+ +files/blobwars-1.19-ldflags.patch, +files/blobwars-1.19-linking-order.patch,
+ +metadata.xml:
+ Initial commit, bug #260843
+
diff --git a/games-arcade/blobwars/blobwars-1.19.ebuild b/games-arcade/blobwars/blobwars-1.19.ebuild
new file mode 100644
index 000000000000..d5653e968960
--- /dev/null
+++ b/games-arcade/blobwars/blobwars-1.19.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/blobwars/blobwars-1.19.ebuild,v 1.1 2011/08/29 18:43:08 pacho Exp $
+
+EAPI="3"
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Platform game about a blob and his quest to rescue MIAs from an alien invader"
+HOMEPAGE="http://sourceforge.net/projects/blobwars/ https://sourceforge.net/apps/mediawiki/blobwars/index.php?title=Main_Page"
+SRC_URI="mirror://sourceforge/blobwars/${P}.tar.gz"
+
+LICENSE="BSD CCPL-Attribution-ShareAlike-3.0 CCPL-Attribution-3.0 GPL-2 LGPL-2.1 fairuse public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ media-libs/sdl-net
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.19-linking-order.patch"
+ epatch "${FILESDIR}/${PN}-1.19-ldflags.patch"
+ sed -i -e "/-Werror/d" makefile || die
+}
+
+src_compile() {
+ emake \
+ USEPAK="1" \
+ DATADIR="${GAMES_DATADIR}/${PN}/" \
+ DOCDIR="/usr/share/doc/${PF}/html/" \
+ LOCALEDIR="/usr/share/locale/" || die
+}
+
+src_install() {
+ emake \
+ USEPAK="1" \
+ DESTDIR="${D}" \
+ BINDIR="${GAMES_BINDIR}/" \
+ DATADIR="${GAMES_DATADIR}/${PN}/" \
+ DOCDIR="/usr/share/doc/${PF}/html/" \
+ ICONDIR="/usr/share/icons/hicolor/" \
+ DESKTOPDIR="/usr/share/applications/" \
+ LOCALEDIR="/usr/share/locale/" \
+ install || die
+
+ # now make the docs Gentoo friendly.
+ dodoc "${ED}/usr/share/doc/${PF}/html/"{changes,hacking,porting,readme} || die
+ rm -f "${ED}/usr/share/doc/${PF}/html/"{changes,hacking,porting,readme} || die
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-arcade/blobwars/files/blobwars-1.19-ldflags.patch b/games-arcade/blobwars/files/blobwars-1.19-ldflags.patch
new file mode 100644
index 000000000000..8b006f1003a8
--- /dev/null
+++ b/games-arcade/blobwars/files/blobwars-1.19-ldflags.patch
@@ -0,0 +1,22 @@
+--- makefile~ 2011-08-29 20:32:22.000000000 +0200
++++ makefile 2011-08-29 20:33:27.052159159 +0200
+@@ -82,16 +82,16 @@
+
+ # linking the program.
+ $(PROG): $(GAMEOBJS)
+- $(CXX) $(GAMEOBJS) -o $(PROG) $(LIBS)
++ $(CXX) $(LDFLAGS) $(GAMEOBJS) -o $(PROG) $(LIBS)
+
+ pak: $(PAKOBJS)
+- $(CXX) $(PAKOBJS) -o pak $(LIBS)
++ $(CXX) $(LDFLAGS) $(PAKOBJS) -o pak $(LIBS)
+
+ %.mo: %.po
+ msgfmt -c -o $@ $<
+
+ mapeditor: $(MAPOBJS)
+- $(CXX) $(MAPOBJS) -o mapeditor $(LIBS)
++ $(CXX) $(LDFLAGS) $(MAPOBJS) -o mapeditor $(LIBS)
+
+ # cleaning everything that can be automatically recreated with "make".
+ clean:
diff --git a/games-arcade/blobwars/files/blobwars-1.19-linking-order.patch b/games-arcade/blobwars/files/blobwars-1.19-linking-order.patch
new file mode 100644
index 000000000000..6b0010138652
--- /dev/null
+++ b/games-arcade/blobwars/files/blobwars-1.19-linking-order.patch
@@ -0,0 +1,36 @@
+From 896cde549eeb254cc4960f20f54cab845e95b061 Mon Sep 17 00:00:00 2001
+From: Andreas Moog <amoog@ubuntu.com>
+Date: Sun, 19 Jun 2011 22:03:10 +0200
+Subject: [PATCH] LIBS go after objects to allow linking with ld --as-needed
+
+---
+ makefile | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/makefile b/makefile
+index 0a9cc94..509c2ff 100755
+--- a/makefile
++++ b/makefile
+@@ -82,16 +82,16 @@ all: $(ALL)
+
+ # linking the program.
+ $(PROG): $(GAMEOBJS)
+- $(CXX) $(LIBS) $(GAMEOBJS) -o $(PROG)
++ $(CXX) $(GAMEOBJS) -o $(PROG) $(LIBS)
+
+ pak: $(PAKOBJS)
+- $(CXX) $(LIBS) $(PAKOBJS) -o pak
++ $(CXX) $(PAKOBJS) -o pak $(LIBS)
+
+ %.mo: %.po
+ msgfmt -c -o $@ $<
+
+ mapeditor: $(MAPOBJS)
+- $(CXX) $(LIBS) $(MAPOBJS) -o mapeditor
++ $(CXX) $(MAPOBJS) -o mapeditor $(LIBS)
+
+ # cleaning everything that can be automatically recreated with "make".
+ clean:
+--
+1.7.5.4
+
diff --git a/games-arcade/blobwars/metadata.xml b/games-arcade/blobwars/metadata.xml
new file mode 100644
index 000000000000..695258917076
--- /dev/null
+++ b/games-arcade/blobwars/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>pacho@gentoo.org</email>
+ <name>Pacho Ramos</name>
+ </maintainer>
+</pkgmetadata>