summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-05-04 17:21:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-05-04 17:21:38 +0000
commit0cedc383f685fae7a2d8fe3e726f6b533001bdb9 (patch)
tree24780c80d5cba9ba6ca9f34885801f2db4a9708d /games-arcade/frozen-bubble/frozen-bubble-1.0.0-r6.ebuild
parentSync with 2006.0 profile. (diff)
downloadgentoo-2-0cedc383f685fae7a2d8fe3e726f6b533001bdb9.tar.gz
gentoo-2-0cedc383f685fae7a2d8fe3e726f6b533001bdb9.tar.bz2
gentoo-2-0cedc383f685fae7a2d8fe3e726f6b533001bdb9.zip
no need to install .xvpics directory (bug #132227)
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'games-arcade/frozen-bubble/frozen-bubble-1.0.0-r6.ebuild')
-rw-r--r--games-arcade/frozen-bubble/frozen-bubble-1.0.0-r6.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r6.ebuild b/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r6.ebuild
index 59a03238db22..092c3d58617c 100644
--- a/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r6.ebuild
+++ b/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r6.ebuild,v 1.1 2006/03/18 00:39:09 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r6.ebuild,v 1.2 2006/05/04 17:21:38 mr_bones_ Exp $
inherit eutils perl-module games
@@ -27,20 +27,22 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ find . -type d -name .xvpics -print0 | xargs -0 rm -rf #bug #132227
# main package
- epatch "${FILESDIR}"/${P}-makefile.patch
- epatch "${FILESDIR}"/${PV}-no-chainreaction.patch
- epatch "${FILESDIR}"/${P}-{editor-,}sdl-perl-2.patch
+ epatch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${PV}-no-chainreaction.patch \
+ "${FILESDIR}"/${P}-{editor-,}sdl-perl-2.patch
sed -i \
-e 's:INSTALLDIRS=.*:PREFIX=${D}/usr:' \
c_stuff/Makefile \
- || die 'sed c_stuff/Makefile failed'
+ || die 'sed failed'
# server addon
cd "${WORKDIR}"/${NET_SERVER_P}
sed -i \
-e '/^dnl AM_CONFIG_HEADER/s:dnl ::' configure.in \
- || die "sed configure.in failed"
+ || die "sed failed"
libtoolize -c -f || die "libtoolize failed"
env \
WANT_AUTOMAKE=1.4 \