summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-08-23 23:49:21 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-08-23 23:49:21 +0000
commit257d163d175b8b4f3cda80b5e974799c987f572a (patch)
treeb20f81b2236066f78fab078dcdc377dc3970ad7d /games-arcade/gunocide2ex
parentVersion bump. (diff)
downloadgentoo-2-257d163d175b8b4f3cda80b5e974799c987f572a.tar.gz
gentoo-2-257d163d175b8b4f3cda80b5e974799c987f572a.tar.bz2
gentoo-2-257d163d175b8b4f3cda80b5e974799c987f572a.zip
Added gcc4 patch from Mark Loeser <mark@halcy0n.com> and closing bug #131028.
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'games-arcade/gunocide2ex')
-rw-r--r--games-arcade/gunocide2ex/ChangeLog8
-rw-r--r--games-arcade/gunocide2ex/files/1.0-gcc4.patch33
-rw-r--r--games-arcade/gunocide2ex/files/digest-gunocide2ex-1.02
-rw-r--r--games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild10
4 files changed, 46 insertions, 7 deletions
diff --git a/games-arcade/gunocide2ex/ChangeLog b/games-arcade/gunocide2ex/ChangeLog
index c6d0529b7fda..b23130b323e2 100644
--- a/games-arcade/gunocide2ex/ChangeLog
+++ b/games-arcade/gunocide2ex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/gunocide2ex
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/ChangeLog,v 1.7 2005/05/17 17:38:28 wolf31o2 Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/ChangeLog,v 1.8 2006/08/23 23:49:21 wolf31o2 Exp $
+
+ 23 Aug 2006; Chris Gianelloni <wolf31o2@gentoo.org> +files/1.0-gcc4.patch,
+ gunocide2ex-1.0.ebuild:
+ Added gcc4 patch from Mark Loeser <mark@halcy0n.com> and closing bug #131028.
17 May 2005; Chris Gianelloni <wolf31o2@gentoo.org>
gunocide2ex-1.0.ebuild:
diff --git a/games-arcade/gunocide2ex/files/1.0-gcc4.patch b/games-arcade/gunocide2ex/files/1.0-gcc4.patch
new file mode 100644
index 000000000000..04bb3fd1fcd8
--- /dev/null
+++ b/games-arcade/gunocide2ex/files/1.0-gcc4.patch
@@ -0,0 +1,33 @@
+diff -ur work-orig/src/cEffects.cpp work/src/cEffects.cpp
+--- work-orig/src/cEffects.cpp 2006-04-26 22:53:06.000000000 -0400
++++ work/src/cEffects.cpp 2006-04-26 22:52:02.000000000 -0400
+@@ -180,7 +180,6 @@
+ {
+ if(!i->update())
+ i=lEffects.erase(i);
+- if(i==NULL)break;
+ }
+
+ for(p=lParticles.begin();p!=lParticles.end();++p)
+@@ -190,8 +189,6 @@
+ if(!p->active())
+ {
+ p=lParticles.erase(p);
+- if(p==NULL)
+- break;
+ }
+ }
+
+diff -ur work-orig/src/cParticleSys.cpp work/src/cParticleSys.cpp
+--- work-orig/src/cParticleSys.cpp 2006-04-26 22:52:51.000000000 -0400
++++ work/src/cParticleSys.cpp 2006-04-26 22:54:38.000000000 -0400
+@@ -81,9 +81,6 @@
+ if(time-p->getstarttime()>p->getlifetime())
+ {
+ p=lParticles.erase(p);
+- if(p==NULL)
+- break;
+-
+ }
+ }
+
diff --git a/games-arcade/gunocide2ex/files/digest-gunocide2ex-1.0 b/games-arcade/gunocide2ex/files/digest-gunocide2ex-1.0
index 152f53335f8a..a46415ae7b83 100644
--- a/games-arcade/gunocide2ex/files/digest-gunocide2ex-1.0
+++ b/games-arcade/gunocide2ex/files/digest-gunocide2ex-1.0
@@ -1 +1,3 @@
MD5 f247b651937b090b90e6e6dd748e0e36 g2ex-setup.run 30844481
+RMD160 a3d1bfddefd3cdd882a1fb9ab576fd205349de61 g2ex-setup.run 30844481
+SHA256 85cf7ff402b73271e24867c7b0c162b258d61a69065d6a848ea0b74c301a4fbe g2ex-setup.run 30844481
diff --git a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
index a2351c59bfd8..982872847082 100644
--- a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
+++ b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.9 2005/05/17 17:38:28 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.10 2006/08/23 23:49:21 wolf31o2 Exp $
inherit eutils toolchain-funcs games
@@ -16,8 +16,7 @@ IUSE=""
RDEPEND="media-libs/libsdl
media-libs/sdl-ttf
media-libs/sdl-mixer"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+DEPEND="${RDEPEND}"
S="${WORKDIR}"
@@ -26,7 +25,8 @@ src_unpack() {
sed -i "s:-g:${CFLAGS}:" makefile \
|| die "sed makefile failed"
mkdir binary
- epatch ${FILESDIR}/${PV}-gcc3.patch
+ epatch "${FILESDIR}"/${PV}-gcc3.patch
+ epatch "${FILESDIR}"/${PV}-gcc4.patch
edos2unix config.cfg
sed -i \
-e "s:/usr/local/games/gunocide2ex/config\.cfg:${GAMES_SYSCONFDIR}/${PN}.cfg:" \