summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-03 06:13:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-03 06:13:17 +0000
commit7935c808bbb5547f473616f59321ffc827aeea07 (patch)
tree38115e7daa463b9eddf24c2249bb8828a43ad9ba /games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild
parentStable amd64. (Manifest recommit) (diff)
downloadgentoo-2-7935c808bbb5547f473616f59321ffc827aeea07.tar.gz
gentoo-2-7935c808bbb5547f473616f59321ffc827aeea07.tar.bz2
gentoo-2-7935c808bbb5547f473616f59321ffc827aeea07.zip
Fix loading of the sound samples when using sdl-mixer (bug #55932)
Diffstat (limited to 'games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild')
-rw-r--r--games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild b/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild
index 6c3efb870e32..531304ae94ca 100644
--- a/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild
+++ b/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild,v 1.4 2004/06/24 22:11:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild,v 1.5 2004/07/03 06:13:17 mr_bones_ Exp $
-inherit games
+inherit eutils games
DESCRIPTION="Asteroids Clone for X using SDL"
HOMEPAGE="http://david.hedbor.org/projects/sdlroids/"
@@ -13,17 +13,20 @@ SLOT="0"
KEYWORDS="x86 ppc ~amd64"
IUSE=""
-RDEPEND=">=media-libs/libsdl-1.1.8"
+RDEPEND=">=media-libs/libsdl-1.1.8
+ media-libs/sdl-mixer"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
src_unpack() {
unpack ${A}
+ cd "${S}"
sed -i \
-e 's/$(SOUNDSDIR)/$(DESTDIR)$(SOUNDSDIR)/' \
- -e 's/$(GFXDIR)/$(DESTDIR)$(GFXDIR)/' ${S}/Makefile.in \
+ -e 's/$(GFXDIR)/$(DESTDIR)$(GFXDIR)/' Makefile.in \
|| die "sed Makefile.in failed"
+ epatch "${FILESDIR}/${PV}-sound.patch"
}
src_install() {