summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-11-30 19:54:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-11-30 19:54:03 +0000
commit70b5fa261ab1874656a2dbca062de028a226d78b (patch)
treed633a6db91a4a501456faade1070c787c7734bf6 /games-arcade/slimevolley/slimevolley-2.4.2.ebuild
parentDrop mask for no longer existant portage version (diff)
downloadgentoo-2-70b5fa261ab1874656a2dbca062de028a226d78b.tar.gz
gentoo-2-70b5fa261ab1874656a2dbca062de028a226d78b.tar.bz2
gentoo-2-70b5fa261ab1874656a2dbca062de028a226d78b.zip
version bump
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'games-arcade/slimevolley/slimevolley-2.4.2.ebuild')
-rw-r--r--games-arcade/slimevolley/slimevolley-2.4.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-arcade/slimevolley/slimevolley-2.4.2.ebuild b/games-arcade/slimevolley/slimevolley-2.4.2.ebuild
new file mode 100644
index 000000000000..37df02d2fc20
--- /dev/null
+++ b/games-arcade/slimevolley/slimevolley-2.4.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/slimevolley/slimevolley-2.4.2.ebuild,v 1.1 2010/11/30 19:54:03 mr_bones_ Exp $
+
+EAPI=2
+inherit cmake-utils eutils games
+
+DESCRIPTION="A simple volleyball game"
+HOMEPAGE="http://slime.tuxfamily.org/index.php"
+SRC_URI="http://downloads.tuxfamily.org/slime/v242/${PN}_${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="net"
+
+RDEPEND="media-libs/libsdl[X,audio,video]
+ media-libs/sdl-ttf
+ media-libs/sdl-image[png]
+ net? ( media-libs/sdl-net )
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+DOCS="docs/README docs/TODO"
+
+PATCHES=( "${FILESDIR}"/${P}-nodatalocal.patch ) # bug #318005
+
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ mycmakeargs=(
+ "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
+ "-DBIN_DIR=${GAMES_BINDIR}"
+ $(use net && echo "-DNO_NET=0" || echo "-DNO_NET=1")
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}