summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-29 15:49:03 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-29 15:49:03 +0000
commit049d0a20da3f86eb26f7d167cd88b0c8dade85be (patch)
treecc161c214d23bb3cf9233d30a1089919e4e4a45f /games-arcade
parentforgot eclass inherit (diff)
downloadgentoo-2-049d0a20da3f86eb26f7d167cd88b0c8dade85be.tar.gz
gentoo-2-049d0a20da3f86eb26f7d167cd88b0c8dade85be.tar.bz2
gentoo-2-049d0a20da3f86eb26f7d167cd88b0c8dade85be.zip
use unpack_zip from unpacker.eclass instead of unzip
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/aquaria/ChangeLog8
-rw-r--r--games-arcade/aquaria/aquaria-1.1.3.ebuild12
2 files changed, 9 insertions, 11 deletions
diff --git a/games-arcade/aquaria/ChangeLog b/games-arcade/aquaria/ChangeLog
index f37175db1d8c..9d97fd6f186b 100644
--- a/games-arcade/aquaria/ChangeLog
+++ b/games-arcade/aquaria/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/aquaria
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/aquaria/ChangeLog,v 1.3 2010/11/09 15:29:21 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/aquaria/ChangeLog,v 1.4 2013/03/29 15:49:03 hasufell Exp $
+
+ 29 Mar 2013; Julian Ospald <hasufell@gentoo.org> aquaria-1.1.3.ebuild:
+ use unpack_zip from unpacker.eclass instead of unzip
09 Nov 2010; Tupone Alfredo <tupone@gentoo.org> aquaria-1.1.3.ebuild:
Fix using of ${A} in pkg_nofetch. Bug #343179 by Dennis Schridde
@@ -14,4 +17,3 @@
12 May 2010; Mike Frysinger <vapier@gentoo.org> +aquaria-1.1.3.ebuild,
+metadata.xml:
Initial ebuild by James Le Cuirot #319041.
-
diff --git a/games-arcade/aquaria/aquaria-1.1.3.ebuild b/games-arcade/aquaria/aquaria-1.1.3.ebuild
index f070580c05cd..64a168cdd036 100644
--- a/games-arcade/aquaria/aquaria-1.1.3.ebuild
+++ b/games-arcade/aquaria/aquaria-1.1.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/aquaria/aquaria-1.1.3.ebuild,v 1.3 2010/11/09 15:29:21 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/aquaria/aquaria-1.1.3.ebuild,v 1.4 2013/03/29 15:49:03 hasufell Exp $
-inherit eutils games
+inherit unpacker eutils games
DESCRIPTION="A 2D scroller set in a massive ocean world"
HOMEPAGE="http://www.bit-blot.com/aquaria/"
@@ -27,11 +27,7 @@ pkg_nofetch() {
}
src_unpack() {
- # self unpacking zip archive; unzip warns about the exe stuff
- local a="${DISTDIR}/${A}"
- echo ">>> Unpacking ${a} to ${PWD}"
- unzip -q "${a}"
- [ $? -gt 1 ] && die "unpacking failed"
+ unpack_zip ${A}
}
src_install() {