summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-03-01 12:45:36 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-03-01 12:45:36 +0000
commit307f6158d54417d02777b1db50fd398461f274fe (patch)
treeff350eae644c5e30a692c116727eff140954245f /games-arcade
parentVersion bump (diff)
downloadgentoo-2-307f6158d54417d02777b1db50fd398461f274fe.tar.gz
gentoo-2-307f6158d54417d02777b1db50fd398461f274fe.tar.bz2
gentoo-2-307f6158d54417d02777b1db50fd398461f274fe.zip
Version bump to new snapshot.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/opentyrian/ChangeLog8
-rw-r--r--games-arcade/opentyrian/files/20090222-datapath.diff25
-rw-r--r--games-arcade/opentyrian/opentyrian-20090222.ebuild47
3 files changed, 79 insertions, 1 deletions
diff --git a/games-arcade/opentyrian/ChangeLog b/games-arcade/opentyrian/ChangeLog
index 044e06b0bb7d..18da0f0b7fee 100644
--- a/games-arcade/opentyrian/ChangeLog
+++ b/games-arcade/opentyrian/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/opentyrian
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/ChangeLog,v 1.2 2009/01/09 22:16:34 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/ChangeLog,v 1.3 2009/03/01 12:45:36 chainsaw Exp $
+
+*opentyrian-20090222 (01 Mar 2009)
+
+ 01 Mar 2009; <chainsaw@gentoo.org> +files/20090222-datapath.diff,
+ +opentyrian-20090222.ebuild:
+ Version bump to new snapshot.
09 Jan 2009; Joseph Jezak <josejx@gentoo.org> opentyrian-20081211.ebuild:
Marked ~ppc for bug #251579.
diff --git a/games-arcade/opentyrian/files/20090222-datapath.diff b/games-arcade/opentyrian/files/20090222-datapath.diff
new file mode 100644
index 000000000000..6decdf8dd89b
--- /dev/null
+++ b/games-arcade/opentyrian/files/20090222-datapath.diff
@@ -0,0 +1,25 @@
+diff -uNr opentyrian.ORIG/Makefile opentyrian/Makefile
+--- opentyrian.ORIG/Makefile 2009-03-01 12:09:16.000000000 +0000
++++ opentyrian/Makefile 2009-03-01 12:09:55.000000000 +0000
+@@ -51,6 +51,9 @@
+ CFLAGS += -DSVN_REV=\"$(SVN_REV)\"
+ endif
+
++ifneq ($(DATA_PATH), )
++ CFLAGS += -DDATA_PATH=\"$(DATA_PATH)\"
++endif
+ ####################################################
+
+ all : $(TARGET)
+diff -uNr opentyrian.ORIG/src/error.c opentyrian/src/error.c
+--- opentyrian.ORIG/src/error.c 2009-03-01 12:09:16.000000000 +0000
++++ opentyrian/src/error.c 2009-03-01 12:09:55.000000000 +0000
+@@ -37,7 +37,7 @@
+ char err_msg[1000] = "No error!?";
+
+ #ifndef TARGET_MACOSX
+-static const char *tyrian_searchpaths[] = { "data", "tyrian", "tyrian2k" };
++static const char *tyrian_searchpaths[] = { DATA_PATH , "data", "tyrian", "tyrian2k" };
+ #endif
+
+ long get_stream_size( FILE *f )
diff --git a/games-arcade/opentyrian/opentyrian-20090222.ebuild b/games-arcade/opentyrian/opentyrian-20090222.ebuild
new file mode 100644
index 000000000000..2c8da157f15c
--- /dev/null
+++ b/games-arcade/opentyrian/opentyrian-20090222.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/opentyrian-20090222.ebuild,v 1.1 2009/03/01 12:45:36 chainsaw Exp $
+
+inherit eutils games
+
+DESCRIPTION="Open-source port of the DOS game Tyrian, vertical scrolling shooter"
+HOMEPAGE="http://code.google.com/p/opentyrian/"
+SRC_URI="http://darklomax.org/tyrian/tyrian21.zip
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc"
+IUSE="debug"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-net"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/subversion"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-datapath.diff"
+ if ! use debug; then
+ sed -i -e "s@DEBUG := 1@DEBUG := 0@" "${S}/Makefile" || die "sed failed"
+ fi
+}
+
+src_compile() {
+ emake DATA_PATH="${GAMES_DATADIR}/${PN}" || die "Compilation failed"
+}
+
+src_install() {
+ dogamesbin tyrian || die "Failed to install game binary"
+ dodoc CREDITS NEWS README || die "Failed to install documentation"
+ domenu opentyrian.desktop || die "Failed to install desktop file"
+ doicon tyrian.xpm || die "Failed to install program icon"
+ insinto "${GAMES_DATADIR}/${PN}"
+ cd "${WORKDIR}/tyrian21"
+ doins * || die "Failed to install game data"
+ prepgamesdirs
+}