summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-09-14 08:11:24 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-09-14 08:11:24 +0000
commit3aef0dda9ad83ca36d4f6fb7b3ba1caa5aed9e89 (patch)
tree053b978d8a0e721f8621c6115c37f6b33e96de89 /games-arcade
parentAdd PyPI to adns-python homepage. (diff)
downloadgentoo-2-3aef0dda9ad83ca36d4f6fb7b3ba1caa5aed9e89.tar.gz
gentoo-2-3aef0dda9ad83ca36d4f6fb7b3ba1caa5aed9e89.tar.bz2
gentoo-2-3aef0dda9ad83ca36d4f6fb7b3ba1caa5aed9e89.zip
Build with media-libs/libpng-1.5 Bug #380633
(Portage version: 2.1.10.15/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/xbubble/ChangeLog8
-rw-r--r--games-arcade/xbubble/files/xbubble-0.5.8-png15.patch20
-rw-r--r--games-arcade/xbubble/xbubble-0.5.8.ebuild7
3 files changed, 30 insertions, 5 deletions
diff --git a/games-arcade/xbubble/ChangeLog b/games-arcade/xbubble/ChangeLog
index 83a6423554d7..5dddc19c685c 100644
--- a/games-arcade/xbubble/ChangeLog
+++ b/games-arcade/xbubble/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/xbubble
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbubble/ChangeLog,v 1.13 2010/03/09 21:22:50 mr_bones_ Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbubble/ChangeLog,v 1.14 2011/09/14 08:11:24 tupone Exp $
+
+ 14 Sep 2011; Tupone Alfredo <tupone@gentoo.org> xbubble-0.5.8.ebuild,
+ +files/xbubble-0.5.8-png15.patch:
+ Build with media-libs/libpng-1.5 Bug #380633 by Diego Elio Pettenò
09 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org> xbubble-0.5.8.ebuild:
EAPI=2
diff --git a/games-arcade/xbubble/files/xbubble-0.5.8-png15.patch b/games-arcade/xbubble/files/xbubble-0.5.8-png15.patch
new file mode 100644
index 000000000000..3a0a7d360efb
--- /dev/null
+++ b/games-arcade/xbubble/files/xbubble-0.5.8-png15.patch
@@ -0,0 +1,20 @@
+--- src/loadpng.c.old 2011-09-14 09:58:40.503566961 +0200
++++ src/loadpng.c 2011-09-14 10:03:39.708531447 +0200
+@@ -73,7 +73,7 @@
+ return NULL;
+ }
+ /* libpng does a longjmp here when it encounters an error */
+- if ( setjmp( png_ptr->jmpbuf ) ) {
++ if ( setjmp( png_jmpbuf(png_ptr) ) ) {
+ png_destroy_read_struct( &png_ptr, &info_ptr, NULL);
+ fclose(fd);
+ return NULL;
+@@ -95,7 +95,7 @@
+ png_set_gray_to_rgb(png_ptr);
+
+ /* detect alpha layer */
+- if (( info_ptr->color_type & PNG_COLOR_MASK_ALPHA )||
++ if (( png_get_color_type(png_ptr, info_ptr) & PNG_COLOR_MASK_ALPHA )||
+ ( png_get_valid( png_ptr, info_ptr, PNG_INFO_tRNS )))
+ *has_alpha = 1;
+ else
diff --git a/games-arcade/xbubble/xbubble-0.5.8.ebuild b/games-arcade/xbubble/xbubble-0.5.8.ebuild
index ae5794957ae3..fa63fcdcea9c 100644
--- a/games-arcade/xbubble/xbubble-0.5.8.ebuild
+++ b/games-arcade/xbubble/xbubble-0.5.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbubble/xbubble-0.5.8.ebuild,v 1.15 2010/03/09 21:22:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xbubble/xbubble-0.5.8.ebuild,v 1.16 2011/09/14 08:11:24 tupone Exp $
EAPI=2
inherit eutils games
@@ -25,7 +25,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-xpaths.patch \
"${FILESDIR}"/${P}-locale.patch \
- "${FILESDIR}"/${P}-libpng14.patch
+ "${FILESDIR}"/${P}-libpng14.patch \
+ "${FILESDIR}"/${P}-png15.patch
sed -i \
-e '/^AM_CFLAGS/d' \
src/Makefile.in || die "sed cflags"