summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-28 09:21:09 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-28 09:21:09 +0000
commit4753713260484b6506cedf91c00239df8f6de8fc (patch)
tree3711f5fd2a95cc7e188b42816fdc5fa4d285c29a /games-arcade
parentAdd some more bfd checks and fix tls stripping. (diff)
downloadgentoo-2-4753713260484b6506cedf91c00239df8f6de8fc.tar.gz
gentoo-2-4753713260484b6506cedf91c00239df8f6de8fc.tar.bz2
gentoo-2-4753713260484b6506cedf91c00239df8f6de8fc.zip
oggvorbis -> ogg/vorbis #94254
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/pacmanarena/pacmanarena-0.15.ebuild35
1 files changed, 18 insertions, 17 deletions
diff --git a/games-arcade/pacmanarena/pacmanarena-0.15.ebuild b/games-arcade/pacmanarena/pacmanarena-0.15.ebuild
index f6ea3a910b99..08f551e95c7e 100644
--- a/games-arcade/pacmanarena/pacmanarena-0.15.ebuild
+++ b/games-arcade/pacmanarena/pacmanarena-0.15.ebuild
@@ -1,36 +1,35 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/pacmanarena/pacmanarena-0.15.ebuild,v 1.6 2004/06/24 22:09:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pacmanarena/pacmanarena-0.15.ebuild,v 1.7 2005/05/28 09:21:09 vapier Exp $
inherit games
-S="${WORKDIR}/pacman"
DESCRIPTION="a Pacman clone in full 3D with a few surprises. Rockets, bombs and explosions abound."
HOMEPAGE="http://sourceforge.net/projects/pacmanarena/"
SRC_URI="mirror://sourceforge/pacmanarena/pacman-arena-${PV}.tar.bz2
- mirror://sourceforge/pacmanarena/pacman-data-0.0.zip"
+ mirror://sourceforge/pacmanarena/pacman-data-0.0.zip"
-KEYWORDS="x86 ~alpha ~amd64"
LICENSE="GPL-2"
SLOT="0"
-IUSE="oggvorbis"
+KEYWORDS="x86 ~alpha ~amd64"
+IUSE="vorbis"
-RDEPEND="virtual/x11
+DEPEND="virtual/x11
virtual/opengl
>=media-libs/sdl-mixer-1.2.4
>=media-libs/sdl-net-1.2.4
- oggvorbis? ( media-libs/libvorbis )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+ vorbis? ( media-libs/libvorbis )"
+
+S=${WORKDIR}/pacman
src_unpack() {
unpack pacman-arena-${PV}.tar.bz2
- cd ${S}
+ cd "${S}"
unpack pacman-data-0.0.zip
sed -i \
- -e "/^CFLAGS/ s:pacman:${PN}:" Makefile.in \
- || die "sed file.h failed"
+ -e "/^CFLAGS/ s:pacman:${PN}:" \
+ Makefile.in || die "sed file.h failed"
}
src_install() {
@@ -43,8 +42,10 @@ src_install() {
pkg_postinst() {
games_pkg_postinst
- echo
- ewarn "You need oggvorbis in your USE var and sdl components build"
- ewarn "with oggvorbis to have sound."
- echo
+ if ! use vorbis ; then
+ echo
+ ewarn "You need vorbis in your USE var and sdl components build"
+ ewarn "with vorbis to have sound."
+ echo
+ fi
}