summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-05-17 00:42:37 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-05-17 00:42:37 +0000
commit552fbc20aa07b130a330e24e8f38a00a970962fe (patch)
treefd9cfd326c0056c61dc9861e0d040426b6154c06 /games-arcade
parent2.2.0_alpha107 version bump. This includes all of the fixes in 2.1.10.62. (diff)
downloadgentoo-2-552fbc20aa07b130a330e24e8f38a00a970962fe.tar.gz
gentoo-2-552fbc20aa07b130a330e24e8f38a00a970962fe.tar.bz2
gentoo-2-552fbc20aa07b130a330e24e8f38a00a970962fe.zip
respect FHS
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/opensonic/ChangeLog9
-rw-r--r--games-arcade/opensonic/files/opensonic-0.1.4-r1-cmake.patch (renamed from games-arcade/opensonic/files/opensonic-0.1.4-cmake.patch)18
-rw-r--r--games-arcade/opensonic/opensonic-0.1.4-r1.ebuild (renamed from games-arcade/opensonic/opensonic-0.1.4.ebuild)9
3 files changed, 25 insertions, 11 deletions
diff --git a/games-arcade/opensonic/ChangeLog b/games-arcade/opensonic/ChangeLog
index bdbf0a012330..561271480aa4 100644
--- a/games-arcade/opensonic/ChangeLog
+++ b/games-arcade/opensonic/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-arcade/opensonic
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/opensonic/ChangeLog,v 1.2 2012/05/16 18:50:11 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/opensonic/ChangeLog,v 1.3 2012/05/17 00:42:37 hasufell Exp $
+
+*opensonic-0.1.4-r1 (17 May 2012)
+
+ 17 May 2012; Julian Ospald <hasufell@gentoo.org> -opensonic-0.1.4.ebuild,
+ +opensonic-0.1.4-r1.ebuild, -files/opensonic-0.1.4-cmake.patch,
+ +files/opensonic-0.1.4-r1-cmake.patch:
+ respect FHS
16 May 2012; Julian Ospald <hasufell@gentoo.org> opensonic-0.1.4.ebuild:
we want fetch not mirror restrict
diff --git a/games-arcade/opensonic/files/opensonic-0.1.4-cmake.patch b/games-arcade/opensonic/files/opensonic-0.1.4-r1-cmake.patch
index f7ca95f3e358..684685100d86 100644
--- a/games-arcade/opensonic/files/opensonic-0.1.4-cmake.patch
+++ b/games-arcade/opensonic/files/opensonic-0.1.4-r1-cmake.patch
@@ -48,7 +48,7 @@ add rules for icon, desktop-file and game-wrapper
ENDIF(UNIX)
-@@ -407,19 +406,42 @@
+@@ -407,19 +406,43 @@
SET_TARGET_PROPERTIES(${GAME_UNIXNAME} PROPERTIES PROJECT_NAME "${GAME_NAME}")
@@ -59,6 +59,7 @@ add rules for icon, desktop-file and game-wrapper
- SET(GAME_FINAL_DIR "/usr/bin")
+ SET(GAME_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/share/${GAME_UNIXNAME}" CACHE PATH "")
+ SET(GAME_FINAL_DIR "bin" CACHE PATH "")
++ SET(GAME_LIBDIR "games/lib" CACHE PATH "")
+ SET(GAME_DOCDIR "share/doc/${GAME_UNIXNAME}-${GAME_VERSION}" CACHE PATH "")
+ SET(GAME_HTMLDIR "share/doc/${GAME_UNIXNAME}-${GAME_VERSION}/html" CACHE PATH "")
+ SET(GAME_ICONDIR "share/pixmaps" CACHE PATH "")
@@ -66,11 +67,15 @@ add rules for icon, desktop-file and game-wrapper
+
+ FILE(WRITE ${GAME_UNIXNAME}.sh
+"#!/bin/sh
-+cd ${GAME_INSTALL_DIR}
++cd ${GAME_LIBDIR}
+exec ./${GAME_UNIXNAME} \"$@\"
+"
+)
-+
+
+- INSTALL(CODE "MESSAGE(\"Installing ${GAME_NAME} ${GAME_VERSION}... Make sure you have root privileges.\")")
+- INSTALL(TARGETS ${GAME_UNIXNAME} RUNTIME DESTINATION ${GAME_INSTALL_DIR})
+- INSTALL(FILES license.txt readme.html DESTINATION ${GAME_INSTALL_DIR})
+- INSTALL(DIRECTORY objects sprites config images levels licenses musics quests samples screenshots themes languages DESTINATION ${GAME_INSTALL_DIR} PATTERN ".svn" EXCLUDE)
+ FILE(WRITE ${GAME_UNIXNAME}.desktop
+"[Desktop Entry]
+Name=${GAME_NAME}
@@ -83,13 +88,10 @@ add rules for icon, desktop-file and game-wrapper
+"
+)
- INSTALL(CODE "MESSAGE(\"Installing ${GAME_NAME} ${GAME_VERSION}... Make sure you have root privileges.\")")
- INSTALL(TARGETS ${GAME_UNIXNAME} RUNTIME DESTINATION ${GAME_INSTALL_DIR})
-- INSTALL(FILES license.txt readme.html DESTINATION ${GAME_INSTALL_DIR})
-- INSTALL(DIRECTORY objects sprites config images levels licenses musics quests samples screenshots themes languages DESTINATION ${GAME_INSTALL_DIR} PATTERN ".svn" EXCLUDE)
--
- INSTALL(CODE "MESSAGE(\"Creating files at ${GAME_FINAL_DIR}...\")")
- INSTALL(CODE "EXECUTE_PROCESS(COMMAND \"cmake\" \"-E\" \"copy\" \"${GAME_INSTALL_DIR}/${GAME_UNIXNAME}\" \"${GAME_FINAL_DIR}/${GAME_UNIXNAME}\")")
++ INSTALL(CODE "MESSAGE(\"Installing ${GAME_NAME} ${GAME_VERSION}... Make sure you have root privileges.\")")
++ INSTALL(TARGETS ${GAME_UNIXNAME} RUNTIME DESTINATION ${GAME_LIBDIR})
+# INSTALL(FILES license.txt DESTINATION ${GAME_DOCDIR})
+ INSTALL(FILES readme.html DESTINATION ${GAME_HTMLDIR})
+ INSTALL(FILES icon.png DESTINATION ${GAME_ICONDIR} RENAME ${GAME_UNIXNAME}.png)
diff --git a/games-arcade/opensonic/opensonic-0.1.4.ebuild b/games-arcade/opensonic/opensonic-0.1.4-r1.ebuild
index 6e96c0801288..ee301963934e 100644
--- a/games-arcade/opensonic/opensonic-0.1.4.ebuild
+++ b/games-arcade/opensonic/opensonic-0.1.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/opensonic/opensonic-0.1.4.ebuild,v 1.2 2012/05/16 18:50:11 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/opensonic/opensonic-0.1.4-r1.ebuild,v 1.1 2012/05/17 00:42:37 hasufell Exp $
EAPI=3
@@ -36,13 +36,14 @@ pkg_nofetch() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-cmake.patch
+ epatch "${FILESDIR}"/${PF}-cmake.patch
}
src_configure() {
local mycmakeargs=(
-DGAME_INSTALL_DIR="${GAMES_DATADIR}"/${PN}
-DGAME_FINAL_DIR="${GAMES_BINDIR}"
+ -DGAME_LIBDIR="$(games_get_libdir)/${PN}"
)
cmake-utils_src_configure
@@ -50,5 +51,9 @@ src_configure() {
src_install() {
cmake-utils_src_install
+ for i in $(ls "${D}${GAMES_DATADIR}/${PN}") ; do
+ dosym "${GAMES_DATADIR}/${PN}/${i}" \
+ "$(games_get_libdir)/${PN}/${i}" || die
+ done
prepgamesdirs
}