summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-05-01 07:02:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-05-01 07:02:31 +0000
commit61a30f79a5a265b190f66a7bc5800db9e086c247 (patch)
tree193c9020318722cdf4d1e5d261ec13f6e5073939 /games-arcade
parentupdated SRC_URI in older ebuild versions (closes bug 130709) (diff)
downloadgentoo-2-61a30f79a5a265b190f66a7bc5800db9e086c247.tar.gz
gentoo-2-61a30f79a5a265b190f66a7bc5800db9e086c247.tar.bz2
gentoo-2-61a30f79a5a265b190f66a7bc5800db9e086c247.zip
patch for -Wl,--as-needed submitted by TGL via bug #131840
(Portage version: 2.1_pre10)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/monkey-bubble/ChangeLog6
-rw-r--r--games-arcade/monkey-bubble/files/monkey-bubble-0.3.2-asneeded.patch30
-rw-r--r--games-arcade/monkey-bubble/monkey-bubble-0.3.2.ebuild14
3 files changed, 44 insertions, 6 deletions
diff --git a/games-arcade/monkey-bubble/ChangeLog b/games-arcade/monkey-bubble/ChangeLog
index 7b9c7425f9c9..20419ed1b76b 100644
--- a/games-arcade/monkey-bubble/ChangeLog
+++ b/games-arcade/monkey-bubble/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/monkey-bubble
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/monkey-bubble/ChangeLog,v 1.20 2006/04/24 12:33:10 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/monkey-bubble/ChangeLog,v 1.21 2006/05/01 07:02:31 mr_bones_ Exp $
+
+ 01 May 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/monkey-bubble-0.3.2-asneeded.patch, monkey-bubble-0.3.2.ebuild:
+ patch for -Wl,--as-needed submitted by TGL via bug #131840
24 Apr 2006; <Tupone@gentoo.org> monkey-bubble-0.3.2.ebuild:
Fix for gcc-4.1 removing the -Werror flag
diff --git a/games-arcade/monkey-bubble/files/monkey-bubble-0.3.2-asneeded.patch b/games-arcade/monkey-bubble/files/monkey-bubble-0.3.2-asneeded.patch
new file mode 100644
index 000000000000..7bccffd385f4
--- /dev/null
+++ b/games-arcade/monkey-bubble/files/monkey-bubble-0.3.2-asneeded.patch
@@ -0,0 +1,30 @@
+--- monkey-bubble-0.3.2/src/net/Makefile.am.orig 2006-04-30 17:29:36.000000000 +0200
++++ monkey-bubble-0.3.2/src/net/Makefile.am 2006-04-30 17:30:00.000000000 +0200
+@@ -28,10 +28,10 @@
+ monkey_srv_LDFLAGS =
+
+ monkey_srv_LDADD = \
+- $(MONKEY_SRV_LIBS) \
+ libmonkeynet.a \
+ ../monkey/libmonkey.a \
+- ../util/libmonkeyutil.a
++ ../util/libmonkeyutil.a \
++ $(MONKEY_SRV_LIBS)
+
+ $(libmonkeynet_a_OBJECTS): $(marshal_sources)
+
+--- monkey-bubble-0.3.2/src/ui/Makefile.am.orig 2006-04-30 17:41:27.000000000 +0200
++++ monkey-bubble-0.3.2/src/ui/Makefile.am 2006-04-30 17:41:52.000000000 +0200
+@@ -50,10 +50,10 @@
+
+
+ monkey_bubble_LDADD = \
+- $(UI_LIBS) \
+ ../monkey/libmonkey.a \
+ ../view/libmonkeyview.a \
+ ../util/libmonkeyutil.a \
+ ../net/libmonkeynet.a \
+ ../audio/libmonkeyaudio.a \
+- ../input/libmbinput.a
++ ../input/libmbinput.a \
++ $(UI_LIBS)
diff --git a/games-arcade/monkey-bubble/monkey-bubble-0.3.2.ebuild b/games-arcade/monkey-bubble/monkey-bubble-0.3.2.ebuild
index 2b3be2d993da..2178a1a5ee9d 100644
--- a/games-arcade/monkey-bubble/monkey-bubble-0.3.2.ebuild
+++ b/games-arcade/monkey-bubble/monkey-bubble-0.3.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/monkey-bubble/monkey-bubble-0.3.2.ebuild,v 1.11 2006/04/24 12:33:10 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/monkey-bubble/monkey-bubble-0.3.2.ebuild,v 1.12 2006/05/01 07:02:31 mr_bones_ Exp $
-inherit eutils gnome2
+inherit autotools eutils gnome2
DESCRIPTION="A Puzzle Bobble clone"
HOMEPAGE="http://home.gna.org/monkeybubble/"
@@ -10,7 +10,7 @@ SRC_URI="http://home.gna.org/monkeybubble/downloads/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc sparc ~amd64"
+KEYWORDS="~amd64 ~ppc sparc x86"
IUSE=""
DEPEND=">=x11-libs/gtk+-2.0
@@ -27,7 +27,10 @@ DEPEND=">=x11-libs/gtk+-2.0
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}.amd64.patch"
+ epatch \
+ "${FILESDIR}/${P}.amd64.patch" \
+ "${FILESDIR}/${P}-asneeded.patch"
+ eautoreconf
sed -i \
-e "s:-Werror::" \
src/util/Makefile.in \
@@ -37,5 +40,6 @@ src_unpack() {
src/audio/Makefile.in \
src/net/Makefile.in \
src/net/Makefile.in \
- src/ui/Makefile.in
+ src/ui/Makefile.in \
+ || die "sed failed"
}