summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-29 08:21:52 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-29 08:21:52 +0000
commit9694060b4c409531948060f4a7dbd7a753e713d7 (patch)
tree690cd981d9f9928c15cd236f2d0bfcbe4b84a357 /games-arcade
parentVersion bump, fixes security bug #342705 thank Tim Sammut for report. (diff)
downloadgentoo-2-9694060b4c409531948060f4a7dbd7a753e713d7.tar.gz
gentoo-2-9694060b4c409531948060f4a7dbd7a753e713d7.tar.bz2
gentoo-2-9694060b4c409531948060f4a7dbd7a753e713d7.zip
Fix overflow. Bug #340166
(Portage version: 2.1.9.22/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/spacerider/ChangeLog6
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch11
-rw-r--r--games-arcade/spacerider/spacerider-0.13.ebuild8
3 files changed, 21 insertions, 4 deletions
diff --git a/games-arcade/spacerider/ChangeLog b/games-arcade/spacerider/ChangeLog
index dea2d55ca582..6e70cbc3920f 100644
--- a/games-arcade/spacerider/ChangeLog
+++ b/games-arcade/spacerider/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/spacerider
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/ChangeLog,v 1.6 2010/01/05 02:35:58 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/ChangeLog,v 1.7 2010/10/29 08:21:52 tupone Exp $
+
+ 29 Oct 2010; Tupone Alfredo <tupone@gentoo.org> spacerider-0.13.ebuild,
+ +files/spacerider-0.13-ovflfix.patch:
+ Fix overflow. Bug #340166 by flameeyes@gentoo.org
05 Jan 2010; Joseph Jezak <josejx@gentoo.org> spacerider-0.13.ebuild:
Marked ~ppc for bug #293677.
diff --git a/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch b/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch
new file mode 100644
index 000000000000..5ed73c348cf2
--- /dev/null
+++ b/games-arcade/spacerider/files/spacerider-0.13-ovflfix.patch
@@ -0,0 +1,11 @@
+--- spacerider.cpp.old 2010-10-29 10:12:19.000000000 +0200
++++ spacerider.cpp 2010-10-29 10:13:47.000000000 +0200
+@@ -112,7 +112,7 @@
+ break;
+ case 'n':
+ /* specify a name for the online-highscore */
+- strncpy(name, optarg, 128);
++ strncpy(name, optarg, sizeof (name));
+ online_highscore = true;
+ break;
+ case 't':
diff --git a/games-arcade/spacerider/spacerider-0.13.ebuild b/games-arcade/spacerider/spacerider-0.13.ebuild
index e5e2c8afac1a..45df57b53156 100644
--- a/games-arcade/spacerider/spacerider-0.13.ebuild
+++ b/games-arcade/spacerider/spacerider-0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/spacerider-0.13.ebuild,v 1.7 2010/01/05 02:35:58 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/spacerider-0.13.ebuild,v 1.8 2010/10/29 08:21:52 tupone Exp $
EAPI=2
inherit eutils games
@@ -14,15 +14,17 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
-DEPEND="media-libs/sdl-gfx
+RDEPEND="media-libs/sdl-gfx
media-libs/sdl-mixer
media-libs/sdl-image[jpeg]
media-libs/sdl-net
media-libs/sdl-ttf"
+DEPEND="${RDEPEND}"
src_prepare() {
epatch "${FILESDIR}/${P}"-gentoo.patch \
- "${FILESDIR}/${P}"-gcc41.patch
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}"/${P}-ovflfix.patch
sed -i \
-e "s:/usr/share/games/spacerider:${GAMES_DATADIR}/${PN}:" \
globals.cpp \