summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-04-14 17:57:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-04-14 17:57:28 +0000
commitc39d6e56c83e4f0c25b18ab0bf8e51e23d956def (patch)
tree609db88741beb093a769e051e4327ca9d6c7abae /games-arcade
parentNew ebuild from nesyx, closes #79313 (diff)
downloadgentoo-2-c39d6e56c83e4f0c25b18ab0bf8e51e23d956def.tar.gz
gentoo-2-c39d6e56c83e4f0c25b18ab0bf8e51e23d956def.tar.bz2
gentoo-2-c39d6e56c83e4f0c25b18ab0bf8e51e23d956def.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/sdlsasteroids/ChangeLog10
-rw-r--r--games-arcade/sdlsasteroids/Manifest6
-rw-r--r--games-arcade/sdlsasteroids/files/digest-sdlsasteroids-3.0.11
-rw-r--r--games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild50
4 files changed, 63 insertions, 4 deletions
diff --git a/games-arcade/sdlsasteroids/ChangeLog b/games-arcade/sdlsasteroids/ChangeLog
index 1539e923ec60..70c0a2d2a7cc 100644
--- a/games-arcade/sdlsasteroids/ChangeLog
+++ b/games-arcade/sdlsasteroids/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/sdlsasteroids
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/ChangeLog,v 1.4 2004/08/30 13:15:03 dholm Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/ChangeLog,v 1.5 2005/04/14 17:57:28 mr_bones_ Exp $
+
+*sdlsasteroids-3.0.1 (14 Apr 2005)
+
+ 14 Apr 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +sdlsasteroids-3.0.1.ebuild:
+ version bump
30 Aug 2004; David Holm <dholm@gentoo.org> sdlsasteroids-3.0.ebuild:
Added to ~ppc.
diff --git a/games-arcade/sdlsasteroids/Manifest b/games-arcade/sdlsasteroids/Manifest
index a402d027dd8c..29e0442dc712 100644
--- a/games-arcade/sdlsasteroids/Manifest
+++ b/games-arcade/sdlsasteroids/Manifest
@@ -1,4 +1,6 @@
-MD5 942a3b3335d218919315f77a0599fea8 ChangeLog 865
-MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 2b26f4ec9444d9667e324b56fe49b1f9 sdlsasteroids-3.0.ebuild 1188
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 8f3e4be8d15b09c3ced3a24bd8d6903a sdlsasteroids-3.0.1.ebuild 1149
+MD5 942a3b3335d218919315f77a0599fea8 ChangeLog 865
MD5 10d43bd02238bad6d222f9cf78e78b08 files/digest-sdlsasteroids-3.0 66
+MD5 c86a258d418bf42aab1af60f31635fb1 files/digest-sdlsasteroids-3.0.1 71
diff --git a/games-arcade/sdlsasteroids/files/digest-sdlsasteroids-3.0.1 b/games-arcade/sdlsasteroids/files/digest-sdlsasteroids-3.0.1
new file mode 100644
index 000000000000..1036c557134e
--- /dev/null
+++ b/games-arcade/sdlsasteroids/files/digest-sdlsasteroids-3.0.1
@@ -0,0 +1 @@
+MD5 511d1ab59a2688bd618522c025a1f33b SDLSasteroids-3.0.1.tar.gz 531781
diff --git a/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
new file mode 100644
index 000000000000..3748de3ebec4
--- /dev/null
+++ b/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlsasteroids/sdlsasteroids-3.0.1.ebuild,v 1.1 2005/04/14 17:57:28 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Rework of Sasteroids using SDL"
+HOMEPAGE="http://sdlsas.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sdlsas/SDLSasteroids-${PV}.tar.gz"
+
+LICENSE="GPL-2 freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ virtual/opengl
+ >=media-libs/sdl-mixer-1.2.0
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+
+S=${WORKDIR}/SDLSasteroids-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #-e '34 d' \
+ sed -i \
+ -e 's/make /$(MAKE) /' Makefile \
+ || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake \
+ GAMEDIR="${GAMES_DATADIR}/${PN}" \
+ OPTS="${CXXFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/share/man/man6/
+ make \
+ GAMEDIR="${D}/${GAMES_DATADIR}/${PN}" \
+ BINDIR="${D}/${GAMES_BINDIR}" \
+ MANDIR="${D}/usr/share/man/" \
+ install || die "make install failed"
+ dodoc ChangeLog README README.xast TODO description
+ prepgamesdirs
+}