summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-01 05:11:31 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-01 05:11:31 +0000
commited64b72fdd400275d3dabfc85f793166f0f310c6 (patch)
tree2a9dc151568f34c790a509bbf51c51fc6e31a46a /games-arcade
parentRespect LDFLAGS. Bug #337347 (diff)
downloadgentoo-2-ed64b72fdd400275d3dabfc85f793166f0f310c6.tar.gz
gentoo-2-ed64b72fdd400275d3dabfc85f793166f0f310c6.tar.bz2
gentoo-2-ed64b72fdd400275d3dabfc85f793166f0f310c6.zip
Respect LDFLAGS. Bug #337332
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/xjump/ChangeLog8
-rw-r--r--games-arcade/xjump/files/xjump-2.7.5-ldflags.patch11
-rw-r--r--games-arcade/xjump/xjump-2.7.5.ebuild24
3 files changed, 26 insertions, 17 deletions
diff --git a/games-arcade/xjump/ChangeLog b/games-arcade/xjump/ChangeLog
index 11f3ac0efde0..86e7d253a337 100644
--- a/games-arcade/xjump/ChangeLog
+++ b/games-arcade/xjump/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/xjump
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xjump/ChangeLog,v 1.9 2007/04/24 15:22:49 drizzt Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xjump/ChangeLog,v 1.10 2010/10/01 05:11:31 tupone Exp $
+
+ 01 Oct 2010; Tupone Alfredo <tupone@gentoo.org> xjump-2.7.5.ebuild,
+ +files/xjump-2.7.5-ldflags.patch:
+ Respect LDFLAGS. Bug #337332 by flameeyes@gentoo.org
24 Apr 2007; Timothy Redaelli <drizzt@gentoo.org> xjump-2.7.5.ebuild:
Add ~x86-fbsd keyword.
diff --git a/games-arcade/xjump/files/xjump-2.7.5-ldflags.patch b/games-arcade/xjump/files/xjump-2.7.5-ldflags.patch
new file mode 100644
index 000000000000..a30736811318
--- /dev/null
+++ b/games-arcade/xjump/files/xjump-2.7.5-ldflags.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2010-10-01 07:05:03.000000000 +0200
++++ Makefile 2010-10-01 07:05:39.000000000 +0200
+@@ -28,7 +28,7 @@
+ ##########################################################
+
+ xjump : main.o game.o key.o misc.o record.o resource.o
+- $(CC) $(CFLAGS) -o xjump \
++ $(CC) $(LDFLAGS) $(CFLAGS) -o xjump \
+ main.o game.o key.o misc.o record.o resource.o\
+ -lXaw -lXmu -lXt -lXpm -lXext -lX11 $(LDIR)
+
diff --git a/games-arcade/xjump/xjump-2.7.5.ebuild b/games-arcade/xjump/xjump-2.7.5.ebuild
index e8d32c9cea10..a9d99562ef1e 100644
--- a/games-arcade/xjump/xjump-2.7.5.ebuild
+++ b/games-arcade/xjump/xjump-2.7.5.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xjump/xjump-2.7.5.ebuild,v 1.10 2007/04/24 15:22:49 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xjump/xjump-2.7.5.ebuild,v 1.11 2010/10/01 05:11:31 tupone Exp $
+EAPI="2"
inherit eutils games
@@ -15,31 +16,24 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
IUSE=""
-DEPEND="x11-libs/libX11
- x11-libs/libXaw
- x11-libs/libXpm
- x11-libs/libXt
- x11-proto/xproto"
-
RDEPEND="x11-libs/libX11
x11-libs/libXaw
- x11-libs/libXext
- x11-libs/libXmu
x11-libs/libXpm
x11-libs/libXt"
-S=${WORKDIR}/${P}.orig
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+S=${WORKDIR}/${P}.orig
+src_prepare() {
# Where we will keep the highscore file:
HISCORE_FILENAME=xjump.hiscores
HISCORE_FILE="${GAMES_STATEDIR}/${HISCORE_FILENAME}"
epatch "${WORKDIR}/${PN}_${PV}-${DEBIAN_PATCH}.diff"
- epatch "${S}/debian/patches/"*.dpatch
+ epatch "${S}/debian/patches/"*.dpatch \
+ "${FILESDIR}"/${P}-ldflags.patch
# set up where we will keep the highscores file:
sed -i \